Saigonrice Dec 28, 2013 @ 9:22am
Forced to restart game every time I enter the sound options menu?
Every time I try to exit the sound options menu in the game I get told that in order to change the game language I have to restart the game, which makes little sense. I can either cancel and return to the sound options menu or restart.

In other words, once I've opened the sound options meny I will eventually have to restart the game which you can imagine is really annoying.

Why does this happen, and how can I prevent it?

Also, the game language was automatically installed to swedish (my native language). I believe that has something to do with it.
Showing 1-5 of 5 comments
< >
Dingerdonger Jul 18 @ 3:19am 
Jag har Left 4 Dead 2 på svenska och jag har exact samma problem
sniperninjamonkey Jul 23 @ 9:50am 
I got it to stop restarting by right clicking l4d2, chose properties and in the properties menu selected the language tab. In the language tab change whatever language you have set up to english.
Last edited by sniperninjamonkey; Jul 23 @ 9:51am
Originally posted by sniperninjamonkey:
I got it to stop restarting by right clicking l4d2, chose properties and in the properties menu selected the language tab. In the language tab change whatever language you have set up to english.

Well, that is of course not a very good solution, if one wishes to have some other localisation. Why isn't this sort of bug fixed aeons ago; remember having the same one years ago, and it still presists.

Is there for example an ini file where I could chenge the default language, so that the settings wouldn't want to change them? It there a permanent fix, since there isn't a very good interface to mute players that just create inaudible noise, but you have to mute all the VOIP from the audio menu, causing you to be exited from the game.

[EDIT]: Okay, it seems that changing the language to English from the launch preferences does not change the language, that I feel is in a way even more flawed. "English" seems to stand for "Steam default language", that is unfortunate in case where one would prefer the language for Steam, but would not be happy with the translation in the game, making such person incapable of explicitly cahnging the language for this exact game to english.
Last edited by Sir.Hyrrämyyrä[NoobieDoobie]; Aug 20 @ 6:57pm
yogurt break Aug 20 @ 9:29pm 
Originally posted by Sir.HyrrämyyräNoobieDoobie:

[EDIT]: Okay, it seems that changing the language to English from the launch preferences does not change the language, that I feel is in a way even more flawed. "English" seems to stand for "Steam default language", that is unfortunate in case where one would prefer the language for Steam, but would not be happy with the translation in the game, making such person incapable of explicitly cahnging the language for this exact game to english.

Can't replicate your issue, have you tried with any other language? Maybe its sound card related.
Last edited by yogurt break; Aug 20 @ 9:29pm
Originally posted by yogurt break:
Originally posted by Sir.HyrrämyyräNoobieDoobie:

[EDIT]: Okay, it seems that changing the language to English from the launch preferences does not change the language, that I feel is in a way even more flawed. "English" seems to stand for "Steam default language", that is unfortunate in case where one would prefer the language for Steam, but would not be happy with the translation in the game, making such person incapable of explicitly cahnging the language for this exact game to english.

Can't replicate your issue, have you tried with any other language? Maybe its sound card related.



Well, the issue seems to be if you have other language than english as your Steam UI language. Either on default Left 4 Dead 2 then chooses from the launch options your language to be the said language, or very early age of L4D2 the pre launch setting worked properly. Either way, if the default language of Steam is not english, and the language option of the game is that said language (do not know if this presist if the chosen language and Steam UI language is different. Most likely not), the in game audio settings does not allow you to leave the menu because it thinks you want to change the language of the game, that requires restart. An easy shortcut for this problem is to allow the player choose "keep the current language", rather than just giving an option to "OK" or "Cancel", where the first shuts the game, and the last just closes the prompt.

Never the less, it seems that the "English" language option of the game is not actually English localization for the game, but rather "Default Steam language" -option. Meaning that if you have set Steam UI, by default, on other language, there is no way to play teh game in english without changing the Steam UI language. Perhaps this is also the cause for the problem:
If the chosel language is the Steam UI language, the language is not checked on startup, but is set to "Default", that being "Steam UI language" in reality, but "English" (the first entry in the language array) as in listed languages. When then the audio settings are being exited, and the changes (which there is not for language in that said meny, btw) are being applied, it checks if the language chosen is different from the current language, and requires a restart to apply with no way to exit the said menu. On this case therefore, as the chosen language is the Steam UI language, the language is default (0 of the array), but the chosen language is not default, as it is the language that is in actuality the Steam UI language (ergo not 0 of the array), the chages must be applied by restarting, and as the menu itself holds no option to control the language, the language can not be set to default in that menu, causing the exiting of said menu to be impossible.

That all said, it also may be that the language option applies to the dub (localized audio track) of the game, but since not all languages have been dubbed (thank god... although that might be fun to do actually), the audio settings do not display the option to change the spoken language, but still think it's changed because the language in general is set to a different from English, that is the default audio track language. That said, this problem can easily be solved by allowing people to choose a different dub between their localization and the default audio track, and having that said option to exist even if your chosen language is not one that is dubbed. Simple as that.

So in short, to replicate this isuue you probably need to:
-Change your UI language to something that L4D2 does not have audio track for.
-Change the language of L4D2 in the game pre-launch settings to said language
-Enter the audio menu
-Notice the missing option, and incapability to exit the said menu without a restart (fairly annoying in midst of random online game, to be fair)

Also, while we're at it: An option to mute the VOIP of one single person on the server would pe an awesome thing to have. (something that most games actually have, and what improves the gameplay experience vastly, without having to kick the said player).
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Dec 28, 2013 @ 9:22am
Posts: 5