Derezzedj4ck Apr 10 @ 11:01am
Weapon animations are way to close to the screen! | Looking for help!
Recently I purchased a new monitor with a 21:9 aspect ratio.
When I went through all my currently installed games to change the settings and check if they would even support that aspect ratio, I noticed that the player animations for weapons are really close to the screen.
While the standard animations aren't that far away normally, thi still seems really wrong.

Screenshot 16:9[www.dropbox.com]

Screenshot 21:9[www.dropbox.com]

I tried changing the viewmodel_fov amount, but that didn't change anything, which it normally would (and yes, I had sv_cheats on 1).
Now I've reinstalled the game and it's still there and it is getting really annoying.

How do I reset this to normal? Could it be that some workshop item is messing with my animations?
Last edited by Derezzedj4ck; Apr 10 @ 11:02am
Showing 1-5 of 5 comments
< >
It's probably your addons. Or you messed up something in console.
You should set view angle in console to fix it back.

There is also workshop items with normal animation but not that close to the screen,search it up.
Fridge LargeMeat Apr 10 @ 12:18pm 
You want cl_viewmodelfov. 50-ish is default, higher will move the gun further away from your screen.
Last edited by Fridge LargeMeat; Apr 10 @ 12:18pm
dave Apr 10 @ 12:53pm 
I believe the L4D2 setting you are looking for is:

cl_viewmodelfovsurvivor <number> // Sets how "zoomed in" the weapon/arms view is. (Default: 51.)

Note that this *only* changes the presentation of the arms/hands/weapon. It does not change the actual Field of View (FOV). I have used values of anywhere between 51 up to 100. Some "clipping" of animations will occur at about 70 and above.
Derezzedj4ck Apr 10 @ 2:10pm 
Originally posted by dave:
I believe the L4D2 setting you are looking for is:

cl_viewmodelfovsurvivor <number> // Sets how "zoomed in" the weapon/arms view is. (Default: 51.)

Note that this *only* changes the presentation of the arms/hands/weapon. It does not change the actual Field of View (FOV). I have used values of anywhere between 51 up to 100. Some "clipping" of animations will occur at about 70 and above.

This was exactly what I was looking for. I should probably write that down somewhere, since I've used this command before but forgot about it.
Thanks!

This is solved then!
dave Apr 10 @ 3:34pm 
No probs, glad I could help.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Apr 10 @ 11:01am
Posts: 5