Buttshot Mar 24 @ 10:08pm
HELP !! the game doesn't launch !!!
When I press PLAY, it writes "Preapering to launch" but nothing happens. Please help I tried a lot of things, I restarted my computer, steam, and downloaded the game again, and verified the game cache 3 times in a row and nothing helps.

PLEASE HELP !!!!
Showing 1-8 of 8 comments
< >
battle2525 Mar 24 @ 10:14pm 
disable your antivirus
Buttshot Mar 25 @ 11:20am 
Originally posted by battle2525:
disable your antivirus
I tried it. I have Norton 360 and before it I didn't have it maybe I need to uninsall it.
CarsonUK Mar 25 @ 11:25am 
full on secruity suites like Norton Security will interfer with games like that
battle2525 Mar 25 @ 11:27am 
If you have a way to reinstall your antivirus, try uninstalling norton and test if the game runs.

https://support.steampowered.com/kb_article.php?ref=9828-SFLZ-9289
TheMasterBlaster™ Mar 25 @ 12:07pm 
I have Norton 360 and it works fine with L4D2.
I would suggest you delete local content of L4D2. Then manually delete the Left 4 Dead 2 directory. Restart Steam, re-install.
Ресс Шептун Mar 25 @ 12:23pm 
Originally posted by Bo0mButt5hot:
When I press PLAY, it writes "Preapering to launch" but nothing happens. Please help I tried a lot of things, I restarted my computer, steam, and downloaded the game again, and verified the game cache 3 times in a row and nothing helps.

PLEASE HELP !!!!
how much RAM you have?
iGh0st3y™ Mar 25 @ 1:24pm 
I have the best Advice read very slowly: T h r o w, y o u r, c o m p u t e r, o u t, o f, y o u r, w i n d o w! And Norton Sucks!
Last edited by iGh0st3y™; Mar 25 @ 1:25pm
Buttshot Mar 25 @ 9:56pm 
Originally posted by TheMasterBlaster™:
I have Norton 360 and it works fine with L4D2.
I would suggest you delete local content of L4D2. Then manually delete the Left 4 Dead 2 directory. Restart Steam, re-install.
Already tried it.
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Mar 24 @ 10:08pm
Posts: 8