Left 4 Dead 2 > Γενικές συζητήσεις > Λεπτομέρειες θέματος
XingHua31 6 Μαρ, 2014 @ 12:07πμ
Bad stuttering on Ubuntu 12.04.4 with AMD Radeon 7850? :/
Trying to play this on Ubuntu as I'm having a major issue with Windows 7 and my PC (there's nothing wrong with my PC JSYK, it's an activation issue because I was sold an OEM version of Windows 7 instead of a retail one..). Anyway, on Windows 7 I get a super smooth 60 FPS with the game maxed, on Ubuntu it stutters like a ♥♥♥♥♥ on the lowest and highest settings. It kinda keeps dropping the FPS majorly every 3/4 seconds, and is completely unplayable. Any idea how to fix it? :/

My PC specs;
AMD A8 5500 APU @ 3.3Ghz (3.7Ghz boost)
MSI FM2-A55M-E33 Motherboard
Kingston HyperX 4Gb 1600Mhz DDR3 RAM
XFX Radeon 7850 DD 2Gb GDDR5
Evo Labs Cronus 550W 80+ Modular PSU
Zalman ZM-T4 Mini Tower Case
Ubuntu 12.04.4 LTS x64
Τελευταία επεξεργασία από XingHua31; 6 Μαρ, 2014 @ 12:10πμ
Εμφάνιση 1-12 από 12 σχόλια
< >
Butters 6 Μαρ, 2014 @ 12:27πμ 
What graphic card driver are you using?
XingHua31 6 Μαρ, 2014 @ 12:32πμ 
The post-release updates one from the System Settings>Additional Drivers.
Butters 6 Μαρ, 2014 @ 9:23πμ 
My guess is the system is using the integrated GPU of A8. If you're using the open source driver, you can try your luck installing AMD proprietary fglrx drivers:
https://help.ubuntu.com/community/BinaryDriverHowto/AMD
Butters 6 Μαρ, 2014 @ 10:16πμ 
I tested mine today and it did stutter a lot even thought the fps seems fine (around 60 in high setting). I remember it worked fine before.
XingHua31 6 Μαρ, 2014 @ 6:25μμ 
I'm almost certain it isn't using the A8 APU. You have to plug into the motherboards HDMI port or VGA to get the APU graphics to work. The HDMI is plugged into the Radeon 7850. Also, as you can see from the screenshot, the Catalyst Control Center only lists the Radeon 7850.

http://s17.postimg.org/gzzueyf33/Screenshot_from_2014_03_07_02_16_02.png
XingHua31 14 Μαρ, 2014 @ 5:50πμ 
Still having this issue, even after trying the latest 14.2 Beta driver... :'(
XingHua31 14 Μαρ, 2014 @ 11:05πμ 
Bump..
Butters 14 Μαρ, 2014 @ 11:36πμ 
I remember the game used to be fine but last time I tested it had bad stutter even though the fps showed up all right.
Maybe try your luck by installing an old kernel?
Fletch 14 Μαρ, 2014 @ 12:19μμ 
I recommend sticking with Windows, there is a lot more support for games, etc.
XingHua31 15 Μαρ, 2014 @ 2:37πμ 
Αναρτήθηκε αρχικά από Fletch:
I recommend sticking with Windows, there is a lot more support for games, etc.

I guess you didn't read my 1st post lol.
Fletch 15 Μαρ, 2014 @ 2:39πμ 
Αναρτήθηκε αρχικά από XingHua31:
Αναρτήθηκε αρχικά από Fletch:
I recommend sticking with Windows, there is a lot more support for games, etc.

I guess you didn't read my 1st post lol.

Yes, but my recommendation is still Windows. Iwould just get a new one, it is a quality product.
XingHua31 15 Μαρ, 2014 @ 2:41πμ 
Αναρτήθηκε αρχικά από Fletch:
Αναρτήθηκε αρχικά από XingHua31:

I guess you didn't read my 1st post lol.

Yes, but my recommendation is still Windows. Iwould just get a new one, it is a quality product.

Ubuntu is a good OS too. It's just AMD's drivers suck balls lol. But yeah, i may try and get Vista Retail off eBay or something.
Εμφάνιση 1-12 από 12 σχόλια
< >
Ανά σελίδα: 15 30 50
Ημ/νία ανάρτησης: 6 Μαρ, 2014 @ 12:07πμ
Αναρτήσεις: 12