TacoMacSupreme Mar 2 @ 9:24pm
Trouble with Addons staying, well... Added on.
Picked up the game several days ago and have been having a blast with mods. Though, curiously enough, several seemed to disappear. Ignoring it, I continued to play and gather more addons. Now, however, when I start up the game (currently running in the background as I type this) only a few addons appear when choosing which to enable. Anyone have any idea as to why this is happening, how to fix it, or at least a conclusion as to how it started to happen? I have a few friends who have this as well, and they've never had any issues. Thanks!
Showing 1-8 of 8 comments
< >
Player 1 + Player 2 Mar 2 @ 9:35pm 
You can't have 2 mods on the same thing you know
TacoMacSupreme Mar 2 @ 9:50pm 
I know, but I'm talking about campaigns, weapon skins, sounds for special infected, ect. I'm talking about them actually not showing up on my add-ons list at all.
battle2525 Mar 2 @ 9:59pm 
Check if the addon is still in the workshop (assuming you got it there). I had one addon disappear because the one I subscribed, the author deleted it or something.
If it's still there, I suggest to unsubscribe and delete the mod if it's still present (found in workshop folder in l4d2 folder). Resubscribe and let it download, start the game, let it load (until the symbol next to the addon menu disappear). Check the addon to see if it show up.
TacoMacSupreme Mar 2 @ 10:03pm 
I've already checked to see if they were still there, will definitely try out the re-subbing, update when I have an definite answer. Thanks for the idea!
Woudo Mar 2 @ 10:21pm 
Wait on the Mod screen for a minute or two until the list actually loads in.
^1B.o.B ^9CrackerNugget Mar 2 @ 11:02pm 
As Woudo said, you have to wait a minute or two in order for your addons to load. That's just how it is for workshop mods. You can tell when your game is loading addons when you see a "4" insignia by the Addon button on your main screen; HOWEVER!!!! There is an alternative. Most (if not all) workshop mods have alternative versions on l4dmaps.com. If you download your mods from there, you never have to wait for them to load when starting-up your game.
Last edited by ^1B.o.B ^9CrackerNugget; Mar 2 @ 11:03pm
TacoMacSupreme Mar 2 @ 11:53pm 
Originally posted by Woudo:
Wait on the Mod screen for a minute or two until the list actually loads in.


I let it sit for over an hour and nothing. Already attempted that.


Originally posted by ^1Z^7u^1|^7u ^1Cracker:
As Woudo said, you have to wait a minute or two in order for your addons to load. That's just how it is for workshop mods. You can tell when your game is loading addons when you see a "4" insignia by the Addon button on your main screen; HOWEVER!!!! There is an alternative. Most (if not all) workshop mods have alternative versions on l4dmaps.com. If you download your mods from there, you never have to wait for them to load when starting-up your game.


Honestly, I'm about ready to just take that alternative.
TacoMacSupreme Mar 3 @ 11:35am 
Got it lined out finally. Took the alternative ^1Z^7u^1|^7u ^1Cracker suggested. Thanks!
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Mar 2 @ 9:24pm
Posts: 8