LOOMfreek Feb 13, 2014 @ 7:37pm
Insanely High Ping 500+. Can anyone help?
Hi All,

Thought I'd post this and get some help, while my last message to STEAM support gets answered. Figured I've got nothing to loose. I've already opened up a ticket from support and followed their directions to the tee: open my firewalls, configured my router, and reset my steam config, but still no dice.

About 3 months ago my ping in L4D2 has gone down the crapper. Went from 40s to 500+ overnight. I've read old threads about ping bombs, but even changing my name with a tilde' does not work.

I know it isn't my hardware (hardware hasn't changed). It's not my graphics card, FRAPS says I'm getting consitent 60fps ingame. It's not my internet connection as pingtest.net rated me an A with 0% packet loss as well as speedtest.net reading at 32ms Ping / 19.21Mps Down / 1.52Mps Up.

Soo, does anyone have any hints on how to get rid of this dam PING BOMB!!! It's infuriating as I don't even voice chat nor talk much when I play.

Thanks in advance for any help the community can provide.
Last edited by LOOMfreek; Feb 13, 2014 @ 7:39pm
Showing 1-14 of 14 comments
< >
Dharok The Wretched Feb 13, 2014 @ 7:50pm 
Are you playing on servers in your country?
I would assume most likely you are.
If not type 'openserverbrowser' in to console and have a look for servers.
looking 4 friend 2 halp Feb 13, 2014 @ 8:23pm 
Okay, do this.

Steam settings > downloads > download region > Make sure its a region at your place or at least closest to you
Dharok The Wretched Feb 13, 2014 @ 8:49pm 
Originally posted by #hiatus Panduh.:
Okay, do this.

Steam settings > downloads > download region > Make sure its a region at your place or at least closest to you
I would assume this is auto set, but yes if it is incorrect, make it closest possible location to you.
LOOMfreek Feb 14, 2014 @ 9:12am 
Sorry, forgot to mention that. Yes, one of the first things I did was check my region and it is setup properly for San Jose CA. I'm in San Mateo CA.
LOOMfreek Feb 14, 2014 @ 5:44pm 
bump
Dharok The Wretched Feb 14, 2014 @ 6:37pm 
Did you try - 'openserverbrowser' ?
Der Ungrund Feb 14, 2014 @ 7:05pm 
I have a similar problem. There was a huge patch a couple weeks ago (like 7 gigs) and ever since then my ping has always been in the 300 range. I had no hardware changes so I don't know what's wrong.
LOOMfreek Feb 17, 2014 @ 10:59am 
I'll give openserverbrowser a shot. DLR.A.
LOOMfreek Feb 17, 2014 @ 11:17am 
Ok, tried the server browser. Seems to only confirm there is something seriously wrong going on. On the server browser the server I chose read that latency was 50. I jump on and my ping shot to 900. Whooohooo. I think that has got to be a record so far. Highest I've seen it go to was 800 the other night.

And just to cross check my connection with my in-game ping just now. Pingtst.net just gave me an A rating from pingtest.net w/ 0% packet loss / 39ms Ping / 1ms jitter.

So frustrating for the L4D addict that I am :)
Last edited by LOOMfreek; Feb 17, 2014 @ 11:19am
Dharok The Wretched Feb 17, 2014 @ 5:27pm 
Verrrry veeeerry interesting. Did you try multiple servers?
I actually can't help you beyond that I thought that may have helped. :|
I haven't heard anything like this before, I'm assuming you've tried google?
Sounds silly, but it may provide the answer.
I used to have crazy lag-outs, and my ping would skyrocket to over 4000, lol.

I'll have a google and see if I can find anything!
Dharok The Wretched Feb 17, 2014 @ 5:31pm 
Have you tried a very basic uninstall and re-install ?
Have a quick look through this thread and see if anything rings a bell :
http://forums.steampowered.com/forums/showthread.php?t=2209858&page=2
Dharok The Wretched Feb 17, 2014 @ 5:38pm 
Actually, this may be of more interest; it sounds to be more relevant, hope it helps :
http://forums.steampowered.com/forums/showthread.php?t=3027301

EDIT: I just noticed you've already seen these threads. Sorry man, I tried :( lol. It definitely sounds as though someone may be targeting you though... which really sucks. Hopefully they just get sick of it.. lol.
Last edited by Dharok The Wretched; Feb 17, 2014 @ 5:48pm
Dharok The Wretched Feb 17, 2014 @ 6:11pm 
It seems like your best bet may be to play on servers with DOS protection ?
I'm not sure if that only protects the server, or if the individuals on it as well.
I don't know a great deal about it all... just trying to help. lol
LOOMfreek Feb 18, 2014 @ 3:07pm 
Thanks DLR. I appreciate the effort. Guess I just need to wait to hear back from VALVE CS on my last message to them.
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Feb 13, 2014 @ 7:37pm
Posts: 14