Left 4 Dead 2

Left 4 Dead 2

View Stats:
fr0g Feb 7, 2014 @ 9:04pm
connection failed after 10 retries??????????
in tf2, csgo, l4d2, all 3 games, i try connecting to servers, it says "connection failed after 10 retries" i gave up on tf2, stopped playing csgo for awhile, but now im trying to fix l4d2 servers, modded servers work fine, but i want to play normally. Local servers also work, but not much host those, can someone tell me a permanent solution?

P.S: I've tried googling solutions, but most didn't work, some worked for a day or 2, but not forever.
< >
Showing 1-13 of 13 comments
KeToKi Feb 7, 2014 @ 11:29pm 
Im hving the same issue
Meatspin Feb 9, 2014 @ 10:38pm 
try open the l4d2 ports, 27015 disable firewall and antivrus too
fr0g Feb 10, 2014 @ 2:48pm 
ive disabled them before, didn't do anything, and how do i open the ports?
Meatspin Feb 10, 2014 @ 2:59pm 
sarch for the name of the modem you have and how to open ports in then

Last edited by Meatspin; Feb 10, 2014 @ 3:03pm
ChibiYoona Mar 10, 2014 @ 12:15am 
same problem here
fr0g Mar 10, 2014 @ 12:47am 
forgot to reply, i opened the ports and still doesn't work :/
ChibiYoona Mar 10, 2014 @ 8:19am 
so what is the best solution?
qwerty Mar 10, 2014 @ 8:56am 
Well mates im sorry but there is no solution yet(at least good one). But you may try to change the router (if you're using one) . I had the same problem for months, tried every solution in google..and.. nothing happened. So i just bought a new router and guess what?! The damn thing finally works. GL ! :)
Last edited by qwerty; Mar 10, 2014 @ 8:58am
Meatspin Mar 10, 2014 @ 9:28am 
so sorry i no know how to solve your problem, all problems i have with connections i solve opening the ports e.e
Last edited by Meatspin; Mar 10, 2014 @ 9:29am
ChibiYoona Mar 10, 2014 @ 9:43am 
how to do it?
-CF- [CS] Ioskeha Oct 1, 2014 @ 2:20am 
How did you decide this problem?
neofutur Oct 1, 2014 @ 1:19pm 
same here, you have to edit game settings to change to "local server", theres not enough official servers for players ;(
Last edited by neofutur; May 12 @ 10:18am
Xorcist May 12 @ 8:47am 
From your game list: right+click L4D, click properties, set launch options, "+clientport 2700*" where the * is 6 or higher. I had to use 7.

Apparently the default is 27005, so you have to change one or more of your machines to have a different clientport.

OF NOTE: This problem cropped up once a machine with Win8.1 was put on the network. Before it was all Win 7. I suspect Windows 8 has a problem with playing nice with others on a network as apparently something was co-existing previously with Win7 machines and STEAM but not with Win8.1
< >
Showing 1-13 of 13 comments
Per page: 15 30 50

Date Posted: Feb 7, 2014 @ 9:04pm
Posts: 13