Citizen Carnage Jun 29 @ 10:06pm
Left 4 Dead 2 crashing on start up
Hello people,

Left 4 Dead 2 is crashing when gets to the Powered by Souce logo, The logo starts to fade and then nothing game crashes.

Any ideas ?
Showing 1-8 of 8 comments
< >
Destero Jun 30 @ 4:18am 
Mine does the same.
Tuna Jun 30 @ 7:41am 
same here, started about two weeks ago, reinstall solved a problem but started again after one game played.. any fixes for it?
Dog Jun 30 @ 8:02am 
it could be , if you are using reg cleaner or some thing like that it remove files from steam folder . it was that for me
Tuna Jun 30 @ 8:20am 
RESOLVED: If you are using XFIRE then log off from it or remove Left 4 Dead 2 game from detected game (never detect) and click Apply - seems that Xfire is causing problems to L4D
Citizen Carnage Jun 30 @ 5:58pm 
Originally posted by Counting Wth the Count:
Originally posted by TheMasterBlaster™:
Have you searched any of the 10,000 posts about this?

Yes your highness. I did search and I am having trouble finding these 10,000 posts you speak of. So now I ask you specificaly for help with finding these posts. I am not just asking anyone in general. I am asking you specificaly


Well said Counting With the Count, I to could not find these 10,000 posts and the few posts I did find did help fix my issue. This is why I posted in hope someone has a new answer.....

Tuna Im not using XFire
TheMasterBlaster™ Jul 9 @ 2:38pm 
Originally posted by Counting Wth the Count:
Originally posted by TheMasterBlaster™:
Have you searched any of the 10,000 posts about this?

Yes your highness. I did search and I am having trouble finding these 10,000 posts you speak of. So now I ask you specificaly for help with finding these posts. I am not just asking anyone in general. I am asking you specificaly

Apparently you don't know how to search either.

Here you go mr know it all.
http://steamcommunity.com/app/550/discussions/search/?q=crash 1554 posts
http://forums.steampowered.com/forums/search.php?searchid=19427092 6000 posts
Total posts 7,554.
Spodermon Jul 9 @ 3:04pm 
This happens to me alot of times.There's nothing you can do unless you restart your computer
Dharok The Wretched Jul 9 @ 3:18pm 
You might want to have a look at this list and see if any of the applications listed there, are being run on your system.
Otherwise, you could also try bypassing the intro video by adding '-novid' to your launch parameters.
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Jun 29 @ 10:06pm
Posts: 8