John Jul 13 @ 5:48pm
Lag Spikes
I have been playing L4D2 for a while. Never any issues with major lag. Starting 2 or 3 days ago, in every game I get random lag spikes bringing my ping to 400+. The game completely locks up/freezes. Sometimes my ping stays same and the game freezes. Maybe its a background process, i have no idea. Just wanted to know if anyone else has this issue. Any input would be appreciated.
Showing 1-4 of 4 comments
< >
Shao Jul 14 @ 12:00am 
Performance =/= Connection.

If the game is still smooth but your ping is spiking. That's internet related.
If your ping is fine but you can see the game running slow as in frame rate decrease, that's your PC.

L4D2 has know many DDOS attacks along UDP exploit. Most likely it was, or your connection is being a downer. Try to be clearer with this "freezing".

Also worth mentioning, if you're hosting and the PC that you have isn't good at it or aka not fast enough to run the game at a great rate. The game latency will mostly spike up your ping, even if you have amazing UP and DOWN as also offline too.

A lag spike is when the game stops from responding for a few seconds, nada no frames with a repetitive sound until it gets back to run again.
John Jul 14 @ 4:53pm 
Thank you for the input. It must be a connection related issue because on high settings i get 45-60 fps. Yes, the way you described a lag spike is exactly what im experiencing. I do just have a laptop, but it was always good enough for L4D2. Like I said this problem just started occuring
Unbridled☆Enthusiasm Sep 15 @ 4:19am 
This problem just started happening to me. No one else in the house is effected. So i tried a different connection thats reliable (because ive tried it in the past and no lag before then) and the same ♥♥♥♥ still happens. So its not the internet. Its the game reacting really ♥♥♥♥ed up. Sometimes it works fine, but 90 percent of the time i can't play l4d2. Any other game ♥♥♥♥ing works just fine and no lag. I play dayz and destiny on the ps4 just fine, no lag there AT ALL. I reinstalled l4d2. Maybe its some console command but i never ever do that.

If you have the same problem as i do, its not internet related. I play with like 50 ping and every time when infected spawns, i spike to 300 ping. its ♥♥♥♥ing insane. can't do ♥♥♥♥! It feels like the game is having a hard time when spawns occur. I also tried l4d2 on my mothers ♥♥♥♥ty computer. I had to put on the lowest settings just to play and i still get 25fps lol but it never lagged. Its not internet, its my computer reacting to the game somehow....... i have an i5 3740k @4.2ghz 16gb ram and a gtx 780sc. I tried the game on my ssd. Nope, tried it on my other internal hdd, nope.

i dont ♥♥♥♥ing get it. at all.
Shao Sep 15 @ 1:50pm 
Originally posted by Unbridled☆Enthusiasm:
i have an i5 3740k @4.2ghz 16gb ram and a gtx 780sc. I tried the game on my ssd. Nope, tried it on my other internal hdd, nope.

Try without multicore rendering. For all the people i know who have "i" series, source is badly optimized for that series at multiple cores in use and get better frame rates without it. Well so far, most did.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50