Kuroodo Jul 10, 2014 @ 6:59pm
[SOLVED] No sound output and mic input?
I open the game with headphones.
There's no sound, even on the splash screen.

Everything is configured properly in settings and on my pc's sound settings.

I go ahead and unplug headphones + mic. No sound from my speakers.

Any help?
Last edited by Kuroodo; Jul 11, 2014 @ 11:19am
Showing 1-6 of 6 comments
< >
Knappy Jul 10, 2014 @ 7:29pm 
Right click sound icon, Playback Devices/Properties, Disable Speakers. (Right click in the white area to enable viewing disabled devices) Re-Enable them. If this is a sound card, check for drivers.

Also troubleshoot the problem and above all:
[/list]
  • Make sure the headphones are plugged in
  • Make sure the line isn't frayed or snapped
  • Make sure game volume is on and not muted

I had an issue with static and increasing static over time. Mind you it was a five year old card (SB X-Fi Elite Pro) but it was nuked... R.I.P Sonar X3

If none of the above helps feel free to add/contact me.
Last edited by Knappy; Jul 10, 2014 @ 7:36pm
Kuroodo Jul 10, 2014 @ 7:36pm 
Originally posted by Knappy:
Right click sound icon, Playback Devices/Properties, Disable Speakers. (Right click in the white area to enable viewing disabled devices) Re-Enable them. If this is a sound card, check for drivers.

Also troubleshoot the problem and above all:[/list]
  • Make sure the headphones are plugged in
  • Make sure the line isn't frayed or snapped
  • Make sure game volume is on and not muted

I had an issue with static and increasing static over time. Mind you it was a five year old card (SB X-Fi Elite Pro) but it was nuked... R.I.P Sonar X3

Every other game works fine (even other source games). I hear everything loud and clear, and mic works perfectly.

Left 4 Dead 2 just won't work. It's not muted either, and as stated before, everything in the settings is properly configured.

L4D2 doesn't even output sound from my regular speakers (when headphones disconnected as well).


I'm running win 7
Last edited by Kuroodo; Jul 10, 2014 @ 7:37pm
Knappy Jul 10, 2014 @ 7:38pm 
Verify Game Integrity

That should be the first line of defense toward any Steam game issue.

If that fails, in the developer console:
snd_rebuildaudiocache

Go build a house or something while you wait for it to rebuild the sound cache.
Last edited by Knappy; Jul 10, 2014 @ 7:40pm
Kuroodo Jul 10, 2014 @ 7:41pm 
Originally posted by Knappy:
Verify Game Integrity

That should be the first line of defense toward any Steam game issue.

If that fails, in the developer console:
snd_rebuildaudiocache

Go build a house or something while you wait for it to rebuild the sound cache.

Looks like I'll be resorting to snd_rebuildaudiocache

I'll return with the results!
Knappy Jul 11, 2014 @ 11:19am 
Try installing the latest drivers for your sound. :-þ
Last edited by Knappy; Jul 11, 2014 @ 11:19am
Kuroodo Jul 11, 2014 @ 11:19am 
Originally posted by Knappy:
Try installing the latest drivers for your sound.

Wow, it worked!
Thanks thanks thanks!
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Jul 10, 2014 @ 6:59pm
Posts: 6