Zulu Jul 21 @ 8:39am
Huge issue with ping
In the last 3-4 days weird things happens when i join any server, after the join everything running fine but some minutes later the pings of everyone is going up to 900+ and it crashes, not just for me but for all others on the server. i reinstalled the game 2 times, deleted all addons but nothing changed. I have the same laptop and same internet connection for years and this never happened before (others online games like cs go runs perfect)
Guys what do you think?
Showing 1-12 of 12 comments
< >
Venrez Jul 21 @ 8:44am 
If its doing it to others (the whole server) then its a Server problem.

If only YOUR ping rises to 900 and then crashes, its a problem with your net connection.

Still, it can help to turn off any firewalls. Stop any downloads. Close any active internet browsers. All that stuff.

If you're talking about playing in a server with people in real life next to you (like in a LAN) and the Ping rises to 900 and everybody crashes, it is like a problem with your internet settings. A firewall could be blocking it. Your Ports might be blocked. Your TCP/IP settings are incorrect. A number of things.
Zulu Jul 21 @ 9:16am 
Its not lan, random global servers. it runs fine before i join like the third map is going on versus, then i join and everybody getting that pings just in minutes. no firewall blocks, everythings is the same as last week
[linux] sophia hapgood Jul 21 @ 9:41am 
If it only happens after *you* join the game and to all players, maybe it's possible someone is following you and ddosing servers. You may want to make your profile private.
Zulu Jul 21 @ 12:41pm 
Nobody follows.. server is 7/8 without me and i am the last who joined and this always happens... i started a survival game with 1 friend and it lagged, then my friend started the server, it was fine without me but after i connected there lags again
i tried windowed mode, lowest graphic, highest graphic but always the same..
it cant be just connection problem because i have Very good net and as i said others games are just fine
Venrez Jul 21 @ 1:16pm 
It sounds like either some program you are running is directly interfering with L4D - or someone is maliciously hacking / DDOS'ing the server you connect to after you do so.

The same could be said for a Virus doing the same thing. It patiently waits until outbound internet connections are detected via traffic (i.e. on a server) before activating and doing its thing.

Or maybe Steam is attempting to verify something and it causes de-syncs between yourself and the Server, which in turn leads to lag for the other players too - and an inevitable server crash.

Maybe you (or the Server) are running different versions. The censored 'no-gore" version and the default American full-gore version. That can also cause De-sync issues, but its rare.

The problem with these sorts of problems is that there is so much that can go wrong and its often very difficult to pinpoint what is actually doing it.
Zulu Jul 22 @ 11:13am 
I dont know what caused it, but the problem just gone today..
i didnt change anything, maybe the hacker got bored or dont know, anyway thanks for your help Venrez!
[†]Munkee_King[†] Jul 22 @ 12:47pm 
Do a virus scan.

I had bad lag all the time. Found out Mozilla was spamming me with adware. removed it and ta-da. worked fine.
Venrez Jul 22 @ 2:30pm 
Originally posted by †Munkee_King†:
Do a virus scan.

I had bad lag all the time. Found out Mozilla was spamming me with adware. removed it and ta-da. worked fine.

Mozilla Firefox is simply an internet browser. It does not spam you with adware. You may have browsed to a website that does, encountered a virus, or downloaded a plugin for Mozilla that was spamming you with Adware.

But Mozilla itself does not.
[†]Munkee_King[†] Jul 22 @ 2:34pm 
Something we got when we got it then.

But it came with Mozilla. No issues, then when we downloaded it, we suddenly had adware going nuts on our computer, we would delete 1 and 5 more would appear
Last edited by [†]Munkee_King[†]; Jul 22 @ 2:34pm
Venrez Jul 22 @ 2:42pm 
Pay attention to the Installation process.

Many Browsers, like Internet Explorer, Opera, Netscape, Mozilla Firefox, etc - will try to slip in a sponsored program like the .Ask? toolbar or plugin that works through the browser itself.

Just one 'page' during the installation process that asks 'Install the .Ask? toolbar?' or something. Say no.

Either you visited a false download page with a Virus-infected version of Mozilla, or you installed some sort of adware addition / plugin along the way.
[†]Munkee_King[†] Jul 22 @ 5:46pm 
Eh, doesn't matter anymore, ashes to ashes. We don't have the issue. I didn't download or use it.

I just used that time as a example to do a virus scan
Grey Warden Jul 22 @ 7:23pm 
same here, but the server doesnt crash we have to play but 999 ping :_
Showing 1-12 of 12 comments
< >
Per page: 15 30 50
Date Posted: Jul 21 @ 8:39am
Posts: 12