Spidey Aug 26 @ 9:06pm
Problem with choppy gameplay
I am posting this here as this was the first case of it happening on my computer. About 3 days ago my computer was running this game, among others, fairly well. Getting good frame rates for my laptop and things. The next day, when I launched the game it seemed slightly choppy, but I disregarded it, as it did things like this because of mods. I started a campaign and it was extremly choppy and laggy. I thought it was because of a recent mod I got, so I removed it and the problem didn't go away. I just thought my laptop just needed a bit of a break as I play a lot. So I shut it down for a day and came back and nothing changed. I went to watch Youtube as I was bored and just hoped it would go away with time, and even the Youtube vids were choppy, and I don't mean Buffering I mean its was like it was lagging. I was starting to get concerned, so I checked if this happened to others and it was in multiple games, so I wanted to check and see if it was just left4dead. It wasn't. One game worked with no lag. Binding of Isaac. So I check my other low graphic steam game, Towerfall acencsion (Probably spelled that wrong) and in the start up where it says Matt Makes Games was laggy. Hoping it was just steam I check an origin game, Plants vs Zombies, problem still persisted. I ended up checking everything. I updated windows, I checked for virus, none. I defragged my system, nothing changed, among others that I could do with a laptop. Nothing changed. I am wondering if anyone could help me. Thanks in advance.
Showing 1-7 of 7 comments
< >
[†]Munkee_King[†] Aug 26 @ 9:46pm 
I will be honest. You didn't really break that up and was a pain to read a block of words.. lol.

I had choppy gameplay so I turned my settings down. Try that if it isn't already in there.
全能の神Seiesu十七 Aug 27 @ 4:38am 
Check for malware and reinstall your drivers. If this still not solves anything be prepared to reinstall Windows
(ΘČĐ)™Conrad925 Aug 27 @ 10:45am 
So you thought it was tired, and needed to rest? Did you consider the possibility of an evil spell?
zaptehworld Aug 27 @ 11:14am 
Originally posted by Zoey:
Check for malware and reinstall your drivers. If this still not solves anything be prepared to reinstall Windows
yea, format c: and things
Spidey Aug 27 @ 4:27pm 
@(ΘČĐ)™Conrad925 Well I suspected it was overheated and overused. Quite often I forget to turn off my computer, and I use it alot. And I sometimes letting things sit fixed a lot of my problems in the past.

@Zoey Well I reinstalled the drivers and scanned for malware and fixed any problems related to this. I will be back in a little to update things. Here's hoping it works right now, but If it doesn't I will recheck every few days or so, but if next week it still isn't fixed, I'm probably going to have to reinstall windows.
[†]Munkee_King[†] Aug 27 @ 4:34pm 
My family has their computer tower open and a fan to blow on it so it didn't overheat. seemed to work for them well. As long as the fan isn't covered in dust
Spidey Aug 27 @ 4:35pm 
Everything works now, thank you so much. And I hearby swear to never look a rule34 of Zoey ever again....maybe...
Showing 1-7 of 7 comments
< >
Per page: 15 30 50