A Gentleman's Attire (Simen) Aug 11, 2014 @ 3:36pm
''Steam servers are too busy to handle your request''
For a few days now i have not been able to launch L4D2, when i try to launch it, it pops up an installing thing, saying it's installing something, but when it gets to 100% it says the following message: ''Steam servers are too busy to handle your request'' Error code 53.

when i then press OK, nothing happens, it just goes back to my library.
if anyone knows how to fix this, please tell me.
Last edited by A Gentleman's Attire (Simen); Aug 11, 2014 @ 3:36pm
Showing 1-8 of 8 comments
< >
Dharok The Wretched Aug 11, 2014 @ 5:41pm 
Did you even TRY to search for an answer.
I'm going to go with no, and I know I'm right.

See here and here for possible solutions.
Next time, Google it[googleitfor.me]
A Gentleman's Attire (Simen) Aug 11, 2014 @ 5:44pm 
I have googled it, i did not find anything that worked for me.
(ΘČĐ)™Conrad925 Aug 11, 2014 @ 6:12pm 
I can see you being unable to find a remedy if you searched these forums, due to all the helpful threads being bumped by the innumerable fantasy L4D3 posts/L4D community rant posts. Perhaps look to the Steam support page as this sounds like a Steam issue. Good luck.
A Gentleman's Attire (Simen) Aug 11, 2014 @ 6:45pm 
I fixed the problem! thanks for the help guys!!
Kyle tha Wolfie⁷ Aug 12, 2014 @ 4:26pm 
Originally posted by Simen99:
I fixed the problem! thanks for the help guys!! :boomer:
I'm having this problem right now.. how did you fix it?
A Gentleman's Attire (Simen) Aug 13, 2014 @ 1:41am 
i took the firewal down, did the installation and put it back up again!
Waylander Aug 13, 2014 @ 2:06am 
what???
A Gentleman's Attire (Simen) Aug 13, 2014 @ 2:11am 
*Firewall
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Aug 11, 2014 @ 3:36pm
Posts: 8