NieR:Automata™

NieR:Automata™

View Stats:
Does it take an ENTIRE day and more[NOW, A WEEK AND HALF] to make a RESOLUTION BUG PATCH?!
What are you doing?
Sleeping?
Release the Resolution bug patch already!
Last edited by AlterRektMLG; Mar 24 @ 12:51pm
< >
Showing 46-60 of 239 comments
Originally posted by Clueless:
Originally posted by Amanda Ripley McLaren:
I know they are moderators but they could have just replied to some of the tweets concering this issue, right?
They totally couldn't have done that, right?
Really hard for them to contact the developers, right?

I can tell you right now a PR team has nothing to do with a dev team, your "valuable feedback" is either not sent anywhere, or if it's indeed sent to the devs they get no confirmation of anything. They got their pre-determined and pre-planned answers to give you.

You sound like the kind of person that yells at people working at a call center.
Everyone sounds like every other person on the internet.
There's no point in arguing on that.
Borderless Gaming solves my problem pretty much.
There isn't much lag for me.
Antitype Mar 19 @ 11:54am 
In case you missed it, someone figured out the problem with fullscreen and we might get a fix soonish. And yeah, this is an universal issue, so all those "but it works fine on my end" were simply people not noticing it as I expected.

Originally posted by DrDaxxy:
What's going on here is that when switching to fullscreen, the game will ask Windows to switch to a mode with the given resolution that is also stretched... the programmer probably thought this exclusively referred to aspect ratio correction, but what happens instead is that if Windows can't find a stretched mode for that resolution (because it's your monitor's native resolution, and thus doesn't need to be stretched), it'll look for the closest mode that is - so the first supported resolution below your monitor's native res.

The game will still render at the selected res (hence screenshots coming out correctly), but it'll be downscaled and then upscaled again on your display (what happens on my system is that the game renders at 1080p, but the display resolution is 1680x1050 so it's downscaled to that, then my monitor or GPU upscales it to 1080p again).

@Kaldaien: Hook CreateSwapChain, set swapChainDesc->bufferDesc.Scaling to DXGI_MODE_SCALING_UNSPECIFIED, that'll fix it. Note, the game also sets refresh rate to exactly 60 Hz, regardless of whether that exact rate is supported (and not 59 or 59.97 or whatever). Wasn't a problem on my system even though that's not in the list of supported modes, but it might be on others, what do I know...

(I figured it's better not to release this myself since you'll likely have other fixes to make and having two mods for this would just be messy)
>Letting Japs handle optimization when their main market is pachinko machines

:^)
Kaldaien Mar 19 @ 12:07pm 
Originally posted by Antitype:
In case you missed it, someone figured out the problem with fullscreen and we might get a fix soonish. And yeah, this is an universal issue, so all those "but it works fine on my end" were simply people not noticing it as I expected.

Originally posted by DrDaxxy:
What's going on here is that when switching to fullscreen, the game will ask Windows to switch to a mode with the given resolution that is also stretched... the programmer probably thought this exclusively referred to aspect ratio correction, but what happens instead is that if Windows can't find a stretched mode for that resolution (because it's your monitor's native resolution, and thus doesn't need to be stretched), it'll look for the closest mode that is - so the first supported resolution below your monitor's native res.

The game will still render at the selected res (hence screenshots coming out correctly), but it'll be downscaled and then upscaled again on your display (what happens on my system is that the game renders at 1080p, but the display resolution is 1680x1050 so it's downscaled to that, then my monitor or GPU upscales it to 1080p again).

@Kaldaien: Hook CreateSwapChain, set swapChainDesc->bufferDesc.Scaling to DXGI_MODE_SCALING_UNSPECIFIED, that'll fix it. Note, the game also sets refresh rate to exactly 60 Hz, regardless of whether that exact rate is supported (and not 59 or 59.97 or whatever). Wasn't a problem on my system even though that's not in the list of supported modes, but it might be on others, what do I know...

(I figured it's better not to release this myself since you'll likely have other fixes to make and having two mods for this would just be messy)

Where was this posted?

This is already doable with Special K, if you set Scaling=Unspecified in dxgi.ini :)

I use Centered scaling myself because it's a driver optimization (allows DirectFlip). I did catch the stretched scaling problem within the first 5 minutes of starting the game. Never bothered to try Unspecified scaling though.
Last edited by Kaldaien; Mar 19 @ 12:08pm
«(MooP)» Mar 19 @ 12:08pm 
Borderless gaming app is legit 100% Temp fix.... But yea we need a legit patch.... Better see it during this week...
Last edited by «(MooP)»; Mar 19 @ 12:09pm
Antitype Mar 19 @ 12:09pm 
Originally posted by Kaldaien:
Where was this posted?

This is already doable with Special K, if you set Scaling=Unspecified in dxgi.ini :)

I use Centered scaling myself because it's a driver optimization (allows DirectFlip). I did catch the stretched scaling problem within the first 5 minutes of starting the game. Never bothered to try Unspecified scaling though.

Here: http://steamcommunity.com/app/524220/discussions/0/135511757698574434/?ctp=5#c135511913388527190

I had no idea you already fixed it, thanks for saving the day once again. :)
Kaldaien Mar 19 @ 12:14pm 
I didn't already fix it, I just have a feature built-in to Special K that takes care of this already =P You just need to know the correct way to configure the DLL to do what DrDaxxy is talking about.

03/19/2017 15:11:12.855: [ DXGI ] [!] IDXGISwapChain::SetFullscreenState (0, 0000000000000000h) -- [ NieRAutomata.exe, tid=0x1e84 ] 03/19/2017 15:11:13.352: [ DXGI ] [@] Return: S_OK - < SetFullscreenState_Original (This, Fullscreen, pTarget) > 03/19/2017 15:11:13.352: [ DXGI ] [!] IDXGIFactory4::CreateSwapChain (0000000005C58970h, 000000000014FB90h, 000000000D7D4970h) -- [ gameoverlayrenderer64.dll <OverlayHookD3D3>, tid=0x1e84 ] 03/19/2017 15:11:13.352: [ DXGI ] SwapChain: (3840x2160 @ 59.0 Hz - Scaling: Stretched) - {Windowed} [3 Buffers] :: Flags=0x0000, SwapEffect: Discard 03/19/2017 15:11:13.352: [ DXGI ] >> Scaling Override (Requested: DXGI_MODE_SCALING_STRETCHED, Using: DXGI_MODE_SCALING_UNSPECIFIED)

dxgi.ini
[Render.DXGI] ... Scaling=Unspecified

Now, I don't have any code setup to do a refresh rate override, however. So in fullscreen mode the game will continue to select the second-to-last refresh rate (59 Hz on my system). I can whip up a fix for that.
Last edited by Kaldaien; Mar 19 @ 12:15pm
Antitype Mar 19 @ 12:21pm 
I'll give it a try. Refresh rate fix would be cool as well, I noticed the game likes to hover in the 59 range, never really hitting that 60 fps.

For anyone interested, you can grab SpecialK here: https://github.com/Kaldaien/SpecialK/releases/download/sk_gui/SpecialK_0_7_36.7z
And here's the guide to set it up etc: https://steamcommunity.com/groups/SpecialK_Mods/discussions/0/215439774855607641/?ctp=47
Last edited by Antitype; Mar 19 @ 12:22pm
Kaldaien Mar 19 @ 12:42pm 
There, should be fixed now:

03/19/2017 15:41:33.914: [ DXGI ] SwapChain: (3840x2160 @ 59.0 Hz - Scaling: Stretched) - {Windowed} [3 Buffers] :: Flags=0x0000, SwapEffect: Discard 03/19/2017 15:41:33.914: [ DXGI ] >> Scaling Override (Requested: DXGI_MODE_SCALING_STRETCHED, Using: DXGI_MODE_SCALING_UNSPECIFIED) 03/19/2017 15:41:33.914: [ DXGI ] >> Refresh Override (Requested: 0.000000, Using: 60)

I'll release a packaged version with config setup for proper fullscreen mode in a few minutes.
A X O Mar 19 @ 12:50pm 
Originally posted by Amanda Ripley McLaren:
What are you doing?
Sleeping?
Yeah keep managing that twitter account and not even helping people out.
Release the Resolution bug patch already!



maybe enjoyjing the weekend like other people?! calm down
DrDaxxy Mar 19 @ 12:52pm 
Yeah, Centered gives me the same problem as Stretched (except, you know, the resulting native-resolution-downscaled-to-next-highest-resolution picture being centered on the display instead of stretched back up).

In fact it ends up being more broken since that also throws out Nvidia DSR modes :P
Antitype Mar 19 @ 12:52pm 
Originally posted by Kaldaien:
There, should be fixed now:

03/19/2017 15:41:33.914: [ DXGI ] SwapChain: (3840x2160 @ 59.0 Hz - Scaling: Stretched) - {Windowed} [3 Buffers] :: Flags=0x0000, SwapEffect: Discard 03/19/2017 15:41:33.914: [ DXGI ] >> Scaling Override (Requested: DXGI_MODE_SCALING_STRETCHED, Using: DXGI_MODE_SCALING_UNSPECIFIED) 03/19/2017 15:41:33.914: [ DXGI ] >> Refresh Override (Requested: 0.000000, Using: 60)

I'll release a packaged version with config setup for proper fullscreen mode in a few minutes.

Awesome!
Kaldaien Mar 19 @ 1:04pm 
I'll make a new thread for this eventually, for now...

Download / Install
    Special K 0.7.38 (64-bit) with configuration set to fix resolution problems in NieR.

https://github.com/Kaldaien/SpecialK/releases/download/sk_gui/nier_fix.7z

Overview of settings in dxgi.ini

[Compatibility.General] DisableBloatWare_NVIDIA=true ; Disables GeForce Experience / NVIDIA Shield Features, since they are broken for some people. [Render.FrameRate] TargetFPS=60.0 ; Use my framerate limiter, since it performs better - SET TO 0.0 to disable LimiterTolerance=0.05 ; Lower values increase CPU load of framerate limiter for more consistent framerates WaitForVBLANK=true ; Framerate limiter is aligned to VBLANK (fewer dropped frames, possibly lower framerate) BackBufferCount=1 ; Double-Buffered instead of Quad-Buffered PreRenderLimit=3 ; Pre-Rendered Frame Limit, set lower for less input latency but possible stutter PresentationInterval=-1 ; VSYNC (-1 = Game Preference, 0 = OFF, 1 = ON, 2+ = 1/<n> Refresh Rate RefreshRate=60 ;FORCE 60 Hz instead of game's default (59 / 50) [Render.DXGI] MaxRes=0x0 ; Maximum Resolution Listed in-game (0x0 = Unlimited) MinRes=0x0 ; Minimum Resolution Listed in-game (0x0 = Unlimited) Scaling=Unspecified ; Fix Fullscreen Scaling, don't touch this setting

Keybinds

OSD can be turned off by pressing Ctrl + Shift + O, various Special K features can be configured by pressing Ctrl + Shift + Backspace

Misc. Info

On a side note, I also turned off quad-buffering. No idea why Platinum Games thinks that 3 backbuffers in fullscreen mode is needed, but it adds 2 frames of input latency (the OTHER reason you don't want to play this game in fullscreen exclusive mode).
Last edited by Kaldaien; Mar 19 @ 1:05pm
Antitype Mar 19 @ 1:16pm 
Originally posted by Kaldaien:
I'll make a new thread for this eventually, for now...

Download / Install
    Special K 0.7.38 (64-bit) with configuration set to fix resolution problems in NieR.

https://github.com/Kaldaien/SpecialK/releases/download/sk_gui/nier_fix.7z

Thank you, works great. For some reason I can't get the OSD to show up though, the GUI appears normally, but not the OSD. I never had that issue with other games, weird. I'll try and troubleshoot that after dinner I guess.

Ran the game again and it reset my settings and now the OSD works.. oh well, w/e.
Last edited by Antitype; Mar 19 @ 2:32pm
igrat Mar 19 @ 1:17pm 
Originally posted by Kaldaien:
The good stuff
My man, my dude. Let me buy you a beer
< >
Showing 46-60 of 239 comments
Per page: 15 30 50

Date Posted: Mar 18 @ 7:42pm
Posts: 240