Blackmaster17 Dec 25, 2012 @ 1:09pm
Please help only 20 fps on a gaming notebook from asus
Hallo please help me!!! I have just buy darksiders 2 on my asus gaming notebook, but i can run the game with more then 20 fps even if I set it all to low settings. I have a intel i7 on 2ghz boots to 2,9ghz. nvidia geforce 460m 1,5gb. 6gb ram. I can play crysis 2 on high with out lag of any kind. Please say that my notebook not already is to old. Its only 1 years old.
Showing 1-14 of 14 comments
< >
BurningTofu Dec 25, 2012 @ 2:44pm 
Here's a crazy thought... run this under WinXP compatibility. For some reason this game ran faster (30~40fps) when I had WinXP OS but once I upgraded to Win8 (10~20fps), it runs alot slower.
Norke Dec 25, 2012 @ 6:55pm 
I can't say that I can help you, but I will tell you is that it's likely the game and not your computer (if you were looking for confirmation). This game seems to be a bit dodgy as far as ports go and even though they added in more graphical features the optimization was done poorly.
[GVNZET] Dec 25, 2012 @ 7:45pm 
Try turning on Vsync by the way. By default it's off, and normally I'd leave it off, but turning it on seemed to fix a stuttering issue I was having and up my FPS to a playable amount overall. The game is a bad port. Not a bad game, just a bad port, so it's all jacked up on the PC. It's not your system.
Blackmaster17 Dec 26, 2012 @ 8:16am 
thx all its help a bit but now its possible to see when you have killed the enemy. Before its took some time to see when they die.
BlueBanana Dec 27, 2012 @ 7:03am 
stupid idea: have you checked, that DS2 is using the right graphics-card? :)
Your i7-CPU has an internal graphics-card on its own (called "intel hd-graphics" or so).
A while ago, I had the same problem on my laptop too - but with a different game - until I realized that somehow the game starts with the intel-graphics instead of the nvidia.
Blackmaster17 Dec 27, 2012 @ 10:37am 
There is no intel in my gaming laptop. So i think its the right grafik-card ;)
BlueBanana Dec 27, 2012 @ 11:31am 
oh okay. seems to be a weird problem then. Your laptop should be more than capable to handle DS2 with smooth framerates.
I assume your drivers are all up to date?
Blackmaster17 Dec 27, 2012 @ 11:56am 
yes I get a mail when there is coming a now update and if there dont I can see it on facebook
BlueBanana Dec 27, 2012 @ 12:04pm 
any energy-saving functions disabled? try setting the energy-settings to maximum performance (not sure how it's called in english)
[GVNZET] Dec 27, 2012 @ 12:19pm 
Try turning the shadows setting down to low, turn the AA down to 2x, turn AO off (or on, it really doesn't do much), and turn on Vsync if you haven't already, and you should be able to get a good 60fps 95% of the time.
I don't know any other fixes, because once again, it's the game itself, not your system.
I have an Asus G74SX with a 2gb GTX 560m and 8 gigs of RAM, and I still had issues with my fps going below 20 until I tried the above. So I hope that fixes things for you if you decided to try it.
kingfish_ak Dec 27, 2012 @ 12:27pm 
HER IS A GREAT FIX FOR FPS:

Open your task manager, and go to processes, and set the priority of your game to HIGH, and your FPS should be smooth, if not, your pc may need some shovelware removed. Good Luck
Blackmaster17 Dec 29, 2012 @ 3:17am 
thx all i will try
Jaeger Dec 29, 2012 @ 9:23am 
You can enable tons of stuff though your Nvidia controlpanel anyway.

You should force V-sync right away, and add FXAA unless your going with the game own AA on High.

Btw, you can also try Nvidias Beta driver

Good Luck!
Crazy_Nun Dec 29, 2012 @ 7:13pm 
install nvidia driver 295.73 it should work. reinstall when fps drops again
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Dec 25, 2012 @ 1:09pm
Posts: 14