Darksiders > General Discussions > Topic Details
Long Feb 24, 2013 @ 8:18pm
xbox 360 controller problem
hello everyone

I have bought a new xbox 360 controller for my pc, it works perfectlly fine with all the games except darksiders

I can only use start and back botton for my controlle, while all other bottons does not have any response, even I unplug and restart my computer, same case happens

I can't even use my keyboard as control interface when the controller is plugged

anyone have similar experience and have a way to solve this problem?
Showing 1-13 of 13 comments
< >
Frankie-Z- Feb 25, 2013 @ 5:06am 
Try a differnt USB port
Check the devuce manager menue for a conflict.
Try updateing your driver for the controller .
Use the properties menue on Steam to check your Darksiders game files make sure none of the files for the game are corrupt.
Then try dissconnecting other USB devices pluged into your PC and have only the controller pluged in .
Last edited by Frankie-Z-; Feb 25, 2013 @ 5:07am
gunnermac Feb 25, 2013 @ 12:55pm 
In my experience with Darksiders PC and XBOX Controller, I had to be sure my controller was turned on and connected (Wireless) before I started Darsiders. If not then there would usually be troubble with the controller, but when conected before I never had any problems.
Grenadier23 Feb 26, 2013 @ 1:38am 
This game is notorious for not working correctly.

TLDR; Your ♥♥♥♥ won't work, even if it should. You're ♥♥♥♥ed.
rick47601 Feb 26, 2013 @ 2:38pm 
Originally posted by Kaus Mage:
Make sure you don't have another gamepad ENABLED on your computers. I had a logitech G13 gamepad and i did infact make my game go bonkers crazy (camera kept spining, and character wouldn't move, etc.) THE FIX IS go to device manager then go to human interface device and make sure any other game pad is disabled. Right click the game pad device that isn't your Xbox 360 controller and disable it.
Jun_el Feb 27, 2013 @ 5:13am 
Originally posted by rick47601:
Originally posted by Kaus Mage:
Make sure you don't have another gamepad ENABLED on your computers. I had a logitech G13 gamepad and i did infact make my game go bonkers crazy (camera kept spining, and character wouldn't move, etc.) THE FIX IS go to device manager then go to human interface device and make sure any other game pad is disabled. Right click the game pad device that isn't your Xbox 360 controller and disable it.

I had the exact same problem, I had a bluetooth remote control connected and Darksiders kept trying to use that as a controller.

After I removed the remote control it picked up my wireless 360 controller without issue, I've been playing several hours now with zero issues.
Last edited by Jun_el; Feb 27, 2013 @ 5:14am
Zubub Feb 28, 2013 @ 2:10pm 
@ Rick47601, looks like that was the root of my issue. disabled 'HID-compliant game controller' and it worked like a charm.
differances from OP
Controller was Logitech Dule Action.
also ran the XBoxCE for controller emulation.
rick47601 Feb 28, 2013 @ 3:15pm 
I went days with this problem ,upset and just mad. Tell I got it fix.
This is a major problem with this game from some reason
No problems now.I've almost finished the game .Works great .
I'm glad it help .
Last edited by rick47601; Feb 28, 2013 @ 3:16pm
Predator8u Mar 20, 2013 @ 8:21pm 
Originally posted by rick47601:
Originally posted by Kaus Mage:
Make sure you don't have another gamepad ENABLED on your computers. I had a logitech G13 gamepad and i did infact make my game go bonkers crazy (camera kept spining, and character wouldn't move, etc.) THE FIX IS go to device manager then go to human interface device and make sure any other game pad is disabled. Right click the game pad device that isn't your Xbox 360 controller and disable it.

Worked for me Thank You
Last edited by Predator8u; Mar 20, 2013 @ 8:21pm
Darken Mar 23, 2013 @ 3:55pm 
In regards to an x360 wireless controller, I've found that it NEEDS to be set to Player 1 (Left top indicator on the controller). The game could not spot it otherwise.
Cramique Jul 10, 2013 @ 2:23am 
For Anyone with the 360 Controller problem: Download xinputemu from microsoft (just google it); open the zip file and put 'dinput8.dll' in your game directory. this solved the problem for me.
This fix also works on other games like DMC.
Wintermute Dec 26, 2013 @ 8:04pm 
Originally posted by rick47601:
Originally posted by Kaus Mage:
Make sure you don't have another gamepad ENABLED on your computers. I had a logitech G13 gamepad and i did infact make my game go bonkers crazy (camera kept spining, and character wouldn't move, etc.) THE FIX IS go to device manager then go to human interface device and make sure any other game pad is disabled. Right click the game pad device that isn't your Xbox 360 controller and disable it.

This did the trick for me as well. I have a Razer Tartarus and I had to disable it before I could use my Razer Sabertooth controller.
Snake_MPP Dec 27, 2013 @ 2:24am 
You should reinstall the drivers of the controller or change the configuration of the game
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Feb 24, 2013 @ 8:18pm
Posts: 13