pret132 Nov 5, 2013 @ 11:43am
In need of “PecanEngine.ini” EXPERT!
I’m running ACM on a Duo-core with an ancient HD4890.
I have already put the texture-, world- and shadow-detail on the lowest settings.
And I’m playing at 1680 x 1050 which is the lowest acceptable resolution for me.

I’m so freaking close to getting an solid 60 fps with these settings!
But when scenes get very hectic, my frame-rate will still drop to about 50,
which I find to be unacceptable.

I already tumbled around with the [SystemSettings] section, with some very strange effects: Disabling Dynamic Lights & Dynamic Shadows don’t seem to do anything?
Adding more memory to my Poolszie also has no effect.
Only disabling Bloom works and gave me another 3 fps.

The really strange stuff happened when I started to copy the settings from [SystemSettingsMobile] and the [SystemSettingsSplitScreen2] section in my the [SystemSettings]. In one of my earlier attempts I managed to disable all shadows,
but I haven’t been able to reproduce it.

Could a “PecanEngine.ini” –expert help me on the way,
I’m willing to do big graphical concessions to get an solid framerate, except setting the FloatingPointRenderTargets to False, because that makes it look very, very ugly!

And what’s the difference between False and FALSE (in capitals) command-wise?
Last edited by pret132; Nov 19, 2013 @ 7:46am
Showing 1-7 of 7 comments
< >
thebluekosh Nov 6, 2013 @ 10:41am 
First try not to tamper with the PecanEngine.ini file,instead lower your graphics settings because after post patch the graphics were improved(hi-res textures now).
Secondly if you feel the need to alter the PecanEngine.ini file the change HUD Blue effects to false,this will remove the 3D eyepiece effect and turns off the Blue colour but it will considerably improve performance.
Thirdly if you do not wish the removal of this effect get a better system.
pret132 Nov 14, 2013 @ 11:53am 
@thebluekosh
Ty for the info.
Could you provide me the exact command for that “HUD Blue effect” thingie?

: )
I tampered with the PecanEngine.ini file in a big way… and I got it working!
I really have no idea how I did it,
but with these settings I get a very solid 60 fps on my ancient system,
and it still looks “pretty”.

IMPORTANT!
-The Lighting needs to be rebuild on every load!?
-Some settings don’t seem to do anything until you combine them with other changes?
-And I’m also using 3DOverider to force triple buff. & V-sync out of the game.

Also, I haven’t been able to reproduce disabling all the shadows,
but these changes made the game playable for me.
In very Hectic scenes my framerate remains a silky smooth 60 fps.
Mucho importante!

[SystemSettings]
bUseMaxQualityMode=False
StaticDecals=False
DynamicDecals=False
UnbatchedDecals=False
DecalCullDistanceScale=1.000000
DynamicLights=False
DynamicShadows=False
LightEnvironmentShadows=False
CompositeDynamicLights=False
SHSecondaryLighting=False
DirectionalLightmaps=False
MotionBlur=False
MotionBlurPause=False
MotionBlurSkinning=0
DepthOfField=False
AmbientOcclusion=False
Bloom=False
FXAA=False
UseHighQualityBloom=False
bAllowLightShafts=False
Distortion=False
FilteredDistortion=False
DropParticleDistortion=False
bAllowDownsampledTranslucency=False
SpeedTreeLeaves=False
SpeedTreeFronds=False
OnlyStreamInTextures=True
LensFlares=False
FogVolumes=True
FloatingPointRenderTargets=True
OneFrameThreadLag=True
UseVsync=False
UpscaleScreenPercentage=True
WindowMode=0
AllowD3D10=False
AllowRadialBlur=False
SkeletalMeshLODBias=1
ParticleLODBias=1
DetailMode=0
ShadowFilterQualityBias=-1
MaxAnisotropy=0
MaxMultisamples=1
MinShadowResolution=64
MinPreShadowResolution=8
MaxShadowResolution=256
MaxWholeSceneDominantShadowResolution=1344
ShadowFadeResolution=16
PreShadowFadeResolution=16
ShadowFadeExponent=0.250000
ShadowFadeTime=0.500000
MaxTemporaryShadows=2
MaxShadows=4
MaxFadingShadows=2
MaxShadowDistance=5000.000000
ShadowDistanceMultiplier=0.250000
bUseFocusLightThrottle=TRUE
MaxFocusLightDistance=240.000000
ResX=1680
ResY=1050
ScreenPercentage=100.000000
SceneCaptureStreamingMultiplier=0.500000
FoliageDrawRadiusMultiplier=1.000000
ShadowTexelsPerPixel=1.000000
PreShadowResolutionFactor=0.500000
bEnableVSMShadows=False
bAllowHardwareShadowFiltering=True
bAllowBetterModulatedShadows=False
bEnableForegroundShadowsOnWorld=False
bEnableForegroundSelfShadowing=False
bAllowWholeSceneDominantShadows=False
bForceRequestedShadowsOn=False
ShadowFilterRadius=2.000000
ShadowDepthBias=0.012000
CSMSplitPenumbraScale=0.500000
CSMSplitSoftTransitionDistanceScale=4.000000
CSMSplitDepthBiasScale=0.700000
UnbuiltWholeSceneDynamicShadowRadius=20000.000000
UnbuiltNumWholeSceneDynamicShadowCascades=3
WholeSceneShadowUnbuiltInteractionThreshold=50
bAllowFracturedDamage=True
NumFracturedPartsScale=1.000000
FractureDirectSpawnChanceScale=1.000000
FractureRadialSpawnChanceScale=1.000000
FractureCullDistanceScale=1.000000
bForceCPUAccessToGPUSkinVerts=false
bDisableSkeletalInstanceWeights=false
FOVOffset=38

I also added:
[TextureStreaming]
PoolSize=700

[Engine.Engine]
bSmoothFrameRate=True
MinSmoothedFrameRate=72
MaxSmoothedFrameRate=120

ANY MORE TWEAKING ADVICE IS VERY WELCOME!!!
thebluekosh Nov 14, 2013 @ 12:14pm 
It must have been another file.I think it said effectHudblue=true/false or Hudblue=true/false you will know because it's right next to it is Hud=true/false,keep searching and you will find it.
thebluekosh Nov 14, 2013 @ 12:15pm 
Try game settings file.
pret132 Nov 19, 2013 @ 8:21am 
“change HUD Blue effects to false,this will remove the 3D eyepiece effect
and turns off the Blue colour but it will “considerably” improve performance.”

???

No sigar!
No "HUD Blue effects" anywhere to be found.
I found "HudCanvasScale=0.95" in the "PecanGame.ini"
but any changes here don't seem to register.

Could you plz elaborate a bit more upon this tweak,
I would sell my grandmother for only a few fps more in this game!!!

Would just disabling the hud altogether in this game also have the same positive performance effect? At the moment I’m toggling the hud on and off with this command:
Bindings=(name="F7",Command="Togglehud")
It gains me about 2 fps more in my testing-setup, which isn't actually all too bad.
But is this really the “considerably” improved performance you are talking about?
thebluekosh Nov 19, 2013 @ 11:14am 
On my version you could turn the Blue and the 3d curvature of the HUD with this one command,try hudeffects=false it's not in PecanGame.ini try Setting.ini or in another file in the same folder that PecanGame.ini is in.
pret132 Dec 5, 2013 @ 2:26pm 
Found it!

bWithHUDEffects=false // true

It’s in the PecanUI.ini file,
which is located in:
My Documents\My Games\Aliens Colonial Marines\PecanGame\Config folder.

I was hoping it would gain me a few fps extra,
but as you said, it does something much better.
It gets rid of the FLOATING HUD & CROSSHAIR!
In the vanilla game the HUD & CROSSHAIR will TRAIL behind your mouse movements in a feeble attempt to create a 3d Helmet cam effect?
If you set this variable to false, it will get rid of that 3d curvature and thus making your Hud & Crosshair Flat. The crosshair is still dynamic, but it won’t trail anymore which is freaking great!
Pretty elemental stuff here.
TY!
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Nov 5, 2013 @ 11:43am
Posts: 7