Amzurrel Oct 2, 2012 @ 8:28pm
The Steam servers are too busy to handle your request for Borderlands 2. Error Code (55)
I don't know how to fix this and I need help. I ran it just fine when it came out, then for about one week my computer was down. Then when I was able to play again (a week later) I get this code and it won't let me play, all of my other games work just not borderlands 2.

I have tried the http://suppert.steampowered.com fix with no success
I tried restarting my router
I made sure my anti-virus was not blocking it
and last I have ran it as administrator

Nothing has worked and I am at my wits end please help
Showing 1-15 of 33 comments
< >
Pudge Oct 2, 2012 @ 8:40pm 
Same thing has happened to me, I launched a bunch of other games and I tried restarting everything, still getting Error Code 55. I'm incredibly bummed that I can't play right now.
Amzurrel Oct 2, 2012 @ 8:43pm 
its the first time I have had a problem with steam and after looking forward to being able to play againg after a week of playing nothing; it is a serious let down
Pudge Oct 2, 2012 @ 8:46pm 
I've been looking around for about 45 min and it seems like a bunch of people had this problem at launch, but eventually it fixed itself? People just stopped posting or said it just worked again after a bit. But then I go on here and within the last 10 min there have been three threads about it. Seems like it might just be something wonky on Gearbox's end, but it certainly doesn't help chaps like you or me without unlimited time to play games :/
Stonechitlin Oct 2, 2012 @ 9:00pm 
same problem here. i have been playing the game fine, hadn't touched it in about 4 days, now this.
[ADD] TOMMY PIKKLES Oct 2, 2012 @ 9:44pm 
I am also experiencing this and have tried everything that OP has. I even uninstalled my anti-virus completely and the same error still shows up.
bigninja1 Oct 2, 2012 @ 11:11pm 
Happening to me too. Ugh. Anybody get it working?
BeingtheDuke Oct 2, 2012 @ 11:12pm 
Still getting error here too.
Ph.D. Sith Oct 2, 2012 @ 11:16pm 
Same problem here...
Last edited by Ph.D. Sith; Oct 2, 2012 @ 11:16pm
BeingtheDuke Oct 2, 2012 @ 11:22pm 
I just tried to play Risen 2 and got the same error. It must be the new update.
BeingtheDuke Oct 2, 2012 @ 11:23pm 
...and Total War Shogun 2
Ranjoy (scorpian007) Oct 2, 2012 @ 11:49pm 
I'm having the same issue with Borderlands 2 too, haven't played it since Thursday and it won't work today :/
bigninja1 Oct 2, 2012 @ 11:54pm 
OK. I got it running again. Opted out of the beta. (steam>settings>beta participation >Change > none. Then I downloaded the steam installer from steampowered.com, did a REPAIR install, and that did the trick. Hope this helps.
CheezNCrakrz Oct 3, 2012 @ 12:39am 
^^ This suggestion works perfectly. Thanks @bigninja1 for the suggestion
Untold Serenity Oct 3, 2012 @ 3:07am 
i just got same problem did what the steam support said to but still was borked. so im going a reinstall to see if it fixs it. and i may try @bigninja1's idea
Last edited by Untold Serenity; Oct 3, 2012 @ 3:08am
Michi Oct 3, 2012 @ 4:46am 
It works after quitting beta, u must not repair install steam
Showing 1-15 of 33 comments
< >
Per page: 15 30 50
Date Posted: Oct 2, 2012 @ 8:28pm
Posts: 33