Bloopa Sep 21, 2012 @ 3:09am
Really poor frames no matter what settings
I have a decent System and I feel there is something wrong with borderlands 2 as I cant seem to get over 30 fps after putting everything on low and a low resolution. But then again turning everything up to ultra with high physics I am only getting 15 max .

I feel like it is a problem with something in the drivers or a poor setting in the game that is making it run worse than it should . Just to put it in contrast I run the Witcher 2 on my system at high settings and get 60fps and in ultra settings i get 30 - 40 .

I also downloaded the 12.8 update for my graphics card it said something in it about borderlands 2 but i think that was for duel card setups

My system specs are
Intel i7 870 quad running at 2.94 ghz
8 gig 1600hz ram
ati 7970 graphics card
Showing 1-7 of 7 comments
< >
「C❤A」 Pocahawtness Sep 21, 2012 @ 3:17am 
At the moment it seems that Borderlands 2 doesn't really like ATI. Have you tried installing the Physx software from Nvidia? Some say it helps.
Fishburt Sep 21, 2012 @ 3:21am 
Are you sure you don't have the frame rate set to one of the range options? Is it set to unlimited?
NightCreature Sep 21, 2012 @ 3:35am 
It doesn't like NVidia either to be honest just tried on a 560 TI and frame rate is also stuck arround 15fps
Uri Sep 21, 2012 @ 3:36am 
QuadCore 2,4Ghz
4Gb Ram 800hz
NVIDIA GTX 550 Ti

All graphics on 1920x1080 and mostly high graphics, running at 40~60 FPS, I think BL2 is very GPU based.
Rafe Sep 21, 2012 @ 4:06am 
Try Orochi-CEG
Bloopa Sep 22, 2012 @ 6:33pm 
I found out what my problem with the game was , in my ati settings i have over ride settings on set aplications , I had nothing set up for borderlands but when i went into and just disabled any custom settings and now my game is running at a solid 60 frames . I feel like a total fool for not thinking of this before posting it
eliasr50 Sep 23, 2012 @ 5:08pm 
I can't say the same. I have a phenom 960t and an amd 7770, budget friendly build. I get around 60-80 fps max settings with fraps on. check your ccc and windows power plan.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Sep 21, 2012 @ 3:09am
Posts: 7