The Ghost of Rutherford B Hayes Sep 20, 2012 @ 9:13pm
Choppy framerate persists, despite trying all fixes
Specs:
AMD FX-8120 3.1GHz
8GB DDR3 1333
Nvidia Geforce GTX 560 2GB

I have tried:
-Installing (and reinstalling) latest Nvidia video card drivers (ver 306.23)
-Setting PhysX on low (won't let me turn it off)
-Reducing resolution
-Setting all Video options to Low (as well as Medium and High)
-Playing under each and every Framerate Option (Unlimited, Smoothed, etc)
-Playing in Offline Mode as well as disconnecting the PC from the internet entirely
-Changed "MinDesiredFrameRate=35.000000" to "60.00000)" in the .ini file
-Playing in Windowed Mode (this has given me *slightly* better framerate, but it's still horrible when I'm playing with other people online)

None of these options have made one bit of difference-- I still experience terrible, laggy, choppy framerate whenever I'm in a large, wide-open area with several enemies or NPCs. It's getting incredibly frustrating, as every single person I have talked to (with PCs far better and far worse than mine) have been experiencing silky smooth gameplay.

Borderlands 1 plays perfectly on my PC. So does Skyrim. And TF2. And every single other game I have. It's only Borderlands 2 that brings it to its knees, and it's driving me insane.

Does anyone else have this set-up? Are there any other fixes to try?
Last edited by The Ghost of Rutherford B Hayes; Sep 21, 2012 @ 11:24am
Showing 1-10 of 10 comments
< >
vovolagina Sep 20, 2012 @ 9:18pm 
try what i posted. its probably because you have an amd processor.

http://steamcommunity.com/app/49520/discussions/0/882960797640643281/
The Ghost of Rutherford B Hayes Sep 21, 2012 @ 5:49am 
Your download link has expired, and I can't seem to find anything official talking about Orochi when I search Google for it.
Last edited by The Ghost of Rutherford B Hayes; Sep 21, 2012 @ 5:50am
「C❤A」 Pocahawtness Sep 21, 2012 @ 6:00am 
I don't think there is necessarily anything to do with your CPU. There are some reports of the same thing for intel cpu's and nvidia and ati gpu's. I have had a look at the graphical loading of borderlands 2, and it isn't that high. There is obviously something strange going on, I guess all will become clear in time.
The Ghost of Rutherford B Hayes Sep 21, 2012 @ 8:46am 
What makes no sense to me is why Borderlands 1 runs perfectly on the same PC that has trouble with Borderlands 2. This makes me think that it's a problem with PhysX, specifically.

Apparently a handful of people are having luck with going into their Nvidia control panel and switching their PhysX processing over to the "GPU" only. This seems like the last fix I've yet to actually try out. When I checked it last night, mine was set to "Auto-Select", instead of "CPU" or "GeForce GTX 560"aka "GPU"

I guess since most games I've been playing haven't been too PhysX-intensive, "Auto-Select" means it's been trying to use the CPU, which makes for the distinct possibility that this is what is causing all the choppiness. I'll try switching it over to GPU tonight and see if that helps. I'll be sure to update this thread, since it sounds like there are other people in the same boat as me.

If that doesn't work, I guess I'll have to start squawking at the developers for a patch or something.
neo_nille Sep 21, 2012 @ 8:52am 
Have you tried lowering the view distance? That helps for me...
The Ghost of Rutherford B Hayes Sep 21, 2012 @ 8:54am 
@neo_nille, Yes, I have. I've tried lowering view distance, textures, turning on and off bullet marks, lowering PhysX, etc. Thanks for the suggestion, though!
Jinx Sep 21, 2012 @ 10:11am 
Try this tweak, it helped me and I have a Phenom II x6:

First, my in-game settings are:
Vsync: off
Framerate: unlimited

Then go to My Documents and open the engine config file (back it up first!):
C:\Users\*username*\Documents\My Games\Borderlands 2\WillowGame\Config\WillowEngine.ini

Search for
MinDesiredFrameRate=35.000000
change it to
MinDesiredFrameRate=60.000000

Before that my fps bounced from 30 to 60 (exactly) depending on which way I was facing. Now it never goes below about 55 (facing the direction that used to get down to 30).


I am running a mid-high end AMD system:

Phenom II x6 1090T
HD6870 1GB
8GB DDR3
Win7 64-bit
1920x1200
PhysX on Low, AF 8x, everything else maxed.
The Ghost of Rutherford B Hayes Sep 21, 2012 @ 11:23am 
@Jinx, thanks for the suggestion. I should've been even more descriptive in my original post-- I actually came across your fix earlier and already made this tweak to the .ini

It could just be a placebo effect, but it seemed to help (only slightly). In any event, these are the settings I'm making do with at the moment. Do you find that playing online with other people aggravates the choppiness even more? Last night, the game was pretty playable up until I joined a friend's game. When we started running around Sanctuary the fps took such a hit I couldn't even play.
The Ghost of Rutherford B Hayes Sep 22, 2012 @ 7:21am 
Update: I tried changing the PhysX processing to GPU only via the Nvidia Control Panel, and for a while, it really did seem like it made a noticeable difference in-game. I played for about 3 hours, about 2 of those hours were relatively smooth, but later on the game started getting choppy again.

I would suggest people having similar problems try this fix. It might be temporary, but it does seem to help a bit.
OliverRC Dec 17, 2012 @ 11:55pm 
I was have the same issue on a system easily capable of Ultra:
Installing the latest PhysX drivers even when running PhysX on low solved my issue:

http://www.nvidia.com/object/physx-9...31-driver.html
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Sep 20, 2012 @ 9:13pm
Posts: 10