K1llJoy 913 Jul 25, 2013 @ 8:47pm
Borderlands 2 suddenly can't join any games or view matches
Hi guys so I am having some serious trouble here trying to play borderlands 2 with my friend(or anyone else). I can play single player fine, but if I try to join a game, someone joins my hosted game, or if I try to browse available matches I get an infinite loading screen and have to ctrl alt delete. I had been playing with my friend last week just fine, then I got a new computer and this issue came up. I googled it and tried reinstalling, and checking game cache. When I check game cache it says something about one file failing to validate, it redownloads it, and then still same problem. In fact if I validate cache back to back, it will still say that that one 12.5mb file failed to validate, and I can validate it infinitely without any success. Any ideas? I have tried disabling firewalls and anti virus, but nothing seems to work.
Showing 1-15 of 17 comments
< >
Odin Jul 25, 2013 @ 9:01pm 
Have you checked your Network Settings in the Borderlands 2 pause/main menu?
K1llJoy 913 Jul 25, 2013 @ 9:10pm 
Yeah, it's set to online friends invite only. It isn't set to offline or anything.
Sin Jul 25, 2013 @ 9:14pm 
Have you tried:
a. restarting your computer, router, and steam client
b. verifying game cache files
c. aquiring a new IP address
K1llJoy 913 Jul 25, 2013 @ 9:15pm 
I have tried everything but acquiring a new IP address. How would I go about doing that?
Sin Jul 25, 2013 @ 9:15pm 
google :)
Last edited by Sin; Jul 25, 2013 @ 9:16pm
K1llJoy 913 Jul 25, 2013 @ 9:19pm 
Any other ideas while I am doing this? I honestly doubt it will fix it, it seems like an issue with bl2 not something on my end. All other games/software don't have any issues, and my internet connection is fine. Also, the infinite loop of validating that one 12.5mb file also makes me think this is a steam/bl2 issue.
Sin Jul 25, 2013 @ 9:25pm 
I had the same thing happen about a week ago, suddenly couldn't play multiplayer for no explainable reason. Forcing my router to aquire a new IP address worked for me... Or it was pure coincidence that it started working again straight after I did it.
K1llJoy 913 Jul 25, 2013 @ 9:26pm 
Oh okay. So then if/when you validated game cache, did it continuously say that 1 failed to validate and then download a 12.5mb file?
Sin Jul 25, 2013 @ 9:40pm 
I just verified mine and it did 6 files... I had a crash yesterday though so maybe that caused some corruption.
K1llJoy 913 Jul 25, 2013 @ 10:03pm 
Yeah that didn't work, just finished trying it :/ This is really irritating my friend bought the game during the steam sale and I promised I'd play it with him, and now this happens.
MaNiTron Jul 25, 2013 @ 10:10pm 
I usually experience the same errors....

Closing and restarting Steam should resolve.
K1llJoy 913 Jul 26, 2013 @ 11:10pm 
I don't understand.. I have closed and restarted steam hundreds of times. It has never done anthing. What are the errors that you experienced? The validate game cache infinite loop or the inability to join another person's game?
Sin Jul 27, 2013 @ 12:03am 
One last thing I can suggest.
Get Borderlands 2 running, alt+tab to desktop, go to your friends profile page in the steam client, click join game, alt+tab back into BL2.
If your friend is unavailable to test this, feel free to add me and use me to test it.
Last edited by Sin; Jul 27, 2013 @ 12:06am
Koala-Fied Badass Jul 27, 2013 @ 12:36am 
im having the same problem with my boarderlands2 it says that my game is missing 1 of the 2 authenticity files or something like that so i cant play online with anyone else o.o
K1llJoy 913 Jul 27, 2013 @ 11:42am 
Yeah captain, that's what it seems like. And sin, I tried that and got an interesting result. It lets me join the game which is farther than I get before, but then I only get about 5 seconds before the game freezes. This just makes me think more and more that it has to be something related to failure to authenticate properly.
Showing 1-15 of 17 comments
< >
Per page: 15 30 50
Date Posted: Jul 25, 2013 @ 8:47pm
Posts: 17