go2hel Feb 11, 2013 @ 3:47pm
670 sli performance
Just started playing today. Pretty good game. I just got done escorting claptrap to his ship during this sequence my fps dropped into the 50s a bit. I just want to know if its normal for my setup. 670 sli with 3770k at 4.5ghz, 8gb ram and an ssd.
Showing 1-15 of 26 comments
< >
jsachun Feb 11, 2013 @ 4:33pm 
600 series are known to have issues with older generation game engine. I think it's been optimized for DX10 & DX11. I believe B2 still uses DX9. If you play a lot of old games then stick with 500 series, if you only play new games that utilize DX10 & DX11 then buy the 600 series.
go2hel Feb 11, 2013 @ 4:45pm 
i think its just physx acting up because when i turn it down i dont go below 60
skorchi Feb 11, 2013 @ 5:48pm 
What resolution are you playing at? As you have already noted, Physx is a culprit to FPS drops. It seldom occurs, but there are spots where it is very noticeable (Opportunity map comes to mind).
go2hel Feb 11, 2013 @ 6:16pm 
Playing at 1080p only played for like an hour today but noticed the drops when I was escorting claptrap (best minion) to the top where claptraps ship was. Only once in awhile saw it go to the low 50s when a lot of shooting is going on . Lowering phys x stopped it from goin into the 50s but in some spots it does drop to 65 but that doesn't bother me.
jsachun Feb 11, 2013 @ 6:25pm 
i'm using a 560gtx and have no issues with phsx turn to medium playing at 1920x1200 with evrything tuned to max. Haven't tried high on physx yet. But only issues I have is lag that I get sometimes when saving in multiplayer.
bubbacho Feb 11, 2013 @ 6:25pm 
Yep the Physx is a frames sucker. I'm using a GTX 690 on a 30" monitor at 2560x1600 and I finally turned off Physx altogether. Frame rates would drop down into the 40's at times and all of those particles just got annoying. At times I couldn't even see what I was shooting at.
neema_t Feb 11, 2013 @ 6:28pm 
I have a GTX 680 and it makes no difference if I play at 5040x1050 or 1680x1050, the frame rate is usually 60 but often drops when looking out over a level. For example, if I turn around where the Badass Constructor spawns in Thousand Cuts it'll usually drop slightly. PhysX seems to make no difference for me, no matter how much is going on it doesn't really seem to slow anything down. It's a 2GB MSI Twin Frozr III OC, if that makes any difference.
jsachun Feb 11, 2013 @ 6:29pm 
Judging by the size of the board of the new 600 series, I wouldn't buy it. Looks like a reused $100 board with new chips imo.
neema_t Feb 11, 2013 @ 6:31pm 
Originally posted by jsachun:
Judging by the size of the board of the new 600 series, I wouldn't buy it. Looks like a reused $100 board with new chips imo.

Yeah I thought the colour looked a bit off, kind of looked like a late 90's laptop motherboard. Smells funny too.
bubbacho Feb 11, 2013 @ 6:35pm 
I wonder if its CPU dependent? My processor is a 980X EE which when I bought was the bee's knee's but is old by today's standards. And I Iove the 690 board. I had two HD 7970's in crossfire and my system was like a hair dryer at full load. The GTX 690 not only sucks up less power but its also quiet.
go2hel Feb 11, 2013 @ 6:44pm 
So I guess it isn't just me... good to know I'm always suspicious that my computer performs worse than the rest
go2hel Feb 11, 2013 @ 6:50pm 
And by the way I got two msi pe oc 670s they perform at the same level as a 690 stock for more than $200 less and are very quiet
bubbacho Feb 11, 2013 @ 7:32pm 
Well a 690 is just two 680's on one board. I bought it just because it received mad reviews and solved the noise issue with the 7970's (which I also paid over a grand for). I guess I have more money than brains.
TheeMrGuy Feb 11, 2013 @ 9:29pm 
I have almost the same setup with 2 reference 670's slightly oc'ed, i7-3930 at 4.5GHz, 16GB ram and SSD. I have all settings maxed 1080p with PhysX on high. Even if I'm recording, I only drop below 60 fps when I fast travel. I also have vsync on at 60fps capped or my cards will crank the fans, get hot and downclock themselves resulting in worse performance. Only main difference between us is the processor so I wonder if bubbacho is right with PhysX being CPU dependant...
Dr. Orange Feb 12, 2013 @ 4:40am 
Nothing wrong with your setup Go2hel (lol for the name^^)
There are many types of lag, graphics lag is not what you have.
I've got 2 GTX690's, still getting some stutter here and there.
Don't worry about it^^
Showing 1-15 of 26 comments
< >
Per page: 15 30 50
Date Posted: Feb 11, 2013 @ 3:47pm
Posts: 26