Magic: The Gathering — Duels of the Planeswalkers 2012

Magic: The Gathering — Duels of the Planeswalkers 2012

Statisztikák megnézése:
Forest Fury bugged
Seems that forest fury's card cannot be unlocked anymore; if I unlock them but restart the game, i get back to 0/20. Any clues?
< >
112/12 megjegyzés mutatása
Before exiting game, go into deck manager. Remove a card, put it back and save. That ought to fix it.
Tried it and it didn't work.
I also have this problem. It used to work fine and I had everything unlocked, but at some point that it lost everything and I can only have it unlocked for as long as I have the game running.
Has anyone found a real fix for this... this is LITERALLY the last deck I have to unlock, and I can't keep any of the cards saved (maybe that's why it's the last deck, maybe I actually unlocked it before and forgot!).

I have so many hours played on this game it's stupid cuz I unlocked each deck one at a time (and mostly though archenemy, which seems to be the longest match).

Love it though, just need this last deck.
Legutóbb szerkesztette: Fluxion; 2013. jún. 18. @ du. 7:11
I have this problem too. From what I've read, having the Forest Fury deck fully unlocked when downloading Deck Pack 3 causes the savefile to get corrupted. I don't know how to fix it, and would appreciate any help.
Bump. This is still an issue with no solution :(
Looks like I found a rather permanent solution [check the new warning below], but you will have to unlock everything from 0. So, to begin with this bug is related to addition of Deck Pack 3 under certain condition: if you purchased Deck Pack 3 when Forest Fury had already been unlocked, this bug happens and it corrupts your userdata for this game, which make the bug persistent like forever.

At some point a new feature was added to Steam: we can enable and disable any DLCs we have for a game. To get rid of the bug you need to start a fresh game (your current is corrupted) with Deck Pack 3 DLC disabled to avoid corruption, then enable the DLC while your Forest Fury is not fully unlocked.

1. Go to Library, choose MTG 2012 and disable Deck Pack 3 DLC (depending on your Library view you might have to rightclick it, choose "properties", then click on "DLC" tab, untick "Deck Pack 3"). If you have Deck Key for full unlock of Forest Fury, it might be a good idea to disable it too.
2. Disable cloud sync for this game.
3. Delete userdata for this game by deleting everything in C:\Program Files (x86)\Steam\userdata\[your profile number]\49470
4. Launch the game. It will be like the first time: default settings, everything locked. e.t.c. You can play a game with Forest Fury to unlock 1 card, then exit the game and launch it again just to make sure that everything works at this point.
5. You can enable cloud sync now. If you do, choose "upload from this computer to cloud" during next launch.
6. If you intend to play Deck Pack 3, enable it now, while Forest Fury is not fully unlocked. Otherwise, if you unlock Forest Fury first and then reenable Deck Pack 3, the bug will likely corrupt your data again. So avoid such condition.

Now you can play normally without the nasty bug.

One more thing though... There is a minor issue with this game: sometimes when you exit the game, it will be stuck in running mode (it will show that you are in-game although you are actually not). When this happens, you can't shut down Steam, because it thinks that application is still running. If you reboot your computer, everything will be fine except that the state of your DLCs for MTG (which ones are enabled and which are not) may revert to an earlier condition.
If Deck Pack 3 gets disabled, reenabling it with Forest Fury already unlocked may corrupt the data. So before doing so it is highly recommended to back up your userdata (folder "remote" and file "remotecache.vdf") somewhere, so that you always have your spare uncorrupted version.

I am currently working towards full unlock of Forest Fury and going to test it further. Will post about what turns out.

Edit: worked like a charm. I now have fully unlocked Forest Fury and it doesn't reset after exit no matter what. I even tried disabling and re-enabling Deck Pack 3 DLC.

I am very glad to play this wonderful game again. While interface and mechanics are better in 2013 and 2014, it is the 2012 that has the best atmosphere, best music and fresh deck ideas (later games copied too much from these).

Warning: I actually experienced the nasty reset bug once again and had to go back to backup data losing a few campaignes progress (I stopped making backups at some point believing it was safe). I think it happened after the game crashed, Deck Pack 3 DLC became inactive and I launched the game without re-enabling first.

So, as long as you have a good uncorrupted data I suggest you back it up each time after exiting and then checking it by launching the game. If at some point you see that Forest's Fury had reset, use your backup data to fix the issue. This way you can eventually walk through all the campaignes a keep the clean data.
Legutóbb szerkesztette: Stormmaster; ápr. 9. @ de. 4:27
Now I encountered this bug 2 more times, each time after beating Ral Zarek and getting his deck (I keep going to backup data, everything works, then Forest's Fury unlocks disappear just when I get Cloudburst deck).

Going to check out what will happen if I start a fresh game, first go through expansion and beat Ral Zarek, and only then try to start unlocking cards for Forest's Fury...

edit: I started a fresh game, went right to Expansion and completed Liliana, Ajani and Ral using the most basic of all decks, Gideon's. Then I played a custom game with Forest's Fury and unlocked 1 card. Exited, relaunched, it didn't disappear. Then I even played Ral Zarek with Forest's Fury deck and unlocked 3 more cards. No resets!

So now I am going to unlock all 20 and see if everything keeps stable.
Legutóbb szerkesztette: Stormmaster; ápr. 13. @ de. 11:05
Well, Forest's Fury still got reset to 0 after I played against Karn in the main campaign. Looks like it has something to do with unlocking Revenge campaigns. So I once again started a fresh game and went through the whole campaign and the expansion using just basic Gideon's deck. Then I tried Forest's Fury, unlocked the first card, exit, launch... bug, FF has 0 unlocks.

Now I am going to try repeating all this again, but this time I will keep all deck packs uninstalled during the whole walkthrough.
Stormmaster I applaud your efforts to find a permanent fix for this bug. This has been a big one for me as Forest Fury was one of my most favorite decks to play. The next couple of interations have similar bug where there is at least 1 deck that will not stay unlocked. In 2014 it has to do with there are 2 more total decks than the game is programmed to save (possibly to cloud only, but do not recall fully).

I love the series, and can handle the bumps along the way, but realy wish they would fix the bugs with saving this progress in the old games as it keeps locking us out of content allready paid for.
Also experiencing this bug. Any known solution yet?
< >
112/12 megjegyzés mutatása
Laponként: 15 30 50