oracle certified professional 1 sept 2013 à 13h36
Linux Crashes
I thought I might as well post this incase it helps someone who was having the same problems I was having. I'm using Ubuntu 12.04 with an AMD/ATI 5750 graphics card.

ns2 on start was just going to a black screen and mouse pointer before crashing back to the desktop. I managed to fix this by reverting my AMD / ATI graphics drivers package from fglrx-experimental-13, version 2:13:101-ubuntu-0.0.2 to fglrx-updates, version 2:12.104-0ubuntu0.0.1.

There are still some graphics issues and performance problems, but at least I have been able to play through the tutorial.
Affichage des commentaires 1 à 14 sur 14
< >
Linux.PlayX 1 sept 2013 à 14h25 
texture details have to be on middle. on high you will have crases and graphic errors
http://steamcommunity.com/sharedfiles/filedetails/?id=173999794
Dernière modification de Linux.PlayX; 1 sept 2013 à 14h32
TheRoot 1 sept 2013 à 15h13 
Tried this game ealier today, but it crashed my linux box hard... no I/O after crash.
Dernière modification de TheRoot; 1 sept 2013 à 15h13
Nibodhika 9 oct 2013 à 5h19 
I really want to buy this game, but when I tryed it on a free weekend it didn't even start on my computer with an intel GPU, and it was REALLY laggy (like 2 fps) on my AMD gpu computer. Is this a problem with my system (Arch Linux x64) or anyone else is having this crash?
ChrisPlaysLinux 9 oct 2013 à 11h03 
intel GPUs dont even come near being able to run this game lol!
Nibodhika 9 oct 2013 à 11h21 
I tried with the intel because it just keeps surprising me, I wasn't surprised when it didn't start, but since I can run Crusader Kings II perfectly in it, and the GPU requirements are about the same, I figure it wouldn't hurt to try.

But the AMD computer has the recommended settings and still runs at 2fps. So I want to know if anyone managed to run this on an AMD, and if so which one.
ChrisPlaysLinux 9 oct 2013 à 12h17 
GPU requirements obv are way too high on CK2. intel GPUs are crap no matter what. What do you mean AMD computer? what is your CPU and GPU
Nibodhika 9 oct 2013 à 19h12 
Intel I5, Radeon HD 6550M with 1GB dedicated memory, 4GB RAM. Also my system is minimalistic, consuming 100MB of RAM, so that should be enough RAM to run the game with textures on medium. Not top of the line, but should run this game.
ChrisPlaysLinux 10 oct 2013 à 2h21 
i am sorry but that is not enough to run this game especially because its a laptop it runs hot and throttles down the speed to compensate.
Nibodhika 10 oct 2013 à 3h57 
=/ that's a shame, I only have those two laptops, I guess I'll have to wait for the SteamMachines to play this game
JKflipflop 14 oct 2013 à 9h29 
I cant even play the game under Linux. I can see the main menu and the super-low-detail version of the lobby then I crash back to desktop. Tried it with 310 and 313 drivers and the same thing.
ChrisPlaysLinux 14 oct 2013 à 11h42 
did you run steam in a console?
Rose 31 oct 2013 à 8h57 
I'm running Linux Mint 15 and I've had no issues playing the native versions of Dota 2, Euro Truck Simulator 2 and Left 4 Dead 2 through Steam.

With Natural Selection 2 it's different, In the tutorial the game crashes each time I try to fire at the alien bot. I have the 319 drivers from the official NVIDIA website. Verifying the game cache on Steam doesn't solve anything.

These are the last lines of the console output I get when running Steam in a terminal:
WARNING: Corrected case of '/home/[myusername]/.local/share/Steam/SteamApps/common/NatSegmentation fault
Game removed: AppID 4920 "Natural Selection 2", ProcID 2974


I just bought the game yesterday and now I want a refund.
Dernière modification de Rose; 31 oct 2013 à 9h06
TheFox 31 oct 2013 à 10h25 
I have the same problem except that the game
not even want to start but a short error
is displayed and the window closes immediately.
What should you do?
klaus.debreciner 28 jan à 6h16 
For me the problem "Crash when shooting" did resolve today. The things I did:
- Start NS2, and put every Graphics options to very low or "off"
- close it
- cd ~/.config
- rm Natural\ Selection\ 2 -r
- restart and enjoy
Affichage des commentaires 1 à 14 sur 14
< >
Par page : 15 30 50