Natural Selection 2 > Obecné diskuze > Detaily tématu
JSON 28. srp. 2013 v 11.17 odp.
Linux Radeon HD 7770 13.8 beta2 black screen
There are black screen after map loaded. I turn all settings to low, but the result is same.
Zobrazeno 115 z 19 komentářů
< >
BobrO 29. srp. 2013 v 1.39 dop. 
I have the same video card. Game runs with 10-15 fps with all settings on low, in windows runs with 30-45 fps
I use previous version of beta driver amd
Check, will you can run the source based games, tf2 for example?
JSON 29. srp. 2013 v 2.13 dop. 
tf2 is ok. I read about black screen with amd graphics and black screen, but NS2 is affected only.
BobrO 29. srp. 2013 v 2.19 dop. 
hm, maybe you should wait a little after loading level, this game load not to fast :)
JSON 29. srp. 2013 v 2.21 dop. 
Euro Truck Simulator 2 and L4D2 are playable. I wait and nothing happens.
Atheist 29. srp. 2013 v 2.39 dop. 
GeForce GTX 680
driver version 319.32
also black screen after loading
TesX 29. srp. 2013 v 3.10 dop. 
GeForce GTX 670
driver: 325.15
black screen after loading the map (tutorial)
In the main menu: All to max settings (1920x1080) ~60 FPS

The mouse is responsive, ALT+F4 works (and plays a sound)...
Maybe is a script error?
JSON 29. srp. 2013 v 3.11 dop. 
TesX původně napsal:
black screen after loading the map (tutorial)
In the main menu: All to max settings (1920x1080) ~60 FPS

The mouse is responsive, ALT+F4 works (and plays a sound)...
Maybe is a script error?

The same.
Bugage[FR] 29. srp. 2013 v 3.42 dop. 
Same here with Ubuntu 13.04, a GTX 560M, drivers 313. Tweaking the settings doesn't help.
Naposledy upravil Bugage[FR]; 29. srp. 2013 v 3.42 dop.
OuchOfDeath 29. srp. 2013 v 3.57 dop. 
There's unfortunately going to be a lot of this, with AMD in particular. I'm surprised people with Nvidia are having problems as the Nvidia drivers are generally extremely solid and as good as in Windows. I suspect most of these issues are driver side and will require a driver udpate. Could potentially be an engine error too though.
Naposledy upravil OuchOfDeath; 29. srp. 2013 v 4.00 dop.
TesX 29. srp. 2013 v 4.35 dop. 
OuchOfDeath původně napsal:
There's unfortunately going to be a lot of this, with AMD in particular. I'm surprised people with Nvidia are having problems as the Nvidia drivers are generally extremely solid and as good as in Windows. I suspect most of these issues are driver side and will require a driver udpate. Could potentially be an engine error too though.

I don't know... the main menu is working fine and is in 3D...
I suspect it may be an error with some scripts
Naposledy upravil TesX; 29. srp. 2013 v 4.35 dop.
buscher 29. srp. 2013 v 4.58 dop. 
try launching steam with different LANG, like

LANG=en_US steam

works fine for me (after ~3sec black screen, wait a bit)
TesX 29. srp. 2013 v 5.04 dop. 
buscher původně napsal:
try launching steam with different LANG, like

LANG=en_US steam

works fine for me (after ~3sec black screen, wait a bit)

Thanks, anyway I've found a better way: set the game startup options in Steam this way:
LC_ALL=en_US %command%
Bugage[FR] 29. srp. 2013 v 5.28 dop. 
That worked for me :D
Thanks @buscher!
Naposledy upravil Bugage[FR]; 29. srp. 2013 v 5.28 dop.
ParkL 29. srp. 2013 v 6.14 dop. 
hi,

I have the black screen prob as well but the mouse cursor works like a charm!

I get loads and loads of Lua Errors:

NS2Gamerules.lua:843 trying to index field "team2" a nil value

over and over again ... if that helps ...

Ubuntu raring, GTX 560 Ti

Edit: The Locale-Fix works for me also, performance is pretty bad though ...
Naposledy upravil ParkL; 29. srp. 2013 v 8.34 dop.
JSON 29. srp. 2013 v 7.50 dop. 
I use windowed mode and LC for complete traingin. Thanks.
Zobrazeno 115 z 19 komentářů
< >
Na stránku: 15 30 50
Datum odeslání: 28. srp. 2013 v 11.17 odp.
Počet příspěvků: 19