Natural Selection 2 > Discussões gerais > Detalhes do tópico
JSON 28/ago/2013 às 23:17
Linux Radeon HD 7770 13.8 beta2 black screen
There are black screen after map loaded. I turn all settings to low, but the result is same.
Exibindo comentários 115 de 19
< >
BobrO 29/ago/2013 às 1:39 
I have the same video card. Game runs with 10-15 fps with all settings on low, in windows runs with 30-45 fps
I use previous version of beta driver amd
Check, will you can run the source based games, tf2 for example?
JSON 29/ago/2013 às 2:13 
tf2 is ok. I read about black screen with amd graphics and black screen, but NS2 is affected only.
BobrO 29/ago/2013 às 2:19 
hm, maybe you should wait a little after loading level, this game load not to fast :)
JSON 29/ago/2013 às 2:21 
Euro Truck Simulator 2 and L4D2 are playable. I wait and nothing happens.
Atheist 29/ago/2013 às 2:39 
GeForce GTX 680
driver version 319.32
also black screen after loading
TesX 29/ago/2013 às 3:10 
GeForce GTX 670
driver: 325.15
black screen after loading the map (tutorial)
In the main menu: All to max settings (1920x1080) ~60 FPS

The mouse is responsive, ALT+F4 works (and plays a sound)...
Maybe is a script error?
JSON 29/ago/2013 às 3:11 
Escrito originalmente por TesX:
black screen after loading the map (tutorial)
In the main menu: All to max settings (1920x1080) ~60 FPS

The mouse is responsive, ALT+F4 works (and plays a sound)...
Maybe is a script error?

The same.
Bugage[FR] 29/ago/2013 às 3:42 
Same here with Ubuntu 13.04, a GTX 560M, drivers 313. Tweaking the settings doesn't help.
Última edição por Bugage[FR]; 29/ago/2013 às 3:42
OuchOfDeath 29/ago/2013 às 3:57 
There's unfortunately going to be a lot of this, with AMD in particular. I'm surprised people with Nvidia are having problems as the Nvidia drivers are generally extremely solid and as good as in Windows. I suspect most of these issues are driver side and will require a driver udpate. Could potentially be an engine error too though.
Última edição por OuchOfDeath; 29/ago/2013 às 4:00
TesX 29/ago/2013 às 4:35 
Escrito originalmente por OuchOfDeath:
There's unfortunately going to be a lot of this, with AMD in particular. I'm surprised people with Nvidia are having problems as the Nvidia drivers are generally extremely solid and as good as in Windows. I suspect most of these issues are driver side and will require a driver udpate. Could potentially be an engine error too though.

I don't know... the main menu is working fine and is in 3D...
I suspect it may be an error with some scripts
Última edição por TesX; 29/ago/2013 às 4:35
buscher 29/ago/2013 às 4:58 
try launching steam with different LANG, like

LANG=en_US steam

works fine for me (after ~3sec black screen, wait a bit)
TesX 29/ago/2013 às 5:04 
Escrito originalmente por buscher:
try launching steam with different LANG, like

LANG=en_US steam

works fine for me (after ~3sec black screen, wait a bit)

Thanks, anyway I've found a better way: set the game startup options in Steam this way:
LC_ALL=en_US %command%
Bugage[FR] 29/ago/2013 às 5:28 
That worked for me :D
Thanks @buscher!
Última edição por Bugage[FR]; 29/ago/2013 às 5:28
ParkL 29/ago/2013 às 6:14 
hi,

I have the black screen prob as well but the mouse cursor works like a charm!

I get loads and loads of Lua Errors:

NS2Gamerules.lua:843 trying to index field "team2" a nil value

over and over again ... if that helps ...

Ubuntu raring, GTX 560 Ti

Edit: The Locale-Fix works for me also, performance is pretty bad though ...
Última edição por ParkL; 29/ago/2013 às 8:34
JSON 29/ago/2013 às 7:50 
I use windowed mode and LC for complete traingin. Thanks.
Exibindo comentários 115 de 19
< >
Por página: 15 30 50
Publicado em: 28/ago/2013 às 23:17
Mensagens: 19