Pico Von Rico San Jul 3, 2013 @ 8:21pm
Won't start via steam.
So, I wanted to play NS2 tonight, but whenever I try to start the game I see the steam client try to connect, but it won't even get into the actual game. My status goes from "in game Natural Selection 2" back to "online" without NS2 booting up. Thoughts?
Showing 1-13 of 13 comments
< >
Daxx Jul 3, 2013 @ 8:52pm 
Restart Steam.
Pico Von Rico San Jul 3, 2013 @ 8:58pm 
Tried that multiple times. No go.
Goliath Vietnam (Banned) Jul 3, 2013 @ 9:04pm 
uninstall game try again
Pico Von Rico San Jul 4, 2013 @ 6:39pm 
tried that too. still no dice. no firewall issues. no antivirus issues. just won't start. pretty lame
Pico Von Rico San Jul 4, 2013 @ 7:17pm 
also tried validating game files, still in some sort of temporal/spatial anomaly
DerRidda Jul 4, 2013 @ 7:32pm 
Back in the day when Steam was really poopy and you just couldn't figure out why it didn't work you always deleted the ClientRegistry.blob in the Steam directory. It has been a long time since I last had to do that but it might be worth a try.
Pico Von Rico San Jul 4, 2013 @ 7:34pm 
Alright thanks. I'm currently updating my video driver. Didn't know it was behind. Hoping that's the problem, but I will try it your way if this doesn't work. Thanks
Naughty Jul 4, 2013 @ 11:05pm 
Work out if it is the game or steam giving you the issue, have steam running and check it is working with other games them try to directly start the game using ns2.exe In the steam game folders - steamapps / common / Natural Selection 2 /
If that works I also recomend making a new text file when you are there and putting the following line in to give the game CPU Priority and help with this games biggest bottle neck:
Start /high NS2.exe
rename that file to ns2.bat and put a shortcut to it on your desktop.
Optionaly choose a cool NS styled icon for the shortcut then use that and don't bother starting from steam again.
Squishpoke Jul 5, 2013 @ 8:31pm 
When this happens to any Steam game, I kill the process in the Task Manager and relaunch the game.
Pico Von Rico San Jul 6, 2013 @ 5:51pm 
I tried Smash's suggestion, no dice. As for closing in task manager, the game only appears for half a second under processes. I have also tried ending all processes that could interfere with NS2, but still nothing works. I have a query in steam support going right now, hopefully they can fix it for me.
Pico Von Rico San Jul 6, 2013 @ 5:51pm 
Any other suggestions would be helpful.
JCD2150 Jul 7, 2013 @ 1:10am 
Go to the official unknownworlds forum they can help you much better.
www.unknownworlds.com/ns2
[KFV] Gimpy Aug 19 @ 3:37pm 
I had luck going in to C:\Users\"USER NAME"\AppData\Roaming\Natural Selection 2 then opening "system_options.xml" with notepad and manually setting the resolution "1920x1080" then just ran as administrator.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50