Pepe Dec 21, 2012 @ 5:09am
No servers
Hey, now i just bought Natural selection today, and just now have downloaded and tried to play, Yet no servers are showing up, this same situation happened with Killingfloor where no servers show up, I'm pretty sure it has nothing to do with my Firewall settings, but possibly with my porting (Which i have no knowledge over what so ever!), i was wondering if anyone could please help me with this problem.

These are the Computers programs that may be conflicting with the games- Windows Fire wall, Comod firewall, Driver manager (Associated with with Nortan, Possible problem?), Windows-Pc status:, And Avast anti-virus:Free version.

If someone could come up with a fixable solution, it'd be much appreciated.

-Thank you.
Showing 1-15 of 20 comments
< >
Wykin Dec 21, 2012 @ 5:14am 
I sometimes dont get servers too.. a steam or game restart fixes this for me.
If not for u it maybe is a firewall problem...
Check offical forums for solutions
http://www.unknownworlds.com/ns2/forums/index.php?showforum=108
Pepe Dec 21, 2012 @ 5:22am 
I made an account, and it says i don't have permission, Why's that?
MATTFLORENCE [ITA] Dec 21, 2012 @ 5:45am 
I nave the same problemi.... I cannot create a private server e for 'autenthication failed' and the game doesn't find server. Pls help me
Pepe Dec 21, 2012 @ 6:03am 
I've just tried looking for a solution, and yet nothing that can help with the situation, I really hope someone can help me, because this is just really annoying, and i really would like to play this game. :I
Noblesavage Dec 21, 2012 @ 10:04am 
I'm currently running Avast and haven't had any issue with it and NS2. I'd suggest using something like Simple Port Forwarding (http://www.simpleportforwarding.com/) and see if you can't adjust your ports for NS2. You may need to read up on which ports need to be opened for the game.
Pepe Dec 21, 2012 @ 10:06am 
I just validated it, and it said- 43 files failed to validate, and will be reaquired. I'm not entirely sure what this means, as to whether i have to manually sort this out, or the game will do it's thing, i'm really confused. :l
Noblesavage Dec 21, 2012 @ 10:06am 
You may need to adjust your server filters within the game browser and make sure they aren't filtering out potential servers.
Pepe Dec 21, 2012 @ 10:07am 
Also to note that, when i first downloaded the game, i didn't have as many files as to when i had validated the game, first time round.
Pepe Dec 21, 2012 @ 10:12am 
What do you mean by "adjust your server filters within the game browser", are you sure you're not trying to tell me to adjust them via Steam's browser?, also i've checked there, and steam servers, don't show NS2 servers. Perhaps i'll have a double check then.
Noblesavage Dec 21, 2012 @ 10:18am 
Some things to try as i'm combing through various forums:

"Are you running Steam in Administrator mode? Without it you can sometimes have permissions issues which simply fail silently rather than ask permission to edit/add files."
- Prezombie (http://forums.steampowered.com/forums/showthread.php?t=2233785&page=2)

"I've found the solution to the problem, posting it here in case others can benefit from this.
When choosing to Verify the Integrity of the Game Cache, it seems you must first completely quite out of Steam, then relaunch Steam. Once I did this the verification process found 5 files that needed to be reaquired and went about doing so automatically. Now the game runs as before the issue.
Yay!"
-Zuulbash (http://www.robotentertainment.com/forum/topic/Steam-Data-Validation-Failure-SOLVED)
Pepe Dec 21, 2012 @ 10:20am 
Thaks for that, i'll try these now, also something els you might find of any interest?

Build 235
Steam initialized
Render Device: ATI Radeon HD 5770 (8.14.1.6099)
Error: Couldn't start recording (An invalid parameter was passed to this function. )
Sound Device: ATI HDMI Output (ATI High Definition Audio Device) stereo
Record Device:
Loading config://ConsoleBindings.json
Loading config://FavoriteServers.json
Main Menu Initialized at Version: 235
Error: Attempted to load remote options from a file that does not exist.
Noblesavage Dec 21, 2012 @ 10:22am 
Originally posted by ⌠ƒ€ΛГ⌡ Quithanual:
What do you mean by...

In the NS2 Server Browser there should be various filters at the top of the screen such as "Password Protected", "Rookie Friendly", "MOD servers" and a couple of sliders on the top right of the screen that adjust for ping and performance. If you have too many filters turned on the browser in the game may be filtering out all the servers in your area.
Noblesavage Dec 21, 2012 @ 10:28am 
If you feel comfortable with it, you could disable/turn off your firewall and try playing NS2 or Killing Floor and see if the servers pop up for you. Just make sure you restart the game client after the firewall has been turned off.
Pepe Dec 21, 2012 @ 10:29am 
In the NS2 Server Browser there should be various filters at the top of the screen such as "Password Protected", "Rookie Friendly", "MOD servers" and a couple of sliders on the top right of the screen that adjust for ping and performance. If you have too many filters turned on the browser in the game may be filtering out all the servers in your area. [/quote]

Yer, i had come to some consideration that, that may be a cause, i don't have anything filtered, except for a slider option, i think it was the one that displays Ping?, something about Max/Infinite.
Pepe Dec 21, 2012 @ 10:30am 
Sorry, a little new to steam Discussions.
Showing 1-15 of 20 comments
< >
Per page: 15 30 50
Date Posted: Dec 21, 2012 @ 5:09am
Posts: 20