Natural Selection 2

Natural Selection 2

View Stats:
Te3-BloodyIron WTS HD 7970 PST Jan 11, 2014 @ 7:14pm
steamos - black screen
just installed steamos on a buddy's system, running an r9 290 and we're getting a black screen right away for ns2. It doesn't seem to finish launching ever. We've tried STEAM in big picture mode and desktop mode, no luck either way.

Any idea?
< >
Showing 1-15 of 16 comments
jethai Jan 11, 2014 @ 9:57pm 
steamos is mostly for nvidia cards
Te3-BloodyIron WTS HD 7970 PST Jan 13, 2014 @ 8:05am 
But how will I mine for coins in my downtime? D:

I'm also kind of skeptical about that statement.
ChrisPlaysLinux Jan 13, 2014 @ 10:24am 
Ghando Jan 13, 2014 @ 8:03pm 
try run NS2 as Admin and/or re-validate your NS2 data via steam... and/or if u ve Adobe Creative Cloud installed, disable it.
ChrisPlaysLinux Jan 14, 2014 @ 7:05am 
there is no such thing as "admin" on linux, only wheel and root,
Te3-BloodyIron WTS HD 7970 PST Jan 14, 2014 @ 8:55am 
lol run as admin... and then you go on about adobe creative cloud, hahah like that would run in linux.

I think you misread some things there buddy, thanks for pitching in though :)
Last edited by Te3-BloodyIron WTS HD 7970 PST; Jan 14, 2014 @ 8:55am
Ghando Jan 14, 2014 @ 9:27pm 
oh linux nvm ^^ ...about linux... i dont ve a clue about it at all hehe sry
Te3-BloodyIron WTS HD 7970 PST Jan 25, 2014 @ 7:50pm 
Recent steamos update and no fix for this :(
Ghoul Jan 26, 2014 @ 2:16am 
Afaik this is a amd driver bug which is well known by amd and there was also a solution presented at the steam dev congress. But still you have to wait for amd to fix this ... . UWE themself are trying to find a workaround meanwhile.
Te3-BloodyIron WTS HD 7970 PST Jan 26, 2014 @ 1:40pm 
Ahh good some info on this, thanks!
|TG|cyphaetus Feb 4, 2014 @ 6:28pm 
Anyone have more info on this bug? Is being tracked somewhere?
.dPing Mar 25, 2014 @ 8:24pm 
Sadly, no resolve yet with current alchemist beta. I've been trying all day. Its an fglrx driver issue but I dont know what exactly is breaking.
EthraZa Apr 6, 2014 @ 4:41pm 
I have SteamOS with a Radeon hd 7770. All my Linux games run well, plus Star trek under Wine. Im playing Star Conflict right now. But NS never worked... it is just a waste... uninstalling NS in 3, 2, 1...
ChrisPlaysLinux Apr 9, 2014 @ 6:44am 
What do you mean all your linux games? Games that dont even use opengl 2+(shaders)?
Te3-BloodyIron WTS HD 7970 PST Apr 9, 2014 @ 9:26am 
He is vague, but I am goinig to _assume_ he means games that list having native Linux support. Since NS2 is native Linux and this black screen issue is still present, his point is a sharp juxt position to the original intent of this thread, which is appropriate since it outlines how my experience does not inherently match his; with sexy results.
< >
Showing 1-15 of 16 comments
Per page: 15 30 50

Date Posted: Jan 11, 2014 @ 7:14pm
Posts: 16