spacelike May 5 @ 11:20pm
[Linux] Game files do not match server
I haven't been able to connect to any servers, it started happening yesterday.

Whenever I try it says my files don't match the servers, try verifying game cache.
I verified and still can't connect.

This has happened before when an update to NS2 came out, and nothing I could do would fix it, I believe I waited for about a week and it still wouldn't work, so I eventually just stopped trying altogether because I could never join a server

I recently came back to the game and was happy that it was sorted out and I was able to play for several days, but now after the recent updates it's happening again. It's been over 48 hours so far

I'm wondering if it's just a mismatch between the windows files and the Linux ones.

NOTE: I was able to play for a while initially after the new Kodiak update, but I guess a secondary smaller update came out? My list showed that there was another update anyway.. and then now I can't join any servers.
I haven't changed any game files or even game settings since it was last working.
Last edited by spacelike; May 5 @ 11:23pm
Showing 1-6 of 6 comments
< >
Azure Zero May 6 @ 6:57am 
Someone else had this and got an answer
Check the threads here and at UnknownWorlds

Link
Last edited by Azure Zero; May 6 @ 6:57am
spacelike May 7 @ 4:09pm 
I tried deleting those files and still nothing

Also, I just finished completely reinstalling the game and I still get the same errors

I forgot to mention in the OP that there are 2 different but similar errors.
Sometimes it gives the one in the OP about files not matching the servers
and other times it can simply say "Invalid data"

But I still haven't been able to join a single server, even ones that I was playing on earlier in the same day the error started occurring

This has to be a Linux bug, I heard a lot of the servers use independent mods and that they might not update those files for Linux right away
Debianeer May 8 @ 3:31pm 
i'm using the game under linux, it's working fine for me

(i know, so helpful)

I used to have this problem, it was related to mods in my case, but i don't remember the fix.

If you do get (back) in a server with the Linux version of the game, i'm curious to know if the "Customize Player" option shows up for you, as I don't have it. =(
Last edited by Debianeer; May 8 @ 3:33pm
IronHorse May 8 @ 3:52pm 
Technical support is only offered in our forums, not here, per the pinned topic.
Here's a thread that is similar to yours.
http://forums.unknownworlds.com/discussion/comment/2195648/#Comment_2195648
spacelike May 8 @ 4:13pm 
Originally posted by Mousey:
If you do get (back) in a server with the Linux version of the game, i'm curious to know if the "Customize Player" option shows up for you, as I don't have it. =(

I don't see any such option on the main menu. I was actually looking for it because I saw a screenshot of the improved customization, I looked in every single menu and couldn't find customization anywhere

and thanks for responding, it is helpful to know that someone else with Linux is in fact able to connect to servers
Debianeer May 8 @ 7:49pm 
i fixed my customize player option too.. it was server side, i had to remove the "player badges" mod from my server. now my linux client sees Customize Player just fine.

(you have to actually join a server to see the "customize player" option.)
Last edited by Debianeer; May 8 @ 7:49pm
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: May 5 @ 11:20pm
Posts: 6