ObamaCareRules May 2 @ 4:37am
Couldn't Establish A Connection With The Server
After the Kodiak update I am getting this 'Couldn't Establish A Connection With The Server' message over and over after trying to join any servers.

I have tried

• Delete the folder drive\Program Files (x86)\Steam\steamapps\common\Natural Selection 2\ns2\shaders
• Press the Windows key and R (Win+R) and type %APPDATA%\Natural Selection 2 then press enter.
• Delete all the files in this folder
• Verify the Integrity of the NS2 Game Cache
• You can also try deleting the local Steam files for NS2 and reinstall NS2.

All of these and none of those worked out.
I just bought upcoming dlc also and this is just makes me angry again.
Showing 1-6 of 6 comments
< >
Azure Zero May 2 @ 8:04am 
You have to unsubscribe from every workshop item
Un-install game
Delete the AppData\Roaming\NS2 folder

Then you re-install the game
umdum9 May 4 @ 8:05am 
Try reconnection right after it said that to the same server. (Works like a charm)
Ghoul May 4 @ 10:41am 
Make sure you disable Extra Precaching in the options!
IronHorse May 4 @ 1:32pm 
You will not receive technical support here in these forums. Like the pinned thread says, please visit our technical support forums on our official website for solutions and help.
http://forums.unknownworlds.com/categories/technical-support
ObamaCareRules May 4 @ 4:35pm 
I have found solution and also posted on NS2 form.
IronHorse May 4 @ 8:34pm 
So you have! Thank you so much for doing that :)
And nice find, might i add.
For reference for others, it was comodo AV:

http://forums.unknownworlds.com/discussion/134750/couldn-t-establish-a-connection-with-the-server#latest
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: May 2 @ 4:37am
Posts: 6