Natural Selection 2 wont work on linux
I just get black screen. I'm using Arch Linux (Antergos) 64bit radeon 7770 4gb ram. Other games work normally.
Last edited by chew asses and kick bubblegum; Apr 9 @ 12:45pm
Showing 1-15 of 24 comments
< >
Azure Zero Apr 9 @ 4:43pm 
I think NS2 will only work in the Ubuntu version of linux,
Could be wrong
Richard Spectre Apr 9 @ 11:12pm 
I get a error message 'couldn't initialize the render device'.
ArchLinux 64-bit, i5-2500K, Radeon HD6850.
DE: GNOME 3, drivers - open source xf86-video-ati.
Last edited by Richard Spectre; Apr 9 @ 11:14pm
Originally posted by Azure Zero:
I think NS2 will only work in the Ubuntu version of linux,
Could be wrong
Found on the internet that that's problem with kernel > 3.12 , but newest version of ubuntu also use kernel > 3.12
Originally posted by Azure Zero:
I think NS2 will only work in the Ubuntu version of linux,
Could be wrong
Installed Ubuntu Gnome 64bit still doesn't work.
Azure Zero Apr 10 @ 8:34am 
Is it Ubuntu 12.04 LTS or Ubuntu 13.10[www.ubuntu.com]?
As Gnome is the old interface, Unity is the newer one.
Last edited by Azure Zero; Apr 10 @ 8:35am
ubuntu 13.10. Gnome 3 is new interface...
OuchOfDeath Apr 10 @ 12:26pm 
You need a newer version of Mesa (which you have to get through third-party repositories), or get the binary Catalyst driver.
chew asses and kick bubblegum Apr 10 @ 12:29pm 
Originally posted by OuchOfDeath:
You need a newer version of Mesa (which you have to get through third-party repositories), or get the binary Catalyst driver.
can you tell me which version do I need? And if you know any repositroy that has it?
OuchOfDeath Apr 10 @ 12:41pm 
10.1 or 10.2 I believe. And no I don't. You'll have to google around. The next Ubuntu version is going to come with it so that'd be the easiest and least risky way.
Originally posted by OuchOfDeath:
10.1 or 10.2 I believe. And no I don't. You'll have to google around. The next Ubuntu version is going to come with it so that'd be the easiest and least risky way.
Doesn't work. I've installed Mesa 10.2 and it doesn't work. I have saw on the Natural Selection 2 forum that problem is that shaders can't be compiled, still no solution.
On the offical site it says that they are aware of the problems, but they don't know what causes them and that "comunity is going to need to figure it out by themself".
Last edited by chew asses and kick bubblegum; Apr 10 @ 1:06pm
OuchOfDeath Apr 10 @ 2:55pm 
I remember reading someone mention that running it once with Catalyst compiles the shaders, and then you can switch back to Mesa and it'll run. You'd have to do that every patch though.
Originally posted by OuchOfDeath:
I remember reading someone mention that running it once with Catalyst compiles the shaders, and then you can switch back to Mesa and it'll run. You'd have to do that every patch though.
I'm using Catalyst drivers...
640kB Apr 11 @ 4:54am 
Originally posted by OuchOfDeath:
I remember reading someone mention that running it once with Catalyst compiles the shaders, and then you can switch back to Mesa and it'll run. You'd have to do that every patch though.
NO!
The other way around. If you get it running with Mesa, you can switch back to Catalyst.
640kB Apr 11 @ 5:26am 
Ok guys... i uploaded my shaders, which I compiled with Mesa. Download it here, maybe it will work with your graphic card. I am using a Radeon HD 6850. So at least it should work you, if you have the same graphic card and are using the catalyst driver. I dont know if this also works with other graphic card generations.

https://www.dropbox.com/sh/88fsfmc3b7sngqm/Usdubc1jlH/ns2_shaders.tar.bz2

Download the file and extract it in the following folder
cd ~/.config/Natural\ Selection\ 2/
Maybe there are still some missing shaders, which must be compiled. Just left a message.
Last edited by 640kB; Apr 11 @ 5:27am
Originally posted by 640kB:
Ok guys... i uploaded my shaders, which I compiled with Mesa. Download it here, maybe it will work with your graphic card. I am using a Radeon HD 6850. So at least it should work you, if you have the same graphic card and are using the catalyst driver. I dont know if this also works with other graphic card generations.

https://www.dropbox.com/sh/88fsfmc3b7sngqm/Usdubc1jlH/ns2_shaders.tar.bz2

Download the file and extract it in the following folder
cd ~/.config/Natural\ Selection\ 2/
Maybe there are still some missing shaders, which must be compiled. Just left a message.
Omg thanks, It worked! :D
Showing 1-15 of 24 comments
< >
Per page: 15 30 50
Date Posted: Apr 9 @ 12:04pm
Posts: 24