Natural Selection 2 > 一般的な話題 > トピックの詳細
FRÓÐØ Swaggins 2月9日 7時01分
NS2 Linux
Alot of people are complaining about crashes, and the unplayable status of the game. Most people can't even shoot a gun one time before a complete crash. You cant join a game, settings dont help, and you charge $24.99 for a product that doesnt work.

I understand that we are the minority (being a linux user), but your basically just ripping people off. You ignore us and wont show any support or fixes.

Atleast put on the store page that the linux version is very alpha and warn people that you dont plan on working on it.

http://forums.unknownworlds.com/discussion/132765/linux-game-crash-when-shooting/p4

4 Months and no response or fix.
最近の変更はFRÓÐØ Swagginsが行いました; 2月9日 7時08分
1-15 / 29 のコメントを表示
< >
Mindless⚔Solitude 2月9日 10時53分 
Works okay for me on GTX 550Ti with proprietary 310.44 blob.
Dreamer_ 2月10日 7時05分 
For me game starts, but then crashes whenever I try to play any map :/
GTX 760 with proprietary 331.38 blob
FRÓÐØ Swaggins 2月10日 15時33分 
I can start game but it is unplayable. Tutorial crashes at gun fire, cannot join any server without crash
Egeo 2月11日 9時35分 
The game is unplayable, crashes all time
ᵡᴳḽᴰ >>Stickz<< 2月11日 13時59分 
wish people would give more useful information when it comes to problems like these other than "my gpu has 1gb of ram).

-verify your game
-update video card drivers on linux
-reinstall your game just to be sure if nothing else works
最近の変更はᵡᴳḽᴰ >>Stickz<<が行いました; 2月11日 14時01分
blue luke 2月11日 15時16分 
xG:D >>Stickz<< の投稿を引用:
wish people would give more useful information when it comes to problems like these other than "my gpu has 1gb of ram).

-verify your game
-update video card drivers on linux
-reinstall your game just to be sure if nothing else works
That's just nonsense in this case... Did you even read the thread?

There are definitely a couple of gamebreaking linux bugs around.. Which won't fix themselves by a simple cache verify.


But to add some hope to this thread: Check the latest (released today) beta build!
The next build is supposed to contain a couple of linux related fixes:
Mainly the change to core OpenGL (for those who want/have to use Mesa drivers), some radeon fixes and a fix for the 3.12 kernel crashes.
Check out their twitter/forums for the official announcement.

I'm not sure if all those promised fixes are in the beta build yet, but:
I can at least start the game using Mesa drivers now.
It still crashes during precaching, but it's a (albeit small) start. xD

最近の変更はblue lukeが行いました; 2月12日 5時10分
Hideaki 2月11日 23時52分 
Arch Linux user, with a nvidia card running the proprietary drivers here. The game loads me into a map, but crashes the moment a bullet is fired. There's some serious issues with this game on Linux.
sunshinecorp 3月27日 9時24分 
Not working at all. Black screen on load, have to kill the process to exit. Ubuntu 12.04 64-bit, 13.12 AMD drivers (latest non-beta), AMD Radeon HD 7660D. It's been like this since I bought the game some months ago. Won't load, ever, even when I reinstall, change drivers, verify game files.
Davey Darko 3月27日 15時47分 
I've never gotten it to work on Linux, I've tried it in Mint 15 and 16 with various versions of the proprietary Radeon drivers and had no luck. Sure would appreciate it if the developer would at least let use know if they're working on a fix.
DaveN 3月27日 18時24分 
The game works okay on Ubuntu-based distros. I have Xubuntu 13.10 right now and it boots up and works just fine. I can play most of the time, however, with low graphic settings at 60 and random crashes here and there. i5-4430 & 660 on 319.32.

I'm assuming that Ubuntu-based distros are their target Linux user.
Noks 3月28日 9時28分 
+1 the game is sale for linux users, but he is simply unplayable in normal conditions .....

Chris (禁止済) 3月28日 10時06分 
Maybe they should microtransactions some linux hats for development, but I'm thinking they are getting their worth out of all your issues. UWE does release crap that must be molded into place while asking for donations. It's ♥♥♥ backwards. They must have terrible money management issues, but whatever. GL linux users!
Courty 3月29日 7時56分 
i have an average of 72 fps on linux here is my graphical options.
http://imageshack.com/a/img849/1484/wkbk.png
U should try to disable some graphical options it's better to have lower graphic quality and more fps in any fps multiplayer game.
I have the latest NVIDIA driver .run file u should use last driver from nvidia.com (v 334.21 atm).
最近の変更はCourtyが行いました; 3月29日 8時06分
Courty 3月29日 8時03分 
If u use Ubuntu or Xubuntu here is a quick guide to install the last NVIDIA driver (.run file)
If u use Debian u must download ur kernel headers first no need in Ubuntu/Xubuntu.

Last NVIDIA driver (.run file) from nvidia.com TUTORIAL TO INSTALL :
Nvidia driver: http://www.nvidia.com/Download/Find.aspx?lang=en

Right click the .run file u downloaded from nvidia.com and go properties, SET IT AS AN EXECUTABLE FILE and put the file in your /home/yourlogin

You will have to enter the virtual console with Ctrl+Alt+F1 and login into the system with your username and password. (CTRL+Alt+F7 is switch back to ur desktop).

In the console u type:

sudo service lightdm stop

(don't forget the word "service" or it won't work)

sudo ./NV (press TAB to autocomplete the file name)

then u can reboot (CTRL+ALT+DEL) and enjoy the last NVIDIA driver ;)

P.S: If the installer stops before installing it's because you need to reboot first to disable the preinstalled "NOUVEAU driver". (the installer create a file to disable it).
最近の変更はCourtyが行いました; 3月29日 8時10分
Castiel 3月30日 2時28分 
Installing downloaded stuff like this is not truly the linux way, though what should we do when it comes to the latest driver updates :( (?).

LINUX Blaster の投稿を引用:
P.S: If the installer stops before installing it's because you need to reboot first to disable the preinstalled "NOUVEAU driver". (the installer create a file to disable it).

Alternatively, use "rmmod nouveu" or "rmmod -f nouveu" and try installing again...
That should take care of the nouveau driver.
If the nvidia installation doesn't automatically blacklist the nouveau driver after the installation you'd have to launch a terminal and insert:
echo "blacklist nouveau" > /etc/modprobe.d/blacklist.conf
1-15 / 29 のコメントを表示
< >
ページ毎: 15 30 50