Liquidbullets Aug 17, 2014 @ 3:28pm
Server mod out of date
I get this message when I attempt to join "Server mod out of date" . This is not for all of my servers, only about 50% of what I try, however I have some usual servers and would like to join with friends and I am not able to. I have looked it up and have tried every fix suggested. Nothing works. However I failed to find a thread not in 2013 for this issue, is there any newer fix available?

I am currently trying a full reinstall, I will update this when done to let you know what happened.
Last edited by Liquidbullets; Aug 17, 2014 @ 3:29pm
Showing 1-9 of 9 comments
< >
Azure Zero Aug 17, 2014 @ 3:49pm 
They need to update their servers, it's their end, not your end
Liquidbullets Aug 17, 2014 @ 3:51pm 
Then why is it that my wife who is sitting 3 feet away from me can play on the server and I can't?
Azure Zero Aug 17, 2014 @ 3:58pm 
Then it's the workshop items

Unsubscribe from EVERY workshop item.

Delete the Natural Selection 2 folder in Users\USERNAME\AppData\Roaming.

That may fix it.
Liquidbullets Aug 17, 2014 @ 3:58pm 
It's been done, no luck.
Azure Zero Aug 17, 2014 @ 3:59pm 
So no workshop items, and you deleted the NS2 Folder in AppData\Roaming?
exact folder names above
Last edited by Azure Zero; Aug 17, 2014 @ 4:00pm
Liquidbullets Aug 17, 2014 @ 4:03pm 
You don't need to repeat yourself. I stated I've researched and tried the fixes, you suggest a fix, I say i've tried that. One should assume I'm literate and was able to follow a 2 step direction fix. Or next are you going to tell me if I tried turning it on and off again, or did I check to see if it was plugged in? *sarcasm*

Yes I did that.
Last edited by Liquidbullets; Aug 17, 2014 @ 4:04pm
Azure Zero Aug 17, 2014 @ 4:50pm 
I can't think of anything at the moment, but you could try the NS2 technical forums and see if they have the answer.
Liquidbullets Aug 17, 2014 @ 5:22pm 
Full reinstall of the game seemed to work for now.
Janet Reno Aug 25, 2014 @ 7:30am 
Have your wife try turning it off and then on again?
Did you check to see if it was plugged in?
Last edited by Janet Reno; Aug 25, 2014 @ 7:30am
Showing 1-9 of 9 comments
< >
Per page: 15 30 50

Date Posted: Aug 17, 2014 @ 3:28pm
Posts: 9