Aven Colony

Aven Colony

View Stats:
Aven Colony > General Discussions > Topic Details
Vash Stampede Dec 6, 2017 @ 12:17pm
Elevator turned off, colonist kept arriving.
Seemed to stop when I reloaded the game, but even though I had turned it off, I still had colonist arriving.
< >
Showing 1-8 of 8 comments
SlimNasty™ Dec 6, 2017 @ 12:39pm 
You sure you didn't have any other immigration?
Mothership Entertainment  [developer] Dec 6, 2017 @ 2:43pm 
If the elevator was on the way down with colonists in it, they'd still arrive. But it wouldn't go back up and get more colonists until it becomes active again!

The same is true for the Immigration Center (and also Trade Hub!) because it would just be weird for the vessels to just hover in-place.

Could it be that your batteries ran out of power and the Space Elevator became active again?
Vash Stampede Dec 6, 2017 @ 3:39pm 
No,more power then I know what to do with, thank you colonial solar farms, So on deactivation if its still in process it continues. Replicated it a couple of times, even had it switch back on me. May have something to do with switching to the overworld map, turned off the elevator while it was in orbit, received new colonists ever 10 years repeatedly. While its off, No other colonial import, removed it when i added the elevator.

https://imgur.com/a/9qgZR

Vash Stampede Dec 6, 2017 @ 3:48pm 
Even if I start and stop it again it wont stop, Have to reload the game, Here it is untouched repeatedly on the same loading, and producing additional citizens.

https://imgur.com/a/Ffm3H
Cosmic Cowboy Dec 6, 2017 @ 4:09pm 
With the new update, shutdown buildings work off batteries. It doesn't matter how much power you get from anything else. I still don't like it because a shutdown building should remain shutdown until I say otherwise, regardless of how much power is available or what the source is, but that's the way it is right now...
Vash Stampede Dec 6, 2017 @ 6:43pm 
This isnt related to that, when the building is shutdown, yes its still using power, it should, its still being used for storage.

It should not be bringing colonist in, that is the intended function for the shutdown. When the device is shutdown and the process is entering orbit, it gets stuck that way and doesnt fully stop.

I have success fully turned it off without issue, regardless of battery drain. I have repeatedly turned it off when its ascending and it gets stuck in orbit and will stay that way until i turn it on again, then turn it off on descent.

If it stays stuck in orbit it conitnually adds more citizens.
Mothership Entertainment  [developer] Dec 7, 2017 @ 8:46am 
Thanks for the screenshots, I was able to track down and see what you mean!

It is a bug, but it's not adding citizens to the colony, it's telling you (over and over... and over) that citizens are in the elevator. It definitely shouldn't be doing that, so we'll be pushing out a fix for that soon.

Thanks for letting us know!
Mothership Entertainment  [developer] Dec 7, 2017 @ 11:33am 
Thanks for your bug report! We've just pushed out a small hotfix for this - v1.0.23723. :steamhappy:
< >
Showing 1-8 of 8 comments
Per page: 15 30 50

Aven Colony > General Discussions > Topic Details