Anno 2070 > General Discussions > Topic Details
Keramane Dec 24, 2012 @ 10:59pm
Connection to Server has been Lost
So, I get through steam fine, I get through uPlay fine, but when I get the game loaded, it goes through another login and I get this:

http://steamcommunity.com/sharedfiles/filedetails/?id=115619750

Anyone else having this problem?
Last edited by Keramane; Dec 24, 2012 @ 11:00pm
Showing 1-15 of 51 comments
< >
ExiaRS #sokobanja 2-16 Dec 25, 2012 @ 2:19am 
Originally posted by Keramane:
Seriously, who really cares about the DRM? Can you play the game? Sure. If it locks out, can you appeal to Support to get that fixed? Yes. It's an inconvenience at best, not the rise of satan.
Aren't those your own words?
Keramane Dec 25, 2012 @ 4:10am 
They are, and I find the fact that you looked up my thread ironic. It was working at home, but apparently my work has a firewall up that blocks the 3rd DRM rather than the first two.

So whoops, user-side error.

Still not the rise of Satan.
Last edited by Keramane; Dec 25, 2012 @ 4:11am
rababer_blatt Dec 26, 2012 @ 6:59am 
Hi keramane
i get the same problem. i'll try to play around with the firewall... sucks anyway.
Master J Jan 5, 2013 @ 3:14am 
Yes, I bought the game yesterday and I have the same issue. Googling around atm to find a solution. So far opening ports, removing the hosts file in windows and disabling the firewall hasn't solved it.
Bruno Jan 5, 2013 @ 11:02am 
Originally posted by ExiaRS Гангам_стил:
Originally posted by Keramane:
Seriously, who really cares about the DRM? Can you play the game? Sure. If it locks out, can you appeal to Support to get that fixed? Yes. It's an inconvenience at best, not the rise of satan.
Aren't those your own words?

Hahaha
Keramane Jan 5, 2013 @ 5:02pm 
>_> This thread got necro-ed. Anywho, the problem I had was that it was firewall related. My work firewall was blocking the ports used to maintain the connection to the Anno multiplay system. I'm not sure if that's your problem, Master J, but it was mine.

The game works flawlessly at home :3
ztirf Jan 5, 2013 @ 8:33pm 
same problem here!Got the game yesterday,tried five hours to log in,all firewalls off-connection to server lost!I am very unhappy because tomorrow i have to work again! :-(
Asianator Jan 8, 2013 @ 12:06pm 
Hey, I've got the same issue here. I've tried turning off my firewalls but that hasn't worked and it can't be an internet connection problem cause that's been running fine. Any other suggestions?
Keramane Jan 8, 2013 @ 4:08pm 
I've not been able to tinker around with fixes at work, since it's my work network and generally not something I should be trying to game on anyways, so I've no real solutions for ya.
Tristen Jan 8, 2013 @ 7:08pm 
I have contacted Ubisoft and they said that when they download the game that is distributed from Ubisoft it works, but when they download the game from Steam it does not work. They also had me verify if when i do a "Verify integrity of game cache..." and i kept getting 4 missions files lost, now i am only getting one. See if this is happening to you as well, also did you buy the Anno 2070 Pack? I did and i was just wondering maybe if it was the pack version because a friend of mine bought just the game and his works fine.

Also i have contacted steam but, like usual, Steam does not reply very fast so i will update you on what they have to say.

If you have any questions I minght be able to help, i have been contacting Ubisoft with this issue for some time now and could tell what we ahve done trying to fix it.
Tristen Jan 9, 2013 @ 7:55am 
Just an update, He had me install the latest Tages drivers. Go here >> http://www.tagesprotection.com/main.htm?page=minimum.htm and click on the tab that sayd Drivers, pick the correct OS and update. This may work for you, im not saying it will but it may, he said that it has had great success for him. This did not work for me, sad to say. Will keep you updated.

They did tell me that my issue has been escalated to a very high priority so i do think they wil have a fix soon.
ztirf Jan 9, 2013 @ 11:17am 
Thank you for the tips,but i having still the problem!Maybe sometimes in the future there will be a solution.
Greetings
Master J Jan 10, 2013 @ 2:08am 
Sorry for "necro-ing" this thread, I seldom post stuff in forums so I didn't know^^. Anyway, I contacted Ubisoft support, and they asked wheter the problem was still on-going, which it is. I followed your suggestion Tristen of "verifying integrity of game cache", and yesterday when I did it, some files were missing, but today it seemed to be fine; the problem persists however.
Tristen Jan 10, 2013 @ 3:38am 
Hmmm, Do you know how many files were missing. And could you try running the game then "Verify integrity of game cache". Whenever i run the game it seems like the files dissapear. And a nother question, what deal did you buy; i myself bought the whole pack during the steam sale and i was wondering if it was only the people who bought the pack or every Anno 2070 Steam is distributing.
Asianator Jan 13, 2013 @ 7:17pm 
I tried the drivers but it didn't work. I tried the whole verify game cache thing and it's always saying that its missing three files and downloads them. I launch the game then the uplay autopatcher proceeds to download more files. I look to verify the cache again and the same thing happens all over.
Showing 1-15 of 51 comments
< >
Per page: 15 30 50
Date Posted: Dec 24, 2012 @ 10:59pm
Posts: 51