mbrailas Jul 14, 2013 @ 6:56pm
Game crashing on startup
Hey guys,

I know there are already a lot of posts from people having trouble playing the game. I bought it on the Steam sale, and it straight up wont run on my laptop.

I'm not having trouble connecting to the internet. I'm not getting a black screen when I try to launch. It displays some splash art for a few seconds, then I get a message that the game is "not responding."

I really want to play this game, it looks really fun. I've been poking around through these threads and none of the solutions have worked. I went to NVIDIA control panel to make sure the game is detecting my gaming graphics card. I reinstalled the uplay launcher. I reinstalled the whole game. Nothing has helped at all.

My system specs are as follows:
GeForce GTX 670M
Intel core i7-3720QM CPU @ 2.60Gz
15.9 GB ram
driver version 320.49
Windows 7 Home

I bought the gold edition and the latest expansion pack separately through steam.

Does anyone have any insight into how I can fix this? I don't care about getting Ubisoft banned. I don't want a refund. I just want to play my game.
Showing 1-15 of 28 comments
< >
Caipling Jul 14, 2013 @ 11:59pm 
it's crashing for me on startup as well. steam please fix this with ubisoft!
Caipling Jul 15, 2013 @ 12:23am 
at start up, an error message pops up by windows saying "might &mighc heroes VI shades of Darkness has stopped working. A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available." and it only has a close program bottom on it. after clicking it it brings me back to Uplay.

I have geforce 320.49 the latest driver installed for my Geforce GT 650m . I'm running a windows 7 home 64
mbrailas Jul 15, 2013 @ 1:29am 
Yup that sounds pretty much identical to my problem. Really hopes this gets handled soon. At least I know it's not specifically a problem with my computer. If a lot of people are experiencing this, Ubi is going to have to do something about it.
Iroh Jul 15, 2013 @ 1:43am 
Originally posted by Caipling:
at start up, an error message pops up by windows saying "might &mighc heroes VI shades of Darkness has stopped working. A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available." and it only has a close program bottom on it. after clicking it it brings me back to Uplay.

I have geforce 320.49 the latest driver installed for my Geforce GT 650m . I'm running a windows 7 home 64
I have the same problem. Driver 320.18, updated to 320.49, Geforce GT 650m. I'm running a Windows 8 64. I guess it's not hardware or driver problems. Still don't work.
Last edited by Iroh; Jul 15, 2013 @ 2:12am
WarFire Jul 15, 2013 @ 1:43am 
gettin ubisoft launcher: error 1 myself... is their a know issue with ubiplay as well?
NewbieOKS Jul 15, 2013 @ 1:53am 
same here...there is an issue with the uplay software which doesn't compatible with windows and steam

Refer to this thread; its unofficial but for some people it works
http://steamcommunity.com/app/48220/discussions/0/846958724772577376/

I follow the steps but still doesn't work for me, now I am downloading again the whole game from beginning..I even post a ticket to Steam and Ubisoft support
Iroh Jul 15, 2013 @ 2:04am 
Reinstalled Uplay 3 times and Heroes6 2 times yesterday according to the instructions. It's not help.
Originally posted by NewbieOKS:
same here...there is an issue with the uplay software which doesn't compatible with windows and steam
Far Cry 3 works good with Steam and Uplay but Heroes 6 don't. I don't understand what's wrong. Feels like Ubisoft love Far Cry and absolutely don't care about Heroes.
Last edited by Iroh; Jul 15, 2013 @ 3:38am
Caipling Jul 15, 2013 @ 10:37pm 
i deleted my driver and reinstalled with an older version 314.22-notebook-win8-win7-64bit-international-whql from nvida site. it solves the problem.
Caipling Jul 15, 2013 @ 10:39pm 
Originally posted by Iroh:
Originally posted by Caipling:
at start up, an error message pops up by windows saying "might &mighc heroes VI shades of Darkness has stopped working. A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available." and it only has a close program bottom on it. after clicking it it brings me back to Uplay.

I have geforce 320.49 the latest driver installed for my Geforce GT 650m . I'm running a windows 7 home 64
I have the same problem. Driver 320.18, updated to 320.49, Geforce GT 650m. I'm running a Windows 8 64. I guess it's not hardware or driver problems. Still don't work.

i deleted my driver and reinstalled with an older version 314.22-notebook-win8-win7-64bit-international-whql from nvida site. it solves the problem.
Caipling Jul 15, 2013 @ 10:39pm 
Originally posted by mbrailas:
Yup that sounds pretty much identical to my problem. Really hopes this gets handled soon. At least I know it's not specifically a problem with my computer. If a lot of people are experiencing this, Ubi is going to have to do something about it.
i deleted my driver and reinstalled with an older version 314.22-notebook-win8-win7-64bit-international-whql from nvida site. it solves the problem.
Caipling Jul 15, 2013 @ 10:42pm 
if 314.22 is not working for you, try those drivers one by one from new to old from nvidia site http://www.geforce.com/drivers
yjesus Aug 27, 2013 @ 5:39pm 
Had the same problem. Installed the NVidia beta driver version 326.80, and it fixed it. :)
matthiassept Aug 29, 2013 @ 2:40pm 
Originally posted by Caipling:
at start up, an error message pops up by windows saying "might &mighc heroes VI shades of Darkness has stopped working. A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available." and it only has a close program bottom on it. after clicking it it brings me back to Uplay.

I have geforce 320.49 the latest driver installed for my Geforce GT 650m . I'm running a windows 7 home 64

i got the same problem, but i havent buy shades of darkness, but in my uplay libary ist shows me a picture of it, but i only got the normal game and the two dlc´s
superslam1 Aug 30, 2013 @ 10:46pm 
I dont know if anyone else is having this problem, but i too was having issues with my game starting but just going into a black screen with a gauntlet on it that i could move around but would go nowhere. Let me be specific though. The game starts to load and the first thing i see is the blue ubisoft logo that turns from blue to red. Now at some point it comes up with just might and magic VI in letters. If i do nothing that goes away and my screen goest to a black screen where i have my mouse cursor gauntlet and never goes anywhere else. If however, i hit the escape key the moment i see the might and magic VI letters start to come accross, i get to another screen that has might and magic 6 with a red sun or something in the middle and some technology logos at the bottom. If i see that screen it will work fine. I will then be on the main menu page. I have tried every campaign and i have them all. All of them work except the dungeon one. I can select hero, start map, choose my extra resources, tarot deck, or money and accept and get to black screen and never any further. sorry for long post.

superslam1 Aug 30, 2013 @ 10:53pm 
I should also add that im running a nvidia geforce 9600 GSO. I have tried upgrading graphic drivers to latest version and same thing. If you bought this on steam like i did idk if anyone is having problems registering it and it has been mentioned elsewhere you have to use the gold unlock key for it to register on uplay. Once you get into the main menu and are logged into the conflux, choose the option to unlock content and even if you have all installed it should show you pictures for each add on and whether its actually unlocked with a green check mark. If not copy down your cd keys from steam and click on the unlock picture for that add on and it will ask you for the cd key. Enter it and you should be able to play the campaign from the campaign menu. Hope this helps someone.
Showing 1-15 of 28 comments
< >
Per page: 15 30 50