Zamaszysty Jul 14, 2013 @ 5:51am
Heroes VI are unplayable on Windows 8
Hi, I just bought this game on sale today with all DLC addons etc. Apparently it crashes on startup, and no matter what I try, it is not launching at all. Reinstalling UPLAY did not give any positive effects, reinstalling the eintire game did not work either.

I am curently stuck with a game that does not work under any conditions, and reinstalling the gmae or the launcher are useless. My drivers are all up to date, but this still is not working at all.

Any ideas ? :(
Last edited by Zamaszysty; Jul 14, 2013 @ 5:51am
Showing 1-15 of 40 comments
< >
TDF Damien NL Jul 14, 2013 @ 5:52am 
same problem here :(
dvs_x Jul 14, 2013 @ 6:35am 
Mine works fine on WIn 8 x64
Sowilo Jul 14, 2013 @ 6:40am 
I play it on x64 win 8 no problems...
Mad Cheshire Jul 14, 2013 @ 6:52am 
What happens? Does Uplay freeze or crash? Or does the game freeze at "splash screen /Logo" thingy?
Whisler Jul 14, 2013 @ 6:56am 
For me Uplay can connect with the internet. last time i will ever buy a game from it. And steam shouldn;t sell this crap gives them a bad name imo.
Miyoko Rei Jul 14, 2013 @ 7:39am 
I'm running Windows 8 x64. The game is working for me. Are you using Windows 8 x86 or x64?
michaelm82 Jul 14, 2013 @ 4:58pm 
Running windows 8 64 no problems other than lack of sleep due to playing this game!
Eksil Jul 14, 2013 @ 5:03pm 
Win7. I get the error: Might & Magic Heroes VI Shades of Darkness has stopped working.
Last edited by Eksil; Jul 14, 2013 @ 5:04pm
PerroVieho Jul 14, 2013 @ 5:04pm 
I'm using W8 x64 and it's crashing too everytime I try to launch it...
Little Falcon Jul 14, 2013 @ 5:04pm 
when i try to instal it just says unnown error
Miyoko Rei Jul 14, 2013 @ 6:37pm 
Check and make sure Direct X, runtime files, video card drivers, etc are up to date. Then if its still not working try running it in compatibility mode.
sickleek Jul 14, 2013 @ 6:42pm 
running fine here on w8 64bits.
whatever the prb you are having, it's unlikely to have anything to do with W8.
what is your pc made of ? gfx and such ?
Miyoko Rei Jul 14, 2013 @ 6:46pm 
Taken from Ubisoft Forums:

Possible solution
Hey i had the exact same problem recently. I noticed that the problem was with Mircosoft Visual C++, and with some help from google I discovered a solution in uninstall all your versions of Mircosoft Visual C++ and the reinstalling Heroes VI. This allows it to install the version of Microsoft Visual C++ that i was build with, and it fixed it for me.

I tried just reinstalling both Heroes VI and Microsoft Visual both without results hopes this helps if you haven't solved it yet
Eksil Jul 14, 2013 @ 6:46pm 
GeForce GTX 680M
Intel Core i7-3610QM @ 2.30GHz
16GB DDR 3
all latest drivers
Miyoko Rei Jul 14, 2013 @ 6:48pm 
Here's another one. Try revalidating the files through steam.
Showing 1-15 of 40 comments
< >
Per page: 15 30 50
Date Posted: Jul 14, 2013 @ 5:51am
Posts: 40