Might & Magic: Heroes VI

Mad Cheshire Jul 14, 2013 @ 3:22am
[Guide!] to get the game work. -- Issues with Uplay & Error 1 & game freezing.
---If you bought the Gold Edition, Uplay will ask you serial for: "M&M Heroes Shades of Darkness" Use the Gold edition serial for it. ---
-
If you have more issues with serials:Look this post.
-
If at lauch game gives you: Error 1
Also works if game freezes at start up. In splash sceen / Logo

I start by saying this. Most of these problems are from Uplay launcher and overlays.
So first we want to reinstall ubisoft launcher.

1) Uninstall the "Ubisoft Game Launcher" software from the 'Add/Remove Programs' (Windows XP) / 'Installed Programs' (this can be found via control panel)

2) _This is important_
Ubisoft launcher leaves data on your computer. So we need to go delete it.
C:\Program Files\Ubisoft\Ubisoft Game Launcher (32-bit versions of Windows) or C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher (64-bit versions of Windows). Delete the whole directory. We want all that gone.

3) Go here:
Ubisoft Game Launcher Download[static3.cdn.ubi.com]
download and reinstall ubisoft launcher.

If the link doesn't work for any reason, go here:
The-link-to-download-the-UBISOFT-GAME-LAUNCHER-Finally-Forums[forums.ubi.com]


4) Close Steam. (make sure steam is really closed, not hidden in toolbar.)

5) Go to: C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher
-Right click on Uplay.exe
-Select Properties
-Go to: "Compatibility" tab
-And select the: "Run as administrator" on.

6) Start Uplay.exe (As steam is closed it should be able to start updating.)

7) After it updated, make account or login.

8) In right corner, there is a "wheel" icon. Click it. Select "Settings"

9) _Untab_/deselect "Enable in-game overlay for supported games."

10) Click save.

11) You can now close Uplay and start Steam.

12) Happy gaming. :)
While starting the game from Steam, it will open Uplay. Remember that you also need to add your game serial (given by Steam) to your Uplay account.
.
.
First intro/cutscene seems to be half black for many users.
Fix: Right in this topic

.
"Cannot connect" problem

Originally posted by Xander:
Here's how to make a workaround for this issue:
Go to C:\Windows\System32\drivers\etc\ and open hosts with a plaintext editor.
Add entries for the three Ubisoft static servers by adding this to the bottom of the file:
Code:

87.248.214.183 static3.cdn.Ubi.com
95.140.224.199 static2.cdn.Ubi.com
87.248.214.183 static1.cdn.Ubi.com


From ubisoft forums:
If you receive this message and can otherwise connect correctly to the Internet with other programs, please try the following steps:


1) Make sure your Uplay PC client is up-to-date. You might also want to try desinstalling and reinstalling Uplay PC by downloading the latest version from Uplay.com


2) Follow the steps provided in the following Support article to check your firewall, open the needed network ports, check background applications or your "hosts" file:
AC3 Launcher and multiplayer connection issues[ubisoft.custhelp.com]

Method 2) (seems to work sometimes)

Open the ports TCP: 80, 443, 13000, 13005, 13200, 14000, 14008 in the windows firewall (Find it in control panel)
Then boot up your windows in safe mode with networking, Uplay should now be able to connect.

You only should have to boot up Uplay in safe mode for the first time (so it can update), and then you can run it in normal startup mode.
.
.
Can't connect to the CONFLUX

Most of the problems seems to be from firewall or other programs (Peer blocks)
Sadly most of them are running on the background and are hard to find.

Some people have get it to work, if they reinstall Uplay. (See step 1)


I hope this helps.
If nothing seems to work you may try Ubisoft Support: https://support.ubi.com/en-gb/
Last edited by Mad Cheshire; Jul 15, 2013 @ 12:28pm
Showing 1-15 of 92 comments
< >
Tanveyor Jul 14, 2013 @ 3:39am 
step 3 is invalid, there might be a problem with ubisoft ?
Mad Cheshire Jul 14, 2013 @ 3:41am 
Dont put www. in front of it. (normal problem)
:3 I can try to put the link other way.
Tanveyor Jul 14, 2013 @ 3:45am 
still not working, no www in front of it
Mad Cheshire Jul 14, 2013 @ 3:49am 
Tried to fix first link. Added Ubisoft forum topic.
saltan Jul 14, 2013 @ 3:51am 
this helped me after 90 mins (steam telling ive been playing the game) of messing around to try get the game working ive now got half a cut screen going on o.O
Mad Cheshire Jul 14, 2013 @ 3:54am 
Yeah the "Half cutscene"-problem is still something i'm working on. Game works fine, just not the cutscene.
[\/]3TA/\/5|_| Jul 14, 2013 @ 4:14am 
How did you guys get the links to work? I always get the "Server not found" error?
Menace Jul 14, 2013 @ 4:23am 
me too buck, and i even can´t download uplay...site is down?
Mad Cheshire Jul 14, 2013 @ 4:27am 
Weird indeed. Both links work fine for me. (maybe cause of internet cache) The direct link and the Ubisoft forums. I recommend trying to google "Ubisoft game laucher download". or similiar. Basicly I just provided fast link to download latest launcher/installer.
[\/]3TA/\/5|_| Jul 14, 2013 @ 4:30am 
Good to read I'm not the only one. Well, guess we'll just have to wait then. Pretty ♥♥♥♥♥♥ that Ubisoft doesn't have a backup server. And I can't understand why the Steam version doesn't come with the latest version of uplay anyway. Surely they could have known that reducing the price of HOMM6 would get more people to download it...
[\/]3TA/\/5|_| Jul 14, 2013 @ 4:42am 
Mad Cheshire, great tip about the hosts file edit, that did it!
iFruit Jul 14, 2013 @ 6:12am 
@Mad Cheshire, I'm having real trouble finding a interactable version of the launcher, official ubi/uplay site link is broken, can you please help with a working link?
Mad Cheshire Jul 14, 2013 @ 6:37am 
Originally posted by GreenP01son:
@Mad Cheshire, I'm having real trouble finding a interactable version of the launcher, official ubi/uplay site link is broken, can you please help with a working link?

As it seems people have alot of problems with ubisoft site and cant access the launcher.
I uploaded that file myself, (downloaded today)
link: http://www22.zippyshare.com/v/49754010/file.html

Please recommend good uploading sites if needed.
iFruit Jul 14, 2013 @ 6:46am 
TY, link http://static3.cdn.ubi.com/orbit/launcher_installer/UbisoftGameLauncherInstaller.exe from official forum seems to work

New problem now, though, stupid Ubisoft fckrs now saying my keys are ♥♥♥♥♥.. ffs this Ubisoft is crazy
Mongon Jul 14, 2013 @ 7:13am 
I can't make an account for Uplay because it says I don't have an internet connection..
I don't understand how EA got voted worst company when ubisoft is WAY worse
Showing 1-15 of 92 comments
< >
Per page: 15 30 50