Might & Magic: Heroes VI

Might & Magic: Heroes VI

Purify Society 2013年6月3日上午11:47
Cd key problem
I haven't played this game in awhile. I have Might and Magic Heroes 6 (bought it for $60 when it first came out). I tried to play this game recently, logged in with email and password, then it popped up a shades of darkness box asking for my cd product key. I don't have shades of darkness or any other expansions for this game. I tried putting in my CD key, but it says its already in use on another account, which makes no sense cause I only have one account...the one I just logged into. I can't get past this point. Steam support told me to delete all files in the steam folder except userdata, steam.exe. and steamapps. I did this, and restarted my computer, but I'm still having the same problem. Anyone know how to get past this?
最后由 Purify Society 编辑于; 2013年6月3日上午11:49
< >
正在显示第 1 - 15 条,共 23 条留言
arjnav 2013年6月3日下午9:49 
I'm having the same problem ever since the last update to Uplay. I only have one uplay account and all the ubi games that I bought off steam are on it. Now none of them work. They all take me to the activate CD key step and it won't take my CD keys. I was playing HoMM 6 fine up until last week too.
最后由 arjnav 编辑于; 2013年6月3日下午9:50
philo103 2013年6月4日上午7:34 
It might be a Uplay problem. On the French Ubisoft forum dedicated to 'Heroes VI' there are a few recent topics pointing to the recent Uplay update as a cause of problems, for some users.

The Forum Manager there (a Ubisoft employee) recommends to totally remove and then re-install Uplay, according to this procedure :

Step # 1. Uninstall Uplay from your Windows uninstall-program list. If it is not listed there, go to step 2.

Step # 2. Even if you could execute step 1, manually delete the Uplay (or Ubisoft Game Launcher) directory located @ C: \ Program Files \ Ubisoft \ Uplay ( or Ubisoft Game Launcher) for 32-bit Windows, or @ C: \ Program Files (x86) \ Ubisoft \ Uplay (or Ubisoft Game Launcher) for 64-bit Windows -- unless step 1 has already removed it.

It is important that there remains no left-over files from the previous Uplay installation.

Step # 3. Download and re-install Uplay from http://uplay.ubi.com/.

Step # 4. Delete the file named "Hosts" located @ C:\Windows\System32\Drivers\ETC.

Finally, reboot your computer before launching the new Uplay installation and the game.

This 4-step procedure does not originate from my own personal opinion or experience. The procedure I have indicated is purely a translation of the French Ubisoft representative's recommendation.

Source : http://forums-fr.ubi.com/showthread.php/66092-Probl%C3%A8me-sur-la-mise-%C3%A0-jour-d-uplay/page2
最后由 philo103 编辑于; 2013年6月4日上午7:36
Purify Society 2013年6月4日上午7:57 
@philo103 - I tried it, but that didn't work either. Still having the same problem.
stevenlance 2013年6月4日上午8:22 
ok, I had the same problem that you are all having. Very frustrating. Instead of trying to log on with my e-mail address I tried opening HOMMIV from steam, which opened up uplay and the instead of using my e-mail I used my steam account name with my password and that got me to all my games and allowed my to run HOMMIV. Since ubisoft implemented uplay it seems that there was some sort of dislink between e-mail accounts and steam usernames. Anyways, I know this fix isn't perfect but it works
Purify Society 2013年6月4日下午3:22 
@stevenlanc - no dice :(
игра не принимает CD-key
kmulpeter 2013年6月10日上午11:41 
someone know why the cd key card not working with the uplay
i don't have shades of darkness but it ask for CD-KEY but does not work
Radek_SS 2013年6月11日下午3:19 
My cd key is not working either. Whe the hell is the game shows up as purchased on uplay its not actually let you play in the game itself. I have never encountered such a stupidity...
kristofferboejr 2013年6月12日上午8:51 
philo123 thank you man
Sebastian 2013年6月24日下午10:33 
same problem cant make it work-- i bought all games and expansion packs but gives me just the orginal key code? for orginal with picture of shades of darkness and doesnt work
YOLO #meister 2013年6月25日上午3:40 
ı bougt heroes 6 and expansion pack but they dont give me orginal cd key
BboyBulka 2013年6月29日下午2:58 
Have the same problem - got an original HOMMIV but Uplay asks me to type SoD CD-Key and not receiving it - what should I have to do??!!
ClearJunk 2013年6月30日下午1:16 
looks like alot of people are having this problem, me included. Bought the complete edition on steam and every time i enter the key it tells me it's invalid. Fun fun fun!!! Whats even more anoying is the fact that there seems to be no work around to this problem.
katana 2013年6月30日下午1:21 
One more fraud here:

'Requesting cd-key.'

And yes i have done the usual stuff to solve it.
Veritas 2013年6月30日下午8:12 
Wow, so I must have logged into an old UbiPlay account that didn't see I had played all the original content. Double checked and when I logged into the right account, I'd "used" my CD key and now I'm stuck with 1) Buying it again? or 2) Playing just this campaign on the other account and never getting to add to my achievements.... lame Ubi and Steam. Really lame.
< >
正在显示第 1 - 15 条,共 23 条留言
每页显示数: 15 30 50

发帖日期: 2013年6月3日上午11:47
回复数: 23