Tiny&Purple Apr 17, 2013 @ 9:59am
fix for nvidia card besides donwgrading
i decided not to downgrade my driver... so i went to the utility and changed the specific setting for H6 to be medium. over a month now, no crashes. i only play 2-3 hr each time, so maybe i haven't played enough. but still, it works for me.
i only changed the 3D setting...
Showing 1-11 of 11 comments
< >
Tiny&Purple Apr 17, 2013 @ 10:41am 
talked to soon... the city crashed. in the marketplace :(
still, it feels like its the same as downgrading
Talk to my hand faggot May 27, 2013 @ 12:26pm 
follow this tweak and it could work just fine :

1.Start the Game.
2.Start task manager
3.Select the Game.
4.Right Click the game and hover over the “Set Priority” option. Select Realtime.
5.Right Click the game and click on “Set Affinity.”
6.Deselect CPU0 and click ok.

Work perfect for me on i7, gt 540m, 8gb.
Tiny&Purple May 28, 2013 @ 8:51am 
actually, since patch 2.1 no problems. so far :)
THE AVERAGE May 28, 2013 @ 10:21am 
I've had a few random crashes, but they were not much of an issue, and were *random*. Now though, I've encounterd a fight that will 100% crash my game no matter what, so I simply have to skip it (second necro map in the campaign during Anastasya's mind trip).
Athos May 28, 2013 @ 10:28am 
Originally posted by neonmirrorblack:
I've had a few random crashes, but they were not much of an issue, and were *random*. Now though, I've encounterd a fight that will 100% crash my game no matter what, so I simply have to skip it (second necro map in the campaign during Anastasya's mind trip).

I've read that that stack is a known bug. Nothing wrong with your video card.
Faylana May 30, 2013 @ 7:05pm 
Luckily I haven't had to downgrade my nvidia driver, only issue I have is a black screen when I go into town battles. I've found a fix, to delete the profiledata, but it's still a pain to do. I have to do it maybe every other time I play. Didn't have this problem before, so maybe it was a new patch or something.
HazardHawk Jun 12, 2013 @ 5:48am 
My apologies Sir, I just posted this same answer on another thread as I had not seen yours yet. Is there any way to get the admins to sticky these directions so people will stop going nuts looking for the answers?

Originally posted by Lord_Ramzei:
follow this tweak and it could work just fine :

1.Start the Game.
2.Start task manager
3.Select the Game.
4.Right Click the game and hover over the “Set Priority” option. Select Realtime.
5.Right Click the game and click on “Set Affinity.”
6.Deselect CPU0 and click ok.

Work perfect for me on i7, gt 540m, 8gb.
Golan_Maoz Jun 13, 2013 @ 2:11pm 
Works for me as well.. thanks "hazardhawk" :)
HazardHawk Jun 14, 2013 @ 7:09am 
No thanks to me... The thanks should go to whoever it was that found the same issue with Supreme Commander as it has the same multi core cpu problem. What seems to happen is Heroes 6 runs almost totally on CPU0 and does not multi thread well. By removing CPU0 it forces it to spread out across the CPU spectrum and actually plays much smoother as well. It also seems to have an issue with Nvidia Cards using the CPU for Physx.

EDIT: This is in no way comclusive as I do not have the Heroes 6 code to play with, but I do have 4 machines and the only one without problems is an older quad core with ATI card. Even on this particular machine though if you disabled CPU0 the game runs so much better!
Last edited by HazardHawk; Jun 14, 2013 @ 7:14am
Tiny&Purple Jun 14, 2013 @ 8:19am 
Hazardhawk, what about using the GPU for the Physx?
HazardHawk Jun 14, 2013 @ 8:52am 
That is where I have mine set and it does not give me problems
Last edited by HazardHawk; Jun 14, 2013 @ 8:52am
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: Apr 17, 2013 @ 9:59am
Posts: 11