InsanePriest Apr 11 @ 3:21am
Game does not even start
Hey guys, did not find a thread like this, but this really keeps ♥♥♥♥ing me off.
I've been a huge fan of the HoMM-series since part 3 and I've even bought this game twice, because the other one is attached to a uPlay-Account where I cannot remember the password or the trashmail for it :D

Anyways, now I bought it again on steam some time ago, but for quite a long time it keeps crashing right from the start. I do get into uPlay, start the game, that kinda loading sign with the archangel and the devil appears, but then it suddenly crashes and it says: HoMM6 is no longer playable.
I even deinstalled and redownloaded these 10gb, but that did not help at all.

Any kind of help, especially rewarding would be nice =)
Thanks!
Showing 1-4 of 4 comments
< >
InsanePriest Apr 11 @ 3:22am 
note: it worked for some time, then suddenly this crap started
Thorgald Apr 15 @ 3:22pm 
It's a driver issue (i'm assuming you have an nvidia card) and no it's not nvidias fault, ubisoft are being their usual a**hats. I tried playing it again today after not touching it for half a year and at first it was working fine, then when i loaded in to a combat map the game crashed, and now i can't even get to the f*cking loading screen. The instant the game goes fullscreen it crashes. Ubisoft claims it's most likely because i have both an intergrated gfx card and a dedicated one but i don't (and it shouldn't f*cking matter in the first place!). So unless ubisoft gets their thumb out of their arses (and they never will, because it's ubisoft) we're stuck with a game that isn't fit for purpose.
InsanePriest Apr 16 @ 3:05am 
Yes, I do have a an nVidia-card.
I can't believe Ubisoft really managed to destroy one of my favourite games :O
But thanks for your answer!
DinDin Apr 16 @ 7:26am 
I know he told me to downgrade the graphics driver said to run a 3.14
Last edited by DinDin; Apr 16 @ 7:26am
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Apr 11 @ 3:21am
Posts: 4