Assassin's Creed Brotherhood

Assassin's Creed Brotherhood

[TLK] Esparko Feb 24, 2013 @ 6:46pm
Serious glitch during Sequence 9 - "The Fall"
I've tried all the things in trying to fix this glitch but I can't fix it. During the invasion, I climb up the 2nd seige tower to fight Cesare but upon entering the area, nothing happens.

I've:

Redownloaded the game
Killed everyone in the area to gain full notoriety before entering
Restarting the memory

But nothing happens, I've googled this and other people have encountered it, but i can't fix it. Has anyone got any idea?
< >
Showing 1-11 of 11 comments
SiberianDingo Mar 4, 2013 @ 5:13pm 
I'm stuck in the exact same spot
I found other people who had the same problem too
http://www.youtube.com/watch?v=M2EXRFSMbGQ
in the coments they posted 2 possable solutions, non of them worked for me
Big Booty Slamma Mar 6, 2013 @ 3:20pm 
turn on vsync
SiberianDingo Mar 9, 2013 @ 2:10am 
wow, that totally solved it
I never would have guessed
[TLK] Esparko Mar 9, 2013 @ 12:20pm 
wat. sigh. I already uninstalled it and just watched someone play it on YouTube. Thanks for that anyway.
Links May 18, 2013 @ 11:49pm 
Thanks
xale Jan 30, 2014 @ 8:52am 
Originally posted by Big Booty Slamma:
turn on vsync
I already play with vsync on and I tried turning it off then back on but it didn't work. Anyone have a solution to this?

EDIT: I got it to work. When you have climbed the 2nd siege tower, lure the guards after you towards the checkpoint. I did that and the cut scene finally started
Last edited by xale; Jan 30, 2014 @ 9:09am
marky1124 Jul 18, 2014 @ 6:18am 
Vsync=on, having guards follow me, and 60Hz frame rate setting didn't help me. The solution for me was to follow ssj2rich's solution on this youtube webpage (in the comments)
https://www.youtube.com/watch?v=M2EXRFSMbGQ

In summary he identified that if you move your old saves to a new folder. Start a brand new game, play until the first checkpoint, then exit and copy the .sav file you saved originally into your save game location then it fixed it. I did that (whilst also having vsync=on, guards follow me + 1920x1080x60 display), and it worked first time.

On Windows 7 my save game location was C:\Users\<user>\Saved Games\Assassin's Creed Brotherhood
I had this problem too. I simply just restarted from the checkpoint and slowly approached the area again. It worked for some reason
⊰Kørrupt Dec 6, 2015 @ 11:09am 
Had the same problem, turning on Vsync works tho. Weird...
Scot Aug 21, 2016 @ 3:37pm 
Same problem for me but Vsync did not fix it. I had to do the same as for the glider flying mission. You have to set your display resolution to 60 Hz.
switch Jan 20 @ 4:14am 
Make sure your Nvidia Control Panel isn't set to Vertical Sync: Fast. Change it to on or vsync will be off even though it's set to on in the game. This is what finally fixed it for me.

Don't forget to change your Vertical Sync back to Fast after you are done!
Last edited by switch; Jan 20 @ 4:15am
< >
Showing 1-11 of 11 comments
Per page: 15 30 50