Cody Jan 14 @ 8:02am
Assassin's Creed Brotherhood will not launch (Windows 7 32-bit)
I purchased all the Assassin's Creed games during the winter sale and every single one works perfect except for Brotherhood. No matter what I try the damned thing wont launch. I double click, the hourglass will appear for a few moments, sometimes the steam "Preparing to Launch" window will pop up, and then nothing.
I've all the requirements for the game to work, and I've tried everything I've seen on fixing it. Moving the game launcher, re-installing the game (4x), verifying integrity of game cache (which every single time shows one file missing/corrupted), and I've tried adding the damned saves file into the Saved Games folder as well as into My Documents (which is where all of my games save to -.-) and NOTHING WORKS.
Last edited by Cody; Jan 14 @ 8:04am
Showing 1-4 of 4 comments
< >
234metalhead Jan 14 @ 1:47pm 
This is a longshot but this is what I would do. Uninstall the game, then go to steam library, right click assassins creed brotherhood and click "delete local content." Then re-install it. I can't think of any other reason why it won't load.
Cody Jan 14 @ 2:43pm 
Unfortunatly I've tried that also. :/
rafaelherschel Jan 24 @ 3:01pm 
Somebody posted this a while back, worked for me:

"Quote:
Originally Posted by Zoxuf View Post
Try creating the following folder if you dont have it.

C:\Users\<USERNAME>\Saved Games\Assassin's Creed Brotherhood\Saved

I was having the same problem but this fixed it for me."
Cody Jan 25 @ 7:55pm 
I did that and it never worked. I ended up completely reinstalling windows and now the game works fine. Thanks for the help though.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50