Valiant Jan 27 @ 3:50pm
MAC OS X PROBLEM!!!!! again -_-
Im almost certain this has been solved 1000, times but it wont work. I go to the folder, click on acbmp_sf, it opens. But it never actually starts the game. The screen just stays black and won't start. HELP PLZ!!!!!!!!!!! thank you.
Showing 1-14 of 14 comments
< >
StoneCeption Jan 28 @ 11:41pm 
I have the same problem with my mac but i can't help... :(
Valiant Jan 29 @ 3:50pm 
:(((((((((((
StormShadow Feb 1 @ 8:52pm 
they have to fix this ♥♥♥♥
Valiant Feb 2 @ 9:30am 
ikr
Masterhaas Feb 3 @ 6:20am 
Mee to, it starts, nothing happens, and then i receive some sort of error
Luke Feb 15 @ 11:53am 
My game doesn't work on my Mac either. I'm so sad about it. I bought it all happy that I'd be able to play and then nopeeee. I've tried reinstalling it, and it still doesn't work. Please fix this, someone!
EriktheWikinger Feb 20 @ 4:51am 
is it already fixed?
Klap Feb 20 @ 2:37pm 
rightclick "assasins creed brotherhood.app" and choose "show content".
goto /Contents/MacOS
doubleclick "acbmp_sf"
a terminalwindow will appear and then AC:B will start and you are able to login to your mp account or choose cancel do play singleplayer.
jadogibb15 Feb 21 @ 3:35am 
I click on play it opens and then it closes :(
|AQ|BrightWhale Feb 21 @ 9:51am 
OS: Only OS X version Leopard 10.5.8, Snow Leopard 10.6.3.
Processor: Intel Core 2 Duo 3.06 GHz
Memory: 3 GB
Graphics: 256 MB Dedicated Shader model 3.0 or higher (see supported list)
Hard Drive: 9 GB
Note: This product does not support OS prior to Mac OS X 10.5. This product does not support Macs based on PowerPC CPU
READ THE NOTE NOT SUPPORT FOR MAC OS
Locksly Feb 21 @ 11:14pm 
Same troubles, it wont even startup. I'm extremely disappointed they took my money only to supply a faulty product. They need to fix this, BEFORE sending it out.
matt_bry Feb 22 @ 8:52am 
well iv just looked at all them posts and its put me totally off buying it, ubisoft need to do something and fast
hairydonut123 Feb 22 @ 1:36pm 
it sucks i was heaps excited to play and then i launched it and i was happy and then it crashed
i tried again but still it crashed
Valiant Feb 22 @ 1:42pm 
it sucks that ubi soft wont even try to fix it
Last edited by Valiant; Feb 22 @ 1:42pm
Showing 1-14 of 14 comments
< >
Per page: 15 30 50