LIMBO
LIMBO > General Discussions > Topic Details
Eliwood Feb 23, 2014 @ 9:55pm
Limbo only displays black screen
Sorry for the language but... I have recently upgraded my computer and I can play practically any game. Sonic Generations at full specs, Saints Row 4, etc. etc.

But this game. This ♥♥♥♥ing game. This ♥♥♥♥ is the only game in my entire library that refuses to start. Let me explain. EVERYTHING ELSE STARTS EXCEPT THE VIDEO.
Sounds will play, I can even access the menu (but I can't see it). I've tried messing with all the settings. Changing the video properties, putting it in Windowed mode, leaving it in fullscreen mode. No matter what I ♥♥♥♥ing do this game still refuses to actually display any imagery for me to enjoy. I've heard a bunch of fantastic things about this game and I've always wanted to play it. I've already tried verifying the game cache, I've already redownloaded DirectX, I've already reset my computer, I've already deleted and reinstalled LIMBO, but this ♥♥♥♥er still refuses to start. If anyone has got some advice on how to get around this, someone PLEASE tell me. This seems to be a huge problem with the Steam version of LIMBO I've noticed.
< >
Showing 1-11 of 11 comments
Eliwood Feb 27, 2014 @ 10:47pm 
There's absolutely no way I could be the only person on steam to have this problem.
Rodr1g0 Jun 29, 2014 @ 11:38pm 
did you fix that?same problem here =/
Mikail Jun 30, 2014 @ 11:39am 
Ugh Having the same problem
Eliwood Jun 30, 2014 @ 6:56pm 
No I haven't been able to solve this problem. I even redownloaded my video drives just to MAKE SURE I had all the up to date details but nope. Nothing. And no one on here seems to even have any solutions either.
Rodr1g0 Jun 30, 2014 @ 10:15pm 
so i just verified the cache integrity and this works 0__0 =D my windows is 8.1 Pro with all updates ....good luck guys.
ergbigred Jul 7, 2014 @ 2:46pm 
The non-DRM runs OK directly frum Ubuntu 12.04, but I tried the Steam version and just got your black screen of death, not even sound! I had to ctl-alt-del and reboot to escape.
Eliwood Jul 8, 2014 @ 9:15pm 
I wish reverifying the cache worked for me but it didn't. It might be an issue with DirectX I don't know? But I've tried redownloading it and everything and nothing worked so I don't know what's up.
HellCat666 Jan 3, 2015 @ 11:35am 
Same problem on Linux, ♥♥♥♥ developers, lazy ♥♥♥♥ers, they don't want improve old bugs !!! Don't buy this crap of ♥♥♥♥ !!!! I want my money back !!!!!
Last edited by HellCat666; Jan 3, 2015 @ 11:36am
Hey buds.
To GNU/Linux users (and maybe Win or OSX users?) ==> check your screen's refresh rate is not higher than 60Hz. Indeed, the game won't work until you change this setting in your graphic card's driver settings.
In my case, the refresh rate of my screen is 144Hz and I had to force the refresh rate to 60Hz in my NVidia graphic card's driver settings.
Note: The -refresh60 setting you can set to launch the game is not working either.
Cheers.
Inukaze Jun 21 @ 11:17am 
Under GNU/Linux , i just got Black Screen, the menu sound. i can exit normally, i cant see the game.


Using PlayOnPOSIX {PlayOnLinux/PlayOnMac} , and some wine version updated, and the follow override :

d3dx9_28.dll = Vertex Shaders 2.0
d3dx9_36.dll = Vertex Shaders 3.0
d3dcompiler_43.dll -> I do not remember doing
d3dx9_43.dll -> I do not remember doing
xinput1_3.dll = Is for Gamepads in case dont works fine with internal libs

My Hardware :

Processor : AMD Athlon X2 +6000, 3,00 GHz (Dual Core)
RAM : 3,00 GHz, DDR2, 667 MHz
Video : Nvidia GeForce 6200 TurboCache(TM), 256MB


Product Site -> http://www.nvidia.com/page/geforce6200_pci

TechSpecs Site -> http://www.nvidia.com/object/geforce6_techspecs.html

Linux OpenGL Caps -> http://feedback.wildfiregames.com/report/opengl/device/GeForce%206200%20TurboCache(TM)


Steam Reqs :

OS: SteamOS, Ubuntu 12.04 or later, or otherwise compatible Linux distribution. ( I have Debian Jessie Stable & Manjaro OpenRC Xfce )

Processor: 2GHz ( I have 3 GHz Dual Core )

Memory: 1 GB RAM ( I have 3 GHz )

Hard Disk Space: 150MB ( I have a lot free )

Video Card: OpenGL 2.0 compatible video card with 256 MB shared or dedicated RAM (Follow Specs Tech Site "Shader Model 3.0
Full OpenGL support, including OpenGL 2.0")

But i can't play fine under GNU/Linux. i try to set @60 Hz, don't work for me
i try too, put backlightbuffer = 864 , don't work neither.

i use 1152x864 , desktop resolution.
Last edited by Inukaze; Jun 21 @ 11:31am
Inukaze Jun 21 @ 5:30pm 
Well i claim free this game today, i can't play because of a "Black Screen" the menu sound fine. i have the reqs for GNU/Linux but if i can see the game i can't play it

Well , the unique alternative i found its installing Steam via PlayOnLinux + Wine 1.8 SteamCrossOverHack package

Inside Steam For Windows, install Limbo, and after download my compilation of files and registry keys need it for play it

Mega -> https://mega.nz/#!7U82GJyR!KmvzE9Z64QxMGHQQBVqNTh3g5rPSYHZCJdUnE5K3NRw

MediaFire -> http://www.mediafire.com/download/5t0igq3ps5fny07/PlayOnPOSIX_InukazeLIMBO.zip

I really wanna play with native for GNU/Linux . but i can fix it under Wine, but i can't fix it under GNU/Linux yet.

Under Wine i know the files are for Verter Shaders 2.0 & 3.0 , and activation of GLSL for i can see it.
< >
Showing 1-11 of 11 comments
Per page: 15 30 50

LIMBO > General Discussions > Topic Details