MJ_JM^walk Feb 23, 2013 @ 4:10am
Laggs if I scroll
I have a very good pc (Intel core i 7 3770, AMD Radeon 7770 HD, 8GB Ram) but if i scroll ingame it has laggs. I can't understand that. The drivers are already updatet. Please, if somebody can help me tell me pls. (It doesn't matter if I play on high settings or on low settings it laggs over all)
Showing 1-8 of 8 comments
< >
BigBossJD Feb 23, 2013 @ 6:52am 
Turn adaptive anti aliasing off in the ati control centre and get a framerate limiter and limit your fps to..say 60. that might help
BigBossJD Feb 23, 2013 @ 6:53am 
you might want to defrag your pc too
=EGC= Serenity Feb 23, 2013 @ 2:38pm 
Vsync + Tripple Buffer helps alot. Just force it on in the driver.
Some stutter may still be present when scrolling, but the image tearing will be eliminated so it will not seem as bad visually.

Not sure how to get rid of it completely though..
Or at least I couldnt with a 2700K @ 4.6Ghz, 8GB of 1866 RAM, and a SuperClocked GTX 570 with Sims 3 Installed on a Intel SSD.
Though not top of the line these days, this rig should have no issues whatsoever with the Sims.

I think its just the game. But, Vsync will help alot so its not nearly as bad.
In my particular case, running with AA off or AA at MAX made no difference either. So I just leave it ON Maxiumum as it looks better with no performance hit. You may find the same results, but worth testing both ways.
Last edited by =EGC= Serenity; Feb 23, 2013 @ 2:40pm
MJ_JM^walk Feb 23, 2013 @ 2:51pm 
Thank you guys for your answers. But i have a question: Where can i Force it? I have the amd cataclyst programm
=EGC= Serenity Feb 25, 2013 @ 1:04pm 
Im unfamiliar with AMD these days. But in the Nvidia Control panel, you have a 3D section where you can force all games to run at a specific setting, or make a profile for individual games. I do individually, and make a sims 3 profile and set Vsync from Application managed to ON, and the same with Tripple Buffer.

A while back, with ATI card you could just make a profile.= and save it. Then you had to enable whatever profile before launching the game.
I also remember at that time, very few games would work with forced Vsync settings, and it required D3D Overider (I think) 3rd party app to get it to work with ATI cards.

Sorry, its been awhile and that was under much older CCCs. Perhaps its changed and others may know more specifics about the current state of AMDs CCC.
Audacious Hound Feb 27, 2013 @ 8:10am 
the same happens to me but it still works :)
MJ_JM^walk Feb 27, 2013 @ 8:24am 
Originally posted by Silent Soul:
the same happens to me but it still works :)
How did you fix it?
katzenkrimis Feb 27, 2013 @ 11:31am 
Originally posted by =EGC= Serenity:
But in the Nvidia Control panel, you have a 3D section where you can force all games to run at a specific setting, or make a profile for individual games. I set Vsync from Application managed to ON, and the same with Tripple Buffer.

Good advice.

I strongly recommend players do this, if they can.

It completely eliminates the god-awful tearing.

This is one of those games where people with good computers get pretty choked when they see how it runs the first time they fire it up. And the limited in-game graphics settings don't help the cause.


Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Feb 23, 2013 @ 4:10am
Posts: 8