The Sims(TM) 3

The Sims(TM) 3

Shinneth Jan 12, 2013 @ 8:09am
Corrupted Saves & Invalid Cache Files
I think this might have something to do with the >800 MB update that Steam automatically processed a few days ago, because since then I've been unable to use any of my save files from my game. They still exist, but when I hover the cursor over the files it says they contain content that is no longer on the system.

I've tried the option to validate the game's cache files on Steam multiple times, and each time it says that 4 files failed to validate and will be reacquired, following that is a tiny (2.8 KB) update for the game that still doesn't change the situation. So I don't think anything's actually been resolved and I have no idea how to fix the problem.

I'm using a PC with Windows 7 and acquired all of the DLC from the holiday sale on Steam last month, so I haven't had the game for very long but barring some lags in certain areas the game has worked just fine up until now. All of the DLC has been registered and still shows up (I still get the Seasons screen when I load the game for example) so I don't know what's causing my saved games to not run. I've made so much progress in my saved games that I really don't want to start all over, so is there any way to salvage my progress?
< >
Showing 1-6 of 6 comments
-Fields- Jan 12, 2013 @ 9:01am 
Checked your save games folder?
Shinneth Jan 12, 2013 @ 9:35am 
Yeah, everything is still there and in order. I noticed there was a folder that had stuff with a .bad extension and I read somewhere that those were unusable and should be deleted, so I did, but that didn't change anything.
-Fields- Jan 12, 2013 @ 10:11am 
Does it list the 4 failed files? Been a while since I had a issue with a game so unsure if it does or not
Shinneth Jan 12, 2013 @ 10:26am 
No, it doesn't. Steam just says 4 files failed to validate and "will be reacquired", which I assume means they were to be automatically reacquired, but all that happens is a very tiny update to the game (2.6 KB) and that still changes nothing. I still get the same error message when I try to access my saves.
PrimusCovenant Jan 12, 2013 @ 10:37am 
Try this website: I always go there for savegame files.
Shinneth Jan 12, 2013 @ 10:58am 
Hm... well, I followed those procedures (copying the save folders and placing them somewhere else, then deleting the main save folders and renaming the backup folders), but nothing changed. There's still a "this save may contain material from an expansion pack that is no longer on the system" message even though there's no evidence that I lost any of my DLC. It may or may not be related, but now it's having issues signing me in at the main menu. I wonder if this is because Steam-installed Sims problems can't be solved the same way as ones that were installed from a CD...

EDIT: On further research it looks like I'm lacking the file, so that might be the core problem here. I'll try making a new family so I can make copies of that file once I figure out why I can't log in on the main menu. Riverview also seems to have disappeared from the town menu as well.
Last edited by Shinneth; Jan 12, 2013 @ 11:16am
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Date Posted: Jan 12, 2013 @ 8:09am
Posts: 6