DemonRose Mar 20, 2013 @ 7:33pm
Sims 3: 70s, 80s and 90s
I had bought the Sims 3: 70s, 80s and 90s from Steam and I had downloaded it. Upon opening the Sims laucher at the bottom of all the games I have, which is every Sims 3 game, I noticed that this DLC was not on there. So can you help me?
Showing 1-15 of 18 comments
< >
l3v3l.z3r0 Mar 21, 2013 @ 5:44am 
Same problem here.
!Snow! Mar 23, 2013 @ 12:50am 
same
Grimly Feendish Mar 23, 2013 @ 6:38am 
Same problem. Not showing up in game even though its installed :(
ladysmithly Mar 27, 2013 @ 8:27pm 
Happened to me too. I tried registering the game on the sims 3 website with the CD code from steam and it's still not showing up. I don't know what else to try.
Alexis Mar 28, 2013 @ 11:24pm 
D: SAME
Sharpe_nicky Apr 2, 2013 @ 3:17am 
Any help?
DemonRose Apr 2, 2013 @ 6:38pm 
None. Though I am glad that others have the same problem
ladysmithly Apr 4, 2013 @ 8:13pm 
Yeah it's still not working. I even tried redownloading everything and it still didn't show up. Looks like I'm out 20 bucks.
Scarlet Tears Apr 6, 2013 @ 8:45pm 
I have the same problem and I have had it since the game came out! :(
Reverend Apr 8, 2013 @ 9:47am 
Also have the same problem.
Jessi Apr 10, 2013 @ 3:12pm 
Yep same problem here! At least give us a refund if you can't provide the goods EA!
Reverend Apr 10, 2013 @ 6:18pm 
There is a fix by changing the Regedit settings. Sorry I am not very computer literate but I have even managed to get mine working by following the instructions in another thread, here is the info I had to copy to notepad:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sims(Steam)\The Sims 3 70s 80s & 90s Stuff]
"ContentID"="sims3_Sp08_sku7"
"country"="US"
"DisplayName"="The Sims 3 70s 80s & 90s Stuff"
"ErgcRegPath"="Electronic Arts\\\\Sims(Steam)\\\\The Sims 3 70s 80s & 90s Stuff\\\\ergc"
"ExePath"="C:\\Program Files (x86)\\Steam\\SteamApps\\common\\the sims 3\\SP8\\Game\\Bin\\TS3SP08.exe"
"Install Dir"="C:\\Program Files (x86)\\Steam\\SteamApps\\common\\the sims 3\\SP8"
"Locale"="en-US"
"ProductID"=dword:00000011
"sku"=dword:00000007
"Telemetry"=dword:00000000

Include the top line as well. Hopefully someone can explain it better, as I basically bumbled through the instructions. If you browse the forums for The Sims 3 70s 80s & 90s Stuff you will find it.

I hope this is helpfull to you.
fighterjoe22 Apr 10, 2013 @ 7:53pm 
Aside from there being a solution, maybe report the problem? It might actually be a glitch.
Reverend Apr 11, 2013 @ 12:53pm 
Originally posted by fighterjoe22:
Aside from there being a solution, maybe report the problem? It might actually be a glitch.


Hi,

From reading other forums I think it is safe to say this issue has been reported, this appears to have been an issue since 70s 80s and 90s has been released and is now also affecting University (which there is also a fix for). There are loads of posts in the forums so Steam and EA must be aware.

As there is a fix that is in the forums that works, I thought I would share it with the other people on here who were having the same problem as me. So they can get their games working too.

So by all means report the problem if you want. I wish it wasn't the case but I really do get the impression they don't really care all that much.

I hope you get it working :)

ladysmithly Apr 19, 2013 @ 3:21pm 
Yeah mine just randomly started working. I started up my game the other day and the icon was there on the start screen and all the content was there so I don't know what happened.
Showing 1-15 of 18 comments
< >
Per page: 15 30 50
Date Posted: Mar 20, 2013 @ 7:33pm
Posts: 18