Dead Space 2

Dead Space 2

Dead Space 2 > General Discussions > Topic Details
Morgan2990 Sep 4, 2012 @ 4:54pm
Problem with activation
When I try to start the game for the first time, the product activation window opens with a message saying "Connection Failed, please check your internet connection".

Posting this message feels really useless, since yesterday i read in the forums that a lot of people had the same issue, but got no answer from Valve o EA. And now, I don't know where are all these messages, probably gone...

It would be nice to be able to play what I paid for...

Thanks
< >
Showing 1-15 of 62 comments
i have the exact same problem, except that i've played it before, my harddrive failed and i had to get a new one and i redownloaded all my games and now this is happening... i thought it had been just me until i read this.
Fugue Sep 4, 2012 @ 11:28pm 
I feel for you!

I don't know if I can help but at least it will keep the thread active. I seem to remember having some trouble with this as well; is DS remembering your login and failing? Are you not seeing the login screen? Also, the obligatory make sure you try this first without a firewall. I know I had to set a rule for Kaspersky to get it to work. I'm sure you checked that but double and triple check that your 3rd party protection is disabled as well as the windows firewall. Unfortunately when they block things they do it silently.

In your registry what do you see in HKEY_CURRENT_USER\Software\EA Games\Dead Space 2\Online Data ?

The other thing you might want to do (if you are able to see the login screen) is try the login at EA's site. Just to double check the password. If you can't login and don't see the popup, perhaps try alt-tabbing around?

Anyway, haven't played in awhile so I don't totally remember... and I might be off here.
from what is happening to me (which looks like the same as him), you press play, and it downloads the activation manager, and does the connection thing, cant even get into the actual game. it might be my avast, i know it interfered before... i'll try disabling avast real quick and testing.
Last edited by Ocean Man (Clamboya); Sep 5, 2012 @ 10:15am
didn't work, steam/ea games better ♥♥♥♥ing fix this so i can play the game payed for... and i also haven't been able to play l4d2 servers because steam ♥♥♥♥ed that up too, if this♥♥♥♥♥♥keeps happening, i'm not sure i'll buy anything else from steam again. except dayz, i'll buy that no matter what.
Fugue Sep 5, 2012 @ 11:47am 
I knoooow your frustration. You just want to play a game and it's turning in to work. :o(

Hmmm yeah I don't remember *that* happening. So the windows firewall is off as well in the control panel? Also, do you see this product activation program listed in add/remove programs?
Finally the account you are trying to play as, is it an administrator or a normal user? Maybe the activation service requires administrator privileges to run?
i'll try checking add/remove programs, i'll turn off my firewall, and i'll turn off avast and try it again, it's definitely nothing about administrator privilidges because i used to be able to play the game.
Fugue Sep 5, 2012 @ 5:03pm 
Oh ok. I guess I'm wondering if their activation software has been updated (and perhaps *that* version, has the requirement). I'm honestly throwing stuff at the wall, but hopefully it will lead us somewhere. :o)

I did find this... it seems totally insane but more than one person says its fixed things for the activation:

Originally posted by AlwaysTrustwortyInternet:

Go to windows control panel
select nvidia control panel
select manage 3d settings
select global settings
prefered graphics processor:select high-performance Nvidia processor

You should be working after the next activation

I know it seems crazy, but when things are getting crazy you just gotta try everything.
Or, like Sir Arthur Conan Doyle said:

"When you have eliminated the impossible, whatever remains, however improbable, must be the truth."


Let me know if that works. I'm crossing my fingers for ya!
Fugue Sep 5, 2012 @ 5:10pm 
Ok apparently activation with EA is a fragile freaking' thing as there are other problems (besides the one I posted) can arise. Let me just post 'em here so there in one spot. See if this is meaningful to your setup:

Originally posted by http://forums.steampowered.com/forums/showthread.php?t=2892490:
Okay so at first launch (it says this in the manual too) DS2 tries to configure its video settings based on what it detects. So if your having an Activation Successful message, but the game fails to start, check any and all video related software. This is why people with Nvidia cards that have Optimus technology are having this problem.

HOWEVER my problem was due to Lucid Logix Virtu MVP software. The Virtu MVP software comes configured to run DS2 on HyperFormance mode and Virtual VSync. IF you have the Virtu MVP chip and the software, MAKE SURE YOU UNCHECK THE DEAD SPACE 2 checkbox so Virtu MVP doesn't screw with DS2.

If you disable it, DS2 will start right up.

Hope this helps someone! I found this out on my own as I couldn't find anywhere online that this problem could be due to Virtu MVP. It took my hours to figure out.
Last edited by Fugue; Sep 5, 2012 @ 5:19pm
Fugue Sep 5, 2012 @ 5:12pm 
And finally one from a community manager, Ursula, at EA. It's worth a shot. Not sure what the safe mode start accomplishes... but hey...:

Originally posted by Ursula:
Hi everyone,

There are three things you can try when you have problems launching the game:

1. Deactivate your anti-virus program

Sometimes the anti-virus is blocking the game from launching. You can check if an anti-virus is blocking it by turning off that program and launching the game again. AVG is a common one that will block the game, disabling or uninstalling it should allow the game to play. After the game does launch you should be able to re-start or re-install your anti-virus program and it should no longer interfere with the game.

2. Delete the game's Settings file

Double-click on the My Computer icon from your Windows desktop or Start menu.
Double-click on your Local Disk (usually C:).
Double-click Program Files.
Double-click on Electronic Arts.
Double-click on Dead Space.
Delete the file settings.txt.
Be sure to enable the option View hidden files and folders. Otherwise, you may not be able to find the settings.txt file. To do this or ensure your viewing setting is turned on, follow the steps below:
Double-click on the My Computer icon from your Windows desktop or Start Menu.
From the toolbar, select Tools and then select Folder Options.
Select the View tab and then select the option Show hidden files and folders, which is located in the Advanced Settings section.
Select Apply and then select OK at the bottom of the dialog box.
3. Start you computer in safe mode

If you do not have an anti-virus, or have confirmed it is not causing the issue, and if deleting the settings file did not help, starting your computer in safe mode (with networking) might solve the issue. To do that follow the steps below:

XP:
Bring up the run box (press Windows Key + R) and type in "msconfig".
Go to the Boot.INI Tab.
Check the "/SAFEBOOT" box.
Select "NETWORK" to the right of "/SAFEBOOT".
Press "OK".
It should prompt you to restart, do so. (if not, restart anyway)
Vista/7
Bring up the run box (press Windows Key + R) and type in "msconfig".
Go to the Boot Tab.
Check the "Safe boot" box.
Select "Network" underneath "Safe boot".
Press "Apply" then "OK".
It should prompt you to restart, do so. (if not, restart anyway)
Once your computer restarts it will be in safe mode, meaning minimal systems will be running. Your background will most likely appear black and other features may seem different, do not worry, this is normal. Once it has started up, launch Dead Space 2 again. The game will try to start, however this time you should get a message afterwards that the game could not start up, it crashed, or drivers are missing. Again, do not worry, this is what is supposed to happen.

You now need to restart your computer normally. To ensure that Safe mode was turned off simply undo the process from before:

XP:
Bring up the run box (press Windows Key + R) and type in "msconfig".
Go to the Boot.INI Tab.
Uncheck the "/SAFEBOOT" box.
Press "OK".
It should prompt you to restart, do so. (if not, restart anyway)
Vista/7
Bring up the run box (press Windows Key + R) and type in "msconfig".
Go to the Boot Tab.
Uncheck the "Safe boot" box.
Press "Apply" then "OK".
It should prompt you to restart, do so. (if not, restart anyway)
Once your computer comes back up, everything should be back to normal. Launch Dead Space 2 and it should launch and play normally.

Please let us know if one of these methods worked for you.

Thanks,
Ursula
Last edited by Fugue; Sep 5, 2012 @ 5:20pm
Thaldor Sep 6, 2012 @ 3:37am 
Figured mine out! Had to turn of lucid logic mvp for it to work! Funny thing being it used to work with it -.- I think an MVP or dead space udate must have done it
Fugue Sep 6, 2012 @ 11:03am 
Excellent! So the second method worked? Hey Dr. Hax have you had a chance to try any of 'em?
PosMatic Sep 6, 2012 @ 11:21am 
Originally posted by Fugue:
Oh ok. I guess I'm wondering if their activation software has been updated (and perhaps *that* version, has the requirement). I'm honestly throwing stuff at the wall, but hopefully it will lead us somewhere. :o)

I did find this... it seems totally insane but more than one person says its fixed things for the activation:

Originally posted by AlwaysTrustwortyInternet:

Go to windows control panel
select nvidia control panel
select manage 3d settings
select global settings
prefered graphics processor:select high-performance Nvidia processor

You should be working after the next activation

I know it seems crazy, but when things are getting crazy you just gotta try everything.
Or, like Sir Arthur Conan Doyle said:

"When you have eliminated the impossible, whatever remains, however improbable, must be the truth."


Let me know if that works. I'm crossing my fingers for ya!

Came here because of that problem...
Your solution worked! Thank you very much!
Thaldor Sep 6, 2012 @ 7:19pm 
My nvidia graphics card didn't give that option in the global settings (gtx560) I had to swtich off lucid logics virtu mvp completely to play it
Fugue Sep 6, 2012 @ 9:53pm 
@PosMatic: I'm glad! Time for some necromorph dismemberment!
@Thaldor: Good to know. So it sounds like the one you found matches the one described in post #8? So to sum up...

Post #7 is confirmed to work if you have nvidia control panel with the preferred graphics processor setting. Post#8 if you have Lucid Logix Virtu MVP software installed.

@Dr. Hax: What about you? I'm rooting for you buddy (as well as the original poster who hopefully when he's done cursing EA's name he comes back ;o))
Morgan2990 Sep 6, 2012 @ 10:15pm 
lol, I haven't tried today, I give it a shot and let you guys know... The thing is that the error i get is different, is a connection issue in the activation program...
< >
Showing 1-15 of 62 comments
Per page: 15 30 50

Dead Space 2 > General Discussions > Topic Details